libkf5kdegames-dev_18.04.0-1_i386.deb


Advertisement

Description

libkf5kdegames-dev - development files for the KDE games library

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libkf5kdegames-dev_18.04.0-1_i386.deb
Package name libkf5kdegames-dev
Package version 18.04.0
Package release 1
Package architecture i386
Package type deb
Category devel::library libdevel role::devel-lib
Homepage http://games.kde.org/
License -
Maintainer Debian/Kubuntu Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
Download size 85.80 KB
Installed size 448.00 KB
This package contains development files for building software that uses
libraries from the KDE games module.
This package is part of the KDE games module.

Alternatives

Package Version Architecture Repository
libkf5kdegames-dev_18.04.0-1_amd64.deb 18.04.0 amd64 Debian Main
libkf5kdegames-dev - - -

Requires

Name Value
libkf5completion-dev -
libkf5declarative-dev -
libkf5kdegames7 = 4:18.04.0-1
libkf5kdegamesprivate1 = 4:18.04.0-1
qtbase5-dev >= 5.4

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libkf5kdegames-dev_18.04.0-1_i386.deb
Source Package libkdegames

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libkf5kdegames-dev deb package:
    # sudo apt-get install libkf5kdegames-dev

Files

Path
/usr/include/KF5/KF5KDEGames/kdegames_version.h
/usr/include/KF5/KF5KDEGames/kgameclock.h
/usr/include/KF5/KF5KDEGames/kgamepopupitem.h
/usr/include/KF5/KF5KDEGames/kgamerendereditem.h
/usr/include/KF5/KF5KDEGames/kgamerenderedobjectitem.h
/usr/include/KF5/KF5KDEGames/kgamerenderer.h
/usr/include/KF5/KF5KDEGames/kgamerendererclient.h
/usr/include/KF5/KF5KDEGames/kgaudioscene.h
/usr/include/KF5/KF5KDEGames/kgdeclarativeview.h
/usr/include/KF5/KF5KDEGames/kgdifficulty.h
/usr/include/KF5/KF5KDEGames/kgsound.h
/usr/include/KF5/KF5KDEGames/kgtheme.h
/usr/include/KF5/KF5KDEGames/kgthemeprovider.h
/usr/include/KF5/KF5KDEGames/kgthemeselector.h
/usr/include/KF5/KF5KDEGames/kstandardgameaction.h
/usr/include/KF5/KF5KDEGames/libkdegames_capabilities.h
/usr/include/KF5/KF5KDEGames/libkdegames_export.h
/usr/include/KF5/KF5KDEGames/KDE/KGameClock
/usr/include/KF5/KF5KDEGames/KDE/KGamePopupItem
/usr/include/KF5/KF5KDEGames/KDE/KGameRenderedItem
/usr/include/KF5/KF5KDEGames/KDE/KGameRenderedObjectItem
/usr/include/KF5/KF5KDEGames/KDE/KGameRenderer
/usr/include/KF5/KF5KDEGames/KDE/KGameRendererClient
/usr/include/KF5/KF5KDEGames/KDE/KHighscore
/usr/include/KF5/KF5KDEGames/KDE/KScoreDialog
/usr/include/KF5/KF5KDEGames/KDE/KStandardGameAction
/usr/include/KF5/KF5KDEGames/KDE/KgAudioScene
/usr/include/KF5/KF5KDEGames/KDE/KgDeclarativeView
/usr/include/KF5/KF5KDEGames/KDE/KgDifficulty
/usr/include/KF5/KF5KDEGames/KDE/KgSound
/usr/include/KF5/KF5KDEGames/KDE/KgTheme
/usr/include/KF5/KF5KDEGames/KDE/KgThemeProvider
/usr/include/KF5/KF5KDEGames/KDE/KgThemeSelector
/usr/include/KF5/KF5KDEGames/highscore/khighscore.h
/usr/include/KF5/KF5KDEGames/highscore/kscoredialog.h
/usr/include/KF5/KF5KDEGames/libkdegamesprivate/kchatbase.h
/usr/include/KF5/KF5KDEGames/libkdegamesprivate/kchatbaseitemdelegate.h
/usr/include/KF5/KF5KDEGames/libkdegamesprivate/kchatbasemodel.h
/usr/include/KF5/KF5KDEGames/libkdegamesprivate/kgamecanvas.h
/usr/include/KF5/KF5KDEGames/libkdegamesprivate/kgamedifficulty.h
/usr/include/KF5/KF5KDEGames/libkdegamesprivate/kgamesvgdocument.h
/usr/include/KF5/KF5KDEGames/libkdegamesprivate/kgametheme.h
/usr/include/KF5/KF5KDEGames/libkdegamesprivate/kgamethemeselector.h
/usr/include/KF5/KF5KDEGames/libkdegamesprivate/libkdegamesprivate_export.h
/usr/include/KF5/KF5KDEGames/libkdegamesprivate/kgame/kgame.h
/usr/include/KF5/KF5KDEGames/libkdegamesprivate/kgame/kgamechat.h
/usr/include/KF5/KF5KDEGames/libkdegamesprivate/kgame/kgameerror.h
/usr/include/KF5/KF5KDEGames/libkdegamesprivate/kgame/kgameio.h
/usr/include/KF5/KF5KDEGames/libkdegamesprivate/kgame/kgamemessage.h
/usr/include/KF5/KF5KDEGames/libkdegamesprivate/kgame/kgamenetwork.h
/usr/include/KF5/KF5KDEGames/libkdegamesprivate/kgame/kgameproperty.h
/usr/include/KF5/KF5KDEGames/libkdegamesprivate/kgame/kgamepropertyhandler.h
/usr/include/KF5/KF5KDEGames/libkdegamesprivate/kgame/kgamesequence.h
/usr/include/KF5/KF5KDEGames/libkdegamesprivate/kgame/kgameversion.h
/usr/include/KF5/KF5KDEGames/libkdegamesprivate/kgame/kmessageclient.h
/usr/include/KF5/KF5KDEGames/libkdegamesprivate/kgame/kmessageio.h
/usr/include/KF5/KF5KDEGames/libkdegamesprivate/kgame/kmessageserver.h
/usr/include/KF5/KF5KDEGames/libkdegamesprivate/kgame/kplayer.h
/usr/lib/i386-linux-gnu/libKF5KDEGames.so
/usr/lib/i386-linux-gnu/libKF5KDEGamesPrivate.so
/usr/lib/i386-linux-gnu/cmake/KF5KDEGames/KF5KDEGamesConfig.cmake
/usr/lib/i386-linux-gnu/cmake/KF5KDEGames/KF5KDEGamesConfigVersion.cmake
/usr/lib/i386-linux-gnu/cmake/KF5KDEGames/KF5KDEGamesLibraryDepends-debian.cmake
/usr/lib/i386-linux-gnu/cmake/KF5KDEGames/KF5KDEGamesLibraryDepends.cmake
/usr/share/doc/libkf5kdegames-dev/changelog.Debian.gz
/usr/share/doc/libkf5kdegames-dev/copyright

Changelog

2018-05-08 - Pino Toscano <pino@debian.org>
libkdegames (4:18.04.0-1) unstable; urgency=medium
* Team upload.
* New upstream release.
* Switch Vcs-* fields to salsa.debian.org.
* Bump the debhelper compatibility to 11:
- bump the debhelper build dependency to 11~
- bump compat to 11
* Update symbols files.
* Bump Standards-Version to 4.1.4, no changes required.
* Use https for Format in copyright.
* Run the test suite at build time:
- add the xauth, and xvfb build dependencies
- run dh_auto_test using xvfb-run
* Remove the unused & no more useful autopkgtest stuff.
* Do not install the upstream README file as documentation in
kdegames-card-data-kf5, as it is not useful.
2018-02-20 - Pino Toscano <pino@debian.org>
libkdegames (4:17.12.2-1) unstable; urgency=medium
* Team upload.
* New upstream release.
* Update symbols files.
* Tighten the inter-library dependencies.
* Bump Standards-Version to 4.1.3, no changes required.
2017-11-18 - Pino Toscano <pino@debian.org>
libkdegames (4:17.08.3-1) unstable; urgency=medium
* Team upload.
[ Maximiliano Curia ]
* New upstream release (17.08.0)
* Bump Standards-Version to 4.1.0.
* Update upstream metadata
* Update uploaders list as requested by MIA team (Closes: #879394)
[ Pino Toscano ]
* New upstream release.
* Adjust l10npkgs_firstversion_ok to the version where kde-l10n will drop
translations.
* Bump Standards-Version to 4.1.1, no changes required.
* Remove unused kio-dev, and libkf5kdelibs4support-dev build dependencies.
* Simplify watch file, and switch it to https.
2017-08-17 - Neon CI <neon@kde.org>
libkdegames (4:17.08.0-0neon) xenial; urgency=medium
* New release
2017-07-12 - Neon CI <neon@kde.org>
libkdegames (4:17.04.3-0neon) xenial; urgency=medium
* New release
2017-06-07 - Neon CI <neon@kde.org>
libkdegames (4:17.04.2-0neon) xenial; urgency=medium
* New release
2017-05-11 - Neon CI <neon@kde.org>
libkdegames (4:17.04.1-0neon) xenial; urgency=medium
* New release
2017-04-19 - Neon CI <neon@kde.org>
libkdegames (4:17.04.0-0neon) xenial; urgency=medium
* New release
2017-03-08 - Neon CI <neon@kde.org>
libkdegames (4:16.12.3-0neon) xenial; urgency=medium
* New release
2017-02-08 - Neon CI <neon@kde.org>
libkdegames (4:16.12.2-0neon) xenial; urgency=medium
* New release

See Also

Package Description
libkf5kdegames7_18.04.0-1_i386.deb shared library for KDE games
libkf5kdegamesprivate1_18.04.0-1_i386.deb private part of shared library for KDE games
libkf5kdelibs4support-data_5.54.0-1_all.deb Porting aid from KDELibs4
libkf5kdelibs4support-dev_5.54.0-1_i386.deb development files for kde4support
libkf5kdelibs4support5-bin_5.54.0-1_i386.deb Porting aid from KDELibs4
libkf5kdelibs4support5_5.54.0-1_i386.deb Porting aid from KDELibs4
libkf5kdepimdbusinterfaces-dev_18.08.3-2_i386.deb KDE PIM D-Bus interfaces library, devel files
libkf5kdepimdbusinterfaces5_18.08.3-2_i386.deb KDE PIM D-Bus interfaces library
libkf5kexiv2-15.0.0_17.08.3-1_i386.deb Qt like interface for the libexiv2 library
libkf5kexiv2-dev_17.08.3-1_i386.deb Qt-like interface for the libexiv2 library -- development files
libkf5kgeomap-data_17.08.3-1_all.deb World-Map Library interface for KDE - data files
libkf5kgeomap-dev_17.08.3-1_i386.deb World-Map Library interface for KDE - development files
libkf5kgeomap10.0.0_17.08.3-1_i386.deb World-Map Library interface for KDE - shared library
libkf5khtml-bin_5.54.0-1_i386.deb HTML widget and component
libkf5khtml-data_5.54.0-1_all.deb HTML widget and component
Advertisement
Advertisement