libkf5completion-dev_5.54.0-1_i386.deb


Advertisement

Description

libkf5completion-dev - development files for kcompletion

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libkf5completion-dev_5.54.0-1_i386.deb
Package name libkf5completion-dev
Package version 5.54.0
Package release 1
Package architecture i386
Package type deb
Category devel::library libdevel role::devel-lib
Homepage https://projects.kde.org/projects/frameworks/kcompletion
License -
Maintainer Debian/Kubuntu Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
Download size 29.20 KB
Installed size 153.00 KB
KCompletion provides widgets with advanced completion support as well as a
lower-level completion class which can be used with your own widgets.
Contains development files for kcompletion.

Alternatives

Package Version Architecture Repository
libkf5completion-dev_5.54.0-1_amd64.deb 5.54.0 amd64 Debian Main
libkf5completion-dev - - -

Requires

Name Value
libkf5completion5 = 5.54.0-1
libkf5config-dev >= 5.54.0~
libkf5widgetsaddons-dev >= 5.54.0~

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libkf5completion-dev_5.54.0-1_i386.deb
Source Package kcompletion

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libkf5completion-dev deb package:
    # sudo apt-get install libkf5completion-dev

Files

Path
/usr/include/KF5/kcompletion_version.h
/usr/include/KF5/KCompletion/KComboBox
/usr/include/KF5/KCompletion/KCompletion
/usr/include/KF5/KCompletion/KCompletionBase
/usr/include/KF5/KCompletion/KCompletionBox
/usr/include/KF5/KCompletion/KCompletionMatches
/usr/include/KF5/KCompletion/KHistoryComboBox
/usr/include/KF5/KCompletion/KLineEdit
/usr/include/KF5/KCompletion/KPixmapProvider
/usr/include/KF5/KCompletion/KSortableList
/usr/include/KF5/KCompletion/kcombobox.h
/usr/include/KF5/KCompletion/kcompletion.h
/usr/include/KF5/KCompletion/kcompletion_export.h
/usr/include/KF5/KCompletion/kcompletionbase.h
/usr/include/KF5/KCompletion/kcompletionbox.h
/usr/include/KF5/KCompletion/kcompletionmatches.h
/usr/include/KF5/KCompletion/khistorycombobox.h
/usr/include/KF5/KCompletion/klineedit.h
/usr/include/KF5/KCompletion/kpixmapprovider.h
/usr/include/KF5/KCompletion/ksortablelist.h
/usr/lib/i386-linux-gnu/libKF5Completion.so
/usr/lib/i386-linux-gnu/cmake/KF5Completion/KF5CompletionConfig.cmake
/usr/lib/i386-linux-gnu/cmake/KF5Completion/KF5CompletionConfigVersion.cmake
/usr/lib/i386-linux-gnu/cmake/KF5Completion/KF5CompletionQchTargets.cmake
/usr/lib/i386-linux-gnu/cmake/KF5Completion/KF5CompletionTargets-debian.cmake
/usr/lib/i386-linux-gnu/cmake/KF5Completion/KF5CompletionTargets.cmake
/usr/lib/i386-linux-gnu/qt5/mkspecs/modules/qt_KCompletion.pri
/usr/share/doc/libkf5completion-dev/changelog.Debian.gz
/usr/share/doc/libkf5completion-dev/copyright

Changelog

2019-01-17 - Maximiliano Curia <maxy@debian.org>
kcompletion (5.54.0-1) unstable; urgency=medium
* New upstream release (5.52.0).
* Update build-deps and deps with the info from cmake
* New upstream release (5.53.0).
* Update build-deps and deps with the info from cmake
* New upstream release (5.54.0).
* Update build-deps and deps with the info from cmake
* Bump group breaks (5.54)
* Release to unstable
2018-11-07 - Maximiliano Curia <maxy@debian.org>
kcompletion (5.51.0-1) unstable; urgency=medium
* New upstream release (5.50.0).
* Update build-deps and deps with the info from cmake
* Bump group breaks (5.50)
* New upstream release (5.51.0).
* Update build-deps and deps with the info from cmake
* Bump group breaks (5.51)
* Release to unstable
2018-08-17 - Maximiliano Curia <maxy@debian.org>
kcompletion (5.49.0-1) unstable; urgency=medium
* New upstream release (5.48.0).
* Update build-deps and deps with the info from cmake
* New upstream release (5.49.0).
* Update build-deps and deps with the info from cmake
* Bump group breaks (5.49)
* Release to unstable
2018-06-15 - Maximiliano Curia <maxy@debian.org>
kcompletion (5.47.0-1) unstable; urgency=medium
* New upstream release (5.47.0).
* Update build-deps and deps with the info from cmake
* Bump group breaks (5.47)
* Release to unstable
2018-05-17 - Maximiliano Curia <maxy@debian.org>
kcompletion (5.46.0-1) unstable; urgency=medium
* New upstream release (5.46.0).
* Update build-deps and deps with the info from cmake
* Bump Standards-Version to 4.1.4.
* Use https for the debian/copyright
* Bump group breaks (5.46)
* Release to unstable
2018-05-05 - Maximiliano Curia <maxy@debian.org>
kcompletion (5.45.0-1) unstable; urgency=medium
* New upstream release (5.45.0).
* Update build-deps and deps with the info from cmake
* Bump group breaks (5.45)
* Release to unstable
2018-03-21 - Maximiliano Curia <maxy@debian.org>
kcompletion (5.44.0-1) sid; urgency=medium
* New upstream release (5.44.0).
* Update build-deps and deps with the info from cmake
* Bump group breaks (5.44)
* Release to sid
2018-02-26 - Maximiliano Curia <maxy@debian.org>
kcompletion (5.43.0-1) experimental; urgency=medium
* Use the salsa canonical urls
* New upstream release (5.43.0).
* Update build-deps and deps with the info from cmake
* Bump group breaks (5.43)
* Release to experimental
2018-02-12 - Maximiliano Curia <maxy@debian.org>
kcompletion (5.42.0-4) sid; urgency=medium
* New revision
* Fix typo
* Release to sid
2018-02-12 - Maximiliano Curia <maxy@debian.org>
kcompletion (5.42.0-3) sid; urgency=medium
[ Maximiliano Curia ]
* New revision
* Release to sid
[ Adrian Bunk ]
* Fix FTBFS on architectures where Qt uses OpenGL ES (Closes: 890122)

See Also

Package Description
libkf5completion-doc_5.54.0-1_all.deb Widgets with advanced auto-completion features (documentation)
libkf5completion5_5.54.0-1_i386.deb Widgets with advanced auto-completion features
libkf5config-bin_5.54.0-1+deb10u1_i386.deb configuration settings framework for Qt
libkf5config-data_5.54.0-1+deb10u1_all.deb configuration settings framework for Qt
libkf5config-dev-bin_5.54.0-1+deb10u1_i386.deb configuration settings framework for Qt -- binary package
libkf5config-dev_5.54.0-1+deb10u1_i386.deb configuration settings framework for Qt
libkf5config-doc_5.54.0-1+deb10u1_all.deb configuration settings framework for Qt (documentation)
libkf5configcore5_5.54.0-1+deb10u1_i386.deb configuration settings framework for Qt
libkf5configgui5_5.54.0-1+deb10u1_i386.deb configuration settings framework for Qt
libkf5configwidgets-data_5.54.0-1_all.deb Extra widgets for easier configuration support
libkf5configwidgets-dev_5.54.0-1_i386.deb development files for kconfigwidgets
libkf5configwidgets-doc_5.54.0-1_all.deb Extra widgets for easier configuration support (documentation)
libkf5configwidgets5_5.54.0-1_i386.deb Extra widgets for easier configuration support
libkf5contacteditor-dev_18.08.3-1_i386.deb Akonadi contacts editor library - development files
libkf5contacteditor5_18.08.3-1_i386.deb Akonadi contact editor library
Advertisement
Advertisement