libkf5akonadiwidgets5abi1_18.08.3-5_i386.deb


Advertisement

Description

libkf5akonadiwidgets5abi1 - Akonadi widgets library

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libkf5akonadiwidgets5abi1_18.08.3-5_i386.deb
Package name libkf5akonadiwidgets5abi1
Package version 18.08.3
Package release 5
Package architecture i386
Package type deb
Category libs role::shared-lib
Homepage http://pim.kde.org/akonadi
License -
Maintainer Debian/Kubuntu Qt/KDE Maintainers <debian-qt-kde@lists.debian.org>
Download size 258.96 KB
Installed size 867.00 KB
This library contains standard widgets for the Akonadi PIM data server.
This package is part of the KDE Development Platform PIM libraries module.

Alternatives

Package Version Architecture Repository
libkf5akonadiwidgets5abi1_18.08.3-5_amd64.deb 18.08.3 amd64 Debian Main
libkf5akonadiwidgets5abi1 - - -

Requires

Name Value
libc6 >= 2.4
libgcc1 >= 1:3.0
libkf5akonadicore5abi2 = 4:18.08.3-5
libkf5akonadiprivate5abi2 = 4:18.08.3-5
libkf5configcore5 >= 4.97.0
libkf5configgui5 >= 4.97.0
libkf5configwidgets5 >= 4.96.0
libkf5coreaddons5 >= 4.97.0
libkf5dbusaddons5 >= 4.97.0
libkf5i18n5 >= 4.97.0
libkf5iconthemes5 >= 4.96.0
libkf5itemmodels5 >= 4.96.0
libkf5itemviews5 >= 4.96.0
libkf5widgetsaddons5 >= 4.96.0
libkf5windowsystem5 >= 4.96.0
libkf5xmlgui5 >= 4.96.0
libqt5core5a >= 5.11.0~rc1
libqt5dbus5 >= 5.9.0~
libqt5gui5 >= 5.9.0~
libqt5sql5 >= 5.9.0~
libqt5widgets5 >= 5.11.0~rc1
libstdc++6 >= 5

Replaces

Name Value
libkf5akonadicore5 << 4:15.07.90+git20150817.0936

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libkf5akonadiwidgets5abi1_18.08.3-5_i386.deb
Source Package akonadi

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libkf5akonadiwidgets5abi1 deb package:
    # sudo apt-get install libkf5akonadiwidgets5abi1

Files

Path
/usr/lib/i386-linux-gnu/libKF5AkonadiWidgets.so.5.9.3.abi1
/usr/lib/i386-linux-gnu/libKF5AkonadiWidgets.so.5abi1
/usr/share/doc/libkf5akonadiwidgets5abi1/NEWS.Debian.gz
/usr/share/doc/libkf5akonadiwidgets5abi1/changelog.Debian.gz
/usr/share/doc/libkf5akonadiwidgets5abi1/changelog.gz
/usr/share/doc/libkf5akonadiwidgets5abi1/copyright

Changelog

2019-04-29 - Sandro Knauß <hefee@debian.org>
akonadi (4:18.08.3-5) unstable; urgency=medium
* Team upload.
[ Sandro Knauß ]
* Switch back to use default-mysql-server-core instead of default-
mysql-server as dependency (see #910902).
2019-02-14 - Sandro Knauß <hefee@debian.org>
akonadi (4:18.08.3-4) unstable; urgency=medium
* Team upload.
[ Sandro Knauß ]
* Update symbols from buildds for 4:18.08.3
2019-02-08 - Sandro Knauß <hefee@debian.org>
akonadi (4:18.08.3-3) unstable; urgency=medium
* Team upload.
[ Sandro Knauß ]
* Add Build-Depends-package field in symbolfiles.
* Add patch Call-QSqlQuery-finish-on-all-SELECT-queries-when-don
(Closes: #921535).
2019-02-06 - Sandro Knauß <hefee@debian.org>
akonadi (4:18.08.3-2) unstable; urgency=medium
* Team upload.
[ Sandro Knauß ]
* Rename {kubuntu_,}disable_secure_file_priv_check.diff.
* Update symbols from buildds for 4:18.08.3
[ Alf Gaida ]
* Replaced wrapper mysqld-akonadi with link mysqld -> mysqld-akonadi
(Closes: #921389)
* Replaced dependency for akonadi-backend-mysql:
- default-mysql-server-core -> default-mysql-server
- virtual-mysql-server-core -> virtual-mysql-server
2019-02-04 - Sandro Knauß <hefee@debian.org>
akonadi (4:18.08.3-1) unstable; urgency=medium
* Team upload.
[ Sandro Knauß ]
* New upstream release (18.08.3).
* Bump Standards-Version to 4.3.0 (No changes needed).
* Removed acc autopkgtest.
2018-10-02 - Sandro Knauß <hefee@debian.org>
akonadi (4:18.08.1-1) unstable; urgency=medium
* Team upload.
[ Sandro Knauß ]
* Bump Standards-Version to 4.2.1 (No changes needed).
* Update symbols from buildds for 4:18.07.90
* Remove armel specific symbols, that are not exposed anymore.
* Follow stable releases in KDE again..
* New upstream release (18.08.1).
2018-08-16 - Sandro Knauß <hefee@debian.org>
akonadi (4:18.07.90-1) experimental; urgency=medium
* Team upload.
[ Sandro Knauß ]
* New upstream release (18.07.90).
* Update build-deps and deps with the info from cmake
* Update copyright file for new upstream.
* Bump DebianAbi for libkf5akonadicore5 because of breakage to 2.
* Bump DebianAbi for libkf5akonadiprivate5 because of breakage to 2.
* Update symbols for libkf5akonadiagentbase5 for 18.07.90.
* Remove patch that got upstream.
* Update patch hunks.
2018-07-31 - Pino Toscano <pino@debian.org>
akonadi (4:17.12.3-3) unstable; urgency=medium
* Team upload.
* Backport upstream commit 310b6a26f58814568245c781c2136504d1a6f338 to fix
build with Qt 5.11; patch
upstream_Fix-build-with-Qt-5.11-missing-QAbstractItemView.patch.
* Remove empty line at the end of changelog.
* Bump Standards-Version to 4.1.5, no changes required.
* Remove the 'testsuite' autopkgtest:
- it runs the test suite from the build dir, not using the installed
packages (hence misusing what autopkgtest is for)
- it always failed (so it is not useful to even catch regressions), and
nobody bothered to fix it
- hence, pass -DBUILD_TESTING=OFF to cmake to disable the build of the
tests, and pass -DBUILD_TOOLS=ON to explicitly request the test tools
(which are installed)
* Update symbols files for GCC 8, and the loss of test-only symbols.
* Do not append -fvisibility=hidden -fvisibility-inlines-hidden to the
CFLAGS, and CXXFLAGS anymore, since they are already there since at least
the switch to KF5/ECM.
2018-04-05 - Sandro Knauß <hefee@debian.org>
akonadi (4:17.12.3-2) unstable; urgency=medium
* Team upload.
[ Sandro Knauß ]
* Adds Breaks/Replaces against kapptemplate (Closes: #894913)
2018-03-31 - Sandro Knauß <hefee@debian.org>
akonadi (4:17.12.3-1) unstable; urgency=medium
* Team upload.
[ Sandro Knauß ]
* Add kdevelop templates to libkf5akonadi-dev.
* New upstream release (17.12.3).
* Update symbols from buildds for 4:17.12.2
* bump epoch in symbolsfiles to match version of the package.
* use secure copyright format uri.
* small fixes in copyright file.
* Update package descriptions.

See Also

Package Description
libkf5akonadixml5_18.08.3-5_i386.deb Akonadi XML helper library
libkf5alarmcalendar-data_18.08.3-2_all.deb library for handling kalarm calendar data - arch independent files
libkf5alarmcalendar-dev_18.08.3-2_i386.deb library for handling kalarm calendar data - development files
libkf5alarmcalendar5abi1_18.08.3-2_i386.deb library for handling kalarm calendar data
libkf5archive-dev_5.54.0-1_i386.deb development files for karchive
libkf5archive-doc_5.54.0-1_all.deb Qt 5 addon providing access to numerous types of archives (documentation)
libkf5archive5_5.54.0-1_i386.deb Qt 5 addon providing access to numerous types of archives
libkf5attica-dev_5.54.0-1_i386.deb development files for libkf5attica5
libkf5attica-doc_5.54.0-1_all.deb Qt library that implements the Open Collaboration Services API (documentation)
libkf5attica5_5.54.0-1_i386.deb Qt library that implements the Open Collaboration Services API
libkf5auth-data_5.54.0-2_all.deb Abstraction to system policy and authentication features
libkf5auth-dev-bin_5.54.0-2_i386.deb Abstraction to system policy and authentication features
libkf5auth-dev_5.54.0-2_i386.deb Abstraction to system policy and authentication features
libkf5auth-doc_5.54.0-2_all.deb Abstraction to system policy and authentication features (documentation)
libkf5auth5_5.54.0-2_i386.deb Abstraction to system policy and authentication features
Advertisement
Advertisement