libjs-sphinxdoc_1.8.4-1_all.deb


Advertisement

Description

libjs-sphinxdoc - JavaScript support for Sphinx documentation

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libjs-sphinxdoc_1.8.4-1_all.deb
Package name libjs-sphinxdoc
Package version 1.8.4
Package release 1
Package architecture all
Package type deb
Category implemented-in::ecmascript javascript
Homepage http://sphinx-doc.org/
License -
Maintainer Debian Python Modules Team <python-modules-team@lists.alioth.debian.org>
Download size 93.62 KB
Installed size 141.00 KB
Sphinx is a tool for producing documentation for Python projects, using
reStructuredText as markup language.
This package provides JavaScript code for documentation generated by Sphinx.

Alternatives

Package Version Architecture Repository
libjs-sphinxdoc_1.8.4-1_all.deb 1.8.4 all Debian Main
libjs-sphinxdoc - - -

Requires

Name Value
libjs-jquery >= 1.11.1
libjs-underscore >= 1.3.1

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libjs-sphinxdoc_1.8.4-1_all.deb
Source Package sphinx

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libjs-sphinxdoc deb package:
    # sudo apt-get install libjs-sphinxdoc

Files

Path
/usr/share/doc/libjs-sphinxdoc/changelog.Debian.gz
/usr/share/doc/libjs-sphinxdoc/changelog.gz
/usr/share/doc/libjs-sphinxdoc/copyright
/usr/share/javascript/sphinxdoc/index
/usr/share/javascript/sphinxdoc/1.0/css3-mediaqueries.js
/usr/share/javascript/sphinxdoc/1.0/doctools.js
/usr/share/javascript/sphinxdoc/1.0/jquery.js
/usr/share/javascript/sphinxdoc/1.0/searchtools.js
/usr/share/javascript/sphinxdoc/1.0/sidebar.js
/usr/share/javascript/sphinxdoc/1.0/theme_extras.js
/usr/share/javascript/sphinxdoc/1.0/underscore.js

Changelog

2019-02-16 - Dmitry Shachnev <mitya57@debian.org>
sphinx (1.8.4-1) unstable; urgency=medium
* New upstream release.
* Ensure the graphviz filenames are reproducible (closes: #921513).
* Bump year in debian/copyright.
2019-01-26 - Dmitry Shachnev <mitya57@debian.org>
sphinx (1.8.3-2) unstable; urgency=medium
* Bump Standards-Version to 4.3.0, no changes needed.
* Upload to unstable.
2019-01-09 - Dmitry Shachnev <mitya57@debian.org>
sphinx (1.8.3-1) experimental; urgency=medium
* New upstream release.
* Drop language_data.js.diff, applied upstream.
* Refresh skip_tests_network.diff.
* Add a patch to make test_get_module_source() pass on Python 2.
2018-11-11 - Dmitry Shachnev <mitya57@debian.org>
sphinx (1.8.2-1) experimental; urgency=medium
* New upstream release.
* Drop mathjax_on_demand.diff, applied upstream.
* Backport upstream patch to make search work with custom templates, by
moving language data into a separate JS file (language_data.js.diff).
* Adapt dh_sphinxdoc for the introduction of language_data.js.
* Override Lintian false positive warning about todo.py extension.
2018-10-29 - Dmitry Shachnev <mitya57@debian.org>
sphinx (1.8.1-1) experimental; urgency=medium
* New upstream release.
* Drop patches, applied upstream:
- 0005-Fix-testsuite-to-not-rely-on-return-types.patch
- 0007-Fix-spelling-error-in-manpage.patch
- 0008-Call-object_description-recursively-for-dict-keys-an.patch
- 0009-Ensure-the-set-object-description-is-reproducible.patch
* Refresh and rebase the other patches.
* Drop numbers from the remaining patches, use consistent naming.
* Do not copy .doctrees/ during docs build, it is now in source tree.
* Make test_math_compat pass with Python 2, by adding sphinx.ext.mathbase
toplevel import (python2_tests_import_hack.diff).
* Add a patch to load MathJax.js only on demand (mathjax_on_demand.diff).
* Update debian/clean to clean .doctrees, .pytest_cache and tests/build.
* dh_sphinxdoc:
- Remove mention of “non-English searchtools.js”, all language-specific
stuff is now in documentation_options.js.
- Warn about missing SEARCH_LANGUAGE_STOP_WORDS.
* Update numbers in debian/jstest/run-tests for the new release.
* Remove obsolete section from debian/copyright.
2018-09-06 - Dmitry Shachnev <mitya57@debian.org>
sphinx (1.7.9-1) unstable; urgency=medium
* New upstream bugfix release.
* Drop 0012-Make-generated-texinfo-files-reproducible-by-sorting.patch,
applied upstream.
2018-08-31 - Dmitry Shachnev <mitya57@debian.org>
sphinx (1.7.8-1) unstable; urgency=medium
* New upstream bugfix release.
* Refresh 0009-Ensure-the-set-object-description-is-reproducible.patch.
* Make generated texinfo files reproducible (closes: #907352).
* Bump Standards-Version to 4.2.1, no changes needed.
2018-08-25 - Dmitry Shachnev <mitya57@debian.org>
sphinx (1.7.7-1) unstable; urgency=medium
* New upstream bugfix release.
* Refresh patches for the new release.
* Directly use PyStemmer for non-English search (without the wrapper).
* Bump Standards-Version to 4.2.0.
* Pass --verbose to pytest, as now required by Policy §4.9.
2018-07-08 - Dmitry Shachnev <mitya57@debian.org>
sphinx (1.7.6-1) unstable; urgency=medium
* New upstream bugfix release.
* Drop patches, applied upstream:
- 0011-Fix-5022-latex-crashed-with-docutils-package-provide.patch
- 0012-Fix-5048-crashed-with-numbered-toctree.patch
* Refresh other patches.
* Run “wrap-and-sort”.
* Recommend make (closes: #903260).
* Add back PYTHONWARNINGS=d, the pytest warnings have been fixed.
* Add a patch to remove use of external image from img.shields.io in
the documentation template.
* Bump Standards-Version to 4.1.5, no changes needed.
* Rely on dh_python{2,3} for generating most of package dependencies.
2018-07-05 - Dmitry Shachnev <mitya57@debian.org>
sphinx (1.7.5-6) unstable; urgency=medium
* Export LC_ALL=C.UTF-8 to make the build pass on the buildds.

See Also

Package Description
libjs-spin.js_1.2.8+dfsg2-1_all.deb animated CSS3 loading spinner
libjs-sprintf-js_1.1.2+ds1-1_all.deb JavaScript sprintf implementation
libjs-stringmap_0.2.2+20130926-3_all.deb fast and robust stringmap (JavaScript lib)
libjs-stringset_0.2.1+20130926-3_all.deb fast and robust stringset (JavaScript lib)
libjs-strophe_1.2.14+dfsg-4_all.deb Library for writing XMPP clients
libjs-term.js_0.0.7-1_all.deb full xterm clone written in javascript
libjs-text-encoding_0.7.0-1_all.deb Polyfill for the Encoding Living Standard's API (JavaScript lib)
libjs-three_80+dfsg2-2_all.deb lightweight 3D graphics library
libjs-tinycon_0.6.5+ds-1_all.deb Manipulate the favicon
libjs-traverse_0.6.6-1.1_all.deb recursively traverse objects in Javascript
libjs-tv4_1.2.7+dfsg1-2_all.deb tiny validator for JSON schema v4
libjs-twitter-bootstrap-datepicker_1.3.1+dfsg1-4_all.deb add datepicker picker to field or to any other element
libjs-twitter-bootstrap-wizard_1.0.0+dfsg1-2_all.deb wizard using a formatted tabbable structure
libjs-typeahead.js_0.11.1~dfsg1-3_all.deb fast and fully-featured autocomplete library
libjs-typedarray-to-buffer_3.0.3-3_all.deb JavaScript utility converting TypedArray to buffer without copy
Advertisement
Advertisement