libjs-less_1.6.3~dfsg-3_all.deb


Advertisement

Description

libjs-less - LESS CSS meta-language - Javascript library

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libjs-less_1.6.3~dfsg-3_all.deb
Package name libjs-less
Package version 1.6.3~dfsg
Package release 3
Package architecture all
Package type deb
Category javascript
Homepage http://lesscss.org/
License -
Maintainer Debian Javascript Maintainers <pkg-javascript-devel@lists.alioth.debian.org>
Download size 143.68 KB
Installed size 441.00 KB
LESS is a meta-language on top of CSS that’s used to describe the style
of a document cleanly and structurally, with more power than flat CSS
allows.  LESS both provides a simpler, more elegant syntax for CSS and
implements various features that are useful for creating manageable
stylesheets.
less.js is the reference implementation of LESS, written in JavaScript.
This package contains the less.js library usable for dynamic parsing of
LESS in a web browser.

Alternatives

Package Version Architecture Repository
libjs-less_1.6.3~dfsg-3_all.deb 1.6.3~dfsg all Debian Main
libjs-less - - -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libjs-less_1.6.3~dfsg-3_all.deb
Source Package less.js

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libjs-less deb package:
    # sudo apt-get install libjs-less

Files

Path
/usr/share/doc/libjs-less/README.md.gz
/usr/share/doc/libjs-less/changelog.Debian.gz
/usr/share/doc/libjs-less/changelog.gz
/usr/share/doc/libjs-less/copyright
/usr/share/javascript/less/less.js
/usr/share/javascript/less/less.min.js
/usr/share/javascript/less/less.min.js.br
/usr/share/javascript/less/less.min.js.gz

Changelog

2019-01-25 - Jonas Smedegaard <dr@jones.dk>
less.js (1.6.3~dfsg-3) unstable; urgency=medium
* Simplify rules.
Stop build-depend on cdbs.
* Wrap and sort control file.
* Provide gzip and brotli pre-compressed files.
Build-depend on brotli pigz.
* Improve optimization of browser library.
* Add autopkgtest.
Update Vcs-* fields: Maintenance moved to Salsa.
Set Rules-Requires-Root: no.
Declare compliance with Debian Policy 4.3.0.
Relax to (build-)depend unversioned on nodejs:
Needed version satisfied even in oldstable.
Update patch 2001 to use executable nodejs
(not nodejs - see bug#862051).
Tighten dependency on nodejs accordingly.
2015-10-23 - Jonas Smedegaard <dr@jones.dk>
less.js (1.6.3~dfsg-2) unstable; urgency=medium
* Fix have node-less (not libjs-less) recommend node-source-map.
Thanks to David Prévot (see bug#773010).
2015-10-12 - Jonas Smedegaard <dr@jones.dk>
less.js (1.6.3~dfsg-1) unstable; urgency=medium
[ upstream ]
* New release(s).
+ Avoids sys.puts.
Closes: Bug#800353. Thanks to Sebastian Rittau.
[ Jonas Smedegaard ]
* Adjust comment about when to drop backport-easing fallback
build-dependency on yui-compressor.
Thanks to Alexander E. Patrakov.
* Update copyright info:
+ Update source URLs.
+ Extend coverage of packaging to include current year.
+ Drop Files sections (and corresponding License section) for files
no longer shipped upstream since before 1.4.2.
+ Extend coverage for main upstream author.
* Update source URLs in watch file and CDBS hints.
* Reimplement build (i.e. mostly concatenation) in rules file:
Upstream is moving to grunt which is not yet in Debian.
Build-depend on libyaml-tiny-perl.
* Install upstream CLI script in library path and symlink to bin path
(instead of patching paths in script).
* Bump debhelper compatibility level to 9.
* Move package VCS to pkg-javascript team.
* Add patches cherry-picked upstream to succeed testsuite with modern
Nodejs.
* Repackage upstream tarball to avoid sourceless binary code,
potentially sourceless minified code, and convenience code copies.
Mangle version in watch file (to match default CDBS suffix ~dfsg).
* Update patch 2001.
* Build-depend on and recommend node-source-map.
* Stop build-depend on yui-compressor as fallback: Nodejs needed
during build so backporting to oldstable is a pain anyway.
* Strip article from short descriptions.
[ Christian Amsüss ]
* Declare compliance with Debian Policy 3.9.6.
* Build man page using help2man.
Closes: Bug#693944. Thanks to Martey Dodoo and David Prévot.
* Update Vcs-* URIs.
2013-07-23 - Jonas Smedegaard <dr@jones.dk>
less.js (1.4.2-1) unstable; urgency=low
* Add README.source emphasizing control.in file as *not* a
show-stopper for contributions, referring to wiki page for details.
* Stop tracking md5sum of upstream tarball.
* Bump standards-version to 3.9.4.
* Use canonical hostname (anonscm.debian.org) in Vcs-Browser URI.
* Bump packaging license to GPL-3+, and extend copyrigt coverage for
myself to include recent years.
* Simplify to enable CDBS copyright check and get-orig-source features
unconditionally: Both are backporting-friendly nowadays - or rather
nowadays is more CDBS-backporting friendly).
Build-depend on devscripts.
* Extend copyright coverage for main upstream author.
* Skip a graphics file from copyright-check.
* List upstream issue tracker as preferred contact.
* Unfuzz patches.

See Also

Package Description
libjs-lodash_4.17.11+dfsg-2+deb10u1_all.deb Lo-dash is a Javascript utility library
libjs-lrdragndrop_1.0.2-2_all.deb drag and drop module for Angularjs
libjs-lunr_2.3.5~dfsg-7_all.deb simple full-text search - web browsers
libjs-magic-search_0.2.5-1_all.deb AngularJS widget that provides a UI for faceted and text search
libjs-markdown-it-html5-embed_1.0.0+ds-2_all.deb Markdown-it plugin for embedding audio/video in the HTML5 way
libjs-markdown-it-sub_1.0.0-2_all.deb javascript markdown parser subscript plugin
libjs-markdown-it-sup_1.0.0-2_all.deb javascript markdown parser superscript plugin
libjs-markdown-it_8.4.2-2_all.deb javascript markdown parser
libjs-marked_0.5.1+dfsg-1_all.deb Full-featured markdown parser and compiler
libjs-mathjax-doc_2.7+20171212-1_all.deb JavaScript display engine for LaTeX and MathML (documentation)
libjs-mathjax_2.7.4+dfsg-1_all.deb JavaScript display engine for LaTeX and MathML
libjs-matrix-js-sdk_0.9.2-1_all.deb JavaScript Client-Server SDK for the Matrix protocol
libjs-mediaelement_2.15.1+dfsg-1_all.deb HTML5 <audio> or <video> player with Flash and Silverlight shims
libjs-merge_1.2.0-2_all.deb JavaScript utility for merging multiple objects into one
libjs-mgrs_0.0.3-3_all.deb Javascript for converting between WGS84 lat/lng and MGRS coordinates
Advertisement
Advertisement