libjs-jquery-selectize.js_0.12.6+dfsg-1_all.deb


Advertisement

Description

libjs-jquery-selectize.js - Extensible jQuery-based custom select UI control

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libjs-jquery-selectize.js_0.12.6+dfsg-1_all.deb
Package name libjs-jquery-selectize.js
Package version 0.12.6+dfsg
Package release 1
Package architecture all
Package type deb
Category javascript
Homepage https://github.com/selectize/selectize.js
License -
Maintainer Debian Javascript Maintainers <pkg-javascript-devel@lists.alioth.debian.org>
Download size 50.70 KB
Installed size 254.00 KB
Selectize is an extensible jQuery-based custom <select> UI
control. It's useful for tagging, contact lists, country selectors,
and so on. The goal is to provide a solid & usable experience with a
clean and powerful API.
Features
* Smart Option Searching / Ranking
Options are efficiently scored and sorted on-the-fly (using
libjs-sifter.js). Want to search an item's title *and*
description?  No problem.
* Caret between items
Order matters sometimes. Use the left and right arrow keys to move
between selected items.
* Select and delete multiple items at once
Hold down the CTRL key to select more than one item to delete.
* Díåcritîçs supported
Great for international environments.
* Item creation
Allow users to create items on the fly (async saving is supported;
the control locks until the callback is fired).
* Remote data loading
For when you have thousands of options and want them provided by
the server as the user types.
* Clean API and code
Interface with it and make modifications easily.
* Extensible
Plugin API for developing custom features (uses
libjs-microplugin.js).
* Touch Support

Alternatives

Package Version Architecture Repository
libjs-jquery-selectize.js_0.12.6+dfsg-1_all.deb 0.12.6+dfsg all Debian Main
libjs-jquery-selectize.js - - -

Requires

Name Value
libjs-jquery -
libjs-microplugin.js -
libjs-sifter.js -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libjs-jquery-selectize.js_0.12.6+dfsg-1_all.deb
Source Package libjs-jquery-selectize.js

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libjs-jquery-selectize.js deb package:
    # sudo apt-get install libjs-jquery-selectize.js

Files

Path
/usr/share/doc/libjs-jquery-selectize.js/api.md.gz
/usr/share/doc/libjs-jquery-selectize.js/changelog.Debian.gz
/usr/share/doc/libjs-jquery-selectize.js/changelog.gz
/usr/share/doc/libjs-jquery-selectize.js/copyright
/usr/share/doc/libjs-jquery-selectize.js/events.md
/usr/share/doc/libjs-jquery-selectize.js/plugins.md
/usr/share/doc/libjs-jquery-selectize.js/usage.md.gz
/usr/share/javascript/selectize.js/selectize.js
/usr/share/javascript/selectize.js/selectize.min.js
/usr/share/javascript/selectize.js/css/selectize.bootstrap2.css
/usr/share/javascript/selectize.js/css/selectize.bootstrap3.css
/usr/share/javascript/selectize.js/css/selectize.css
/usr/share/javascript/selectize.js/css/selectize.default.css
/usr/share/javascript/selectize.js/css/selectize.legacy.css
/usr/share/javascript/selectize.js/less/selectize.bootstrap2.less
/usr/share/javascript/selectize.js/less/selectize.bootstrap3.less
/usr/share/javascript/selectize.js/less/selectize.default.less
/usr/share/javascript/selectize.js/less/selectize.legacy.less
/usr/share/javascript/selectize.js/less/selectize.less
/usr/share/javascript/selectize.js/less/plugins/drag_drop.less
/usr/share/javascript/selectize.js/less/plugins/dropdown_header.less
/usr/share/javascript/selectize.js/less/plugins/optgroup_columns.less
/usr/share/javascript/selectize.js/less/plugins/remove_button.less

Changelog

2018-07-23 - Sergio Durigan Junior <sergiodj@debian.org>
libjs-jquery-selectize.js (0.12.6+dfsg-1) unstable; urgency=medium
* Update Vcs-* URLs to use salsa.
* New upstream version 0.12.6+dfsg
* List pkg-javascript as Maintainer, put myself as Uploader.
* Bump compat version to 11.
* Bump Standards-Version to 4.1.5.
* Update d/copyright.
2017-08-09 - Sergio Durigan Junior <sergiodj@sergiodj.net>
libjs-jquery-selectize.js (0.12.4+dfsg-1) unstable; urgency=medium
* New upstream version 0.12.4+dfsg
* Bump standards version to 4.0.1.
* Change section to "javascript".
* Use DEB_VERSION instead of dpkg-parsechangelog.
* Import NMU done by Andrey Rahmatullin.
2017-03-29 - Andrey Rahmatullin <wrar@debian.org>
libjs-jquery-selectize.js (0.12.3+dfsg-1.1) unstable; urgency=medium
* Non-maintainer upload.
* Drop unused B-D: npm (Closes: #857988).
2016-08-31 - Sergio Durigan Junior <sergiodj@sergiodj.net>
libjs-jquery-selectize.js (0.12.3+dfsg-1) unstable; urgency=medium
* Update d/copyright to exclude jquery.min.js, in preparation for new release.
* Imported Upstream version 0.12.3+dfsg
2016-08-29 - Sergio Durigan Junior <sergiodj@sergiodj.net>
libjs-jquery-selectize.js (0.12.2+dfsg-1) unstable; urgency=medium
* Initial release of libjs-jquery-seletize.js. (Closes: #834865)

See Also

Package Description
libjs-jquery-simpletreemenu_1.5.0-2_all.deb visually-simple menu inspired by the Mac OS X Finder tree
libjs-jquery-slides_12-1.1_all.deb Simple slideshow plugin for jQuery
libjs-jquery-slimscroll_1.3.6+dfsg-1_all.deb jquery plugin to transform any div into a scrollable area
libjs-jquery-stupidtable_1.1.3+dfsg-1_all.deb jQuery table sorting plugin
libjs-jquery-tablesorter_2.31.1+dfsg1-1_all.deb jQuery flexible client-side table sorting plugin
libjs-jquery-textchange_0.2.3-1_all.deb detects text changes for input and textarea elements
libjs-jquery-textcomplete_1.7.3+dfsg-1_all.deb implement auto-complete support for textareas (browserified)
libjs-jquery-throttle-debounce_1.1+dfsg.1-1_all.deb library of rate-limit wrappers for functions
libjs-jquery-timeago_1.5.4-1_all.deb updates fuzzy timestamps
libjs-jquery-timepicker_1.2-1_all.deb timepicker addon for jQuery UI datepicker
libjs-jquery-tipsy_12-1.1_all.deb jQuery Facebook-style tooltip plugin
libjs-jquery-tmpl_1.0.0~beta+dfsg-2_all.deb original official jQuery Templates plugin
libjs-jquery-treetable_12-1.1_all.deb jQuery treeTable Plugin
libjs-jquery-typeahead_2.10.6+dfsg1-1_all.deb Type-ahead autocompletion plugin for JQuery
libjs-jquery-ui-docs_1.12.1+dfsg-5_all.deb Documentation for JQuery-UI
Advertisement
Advertisement