libiw-dev_30~pre9-13_i386.deb


Advertisement

Description

libiw-dev - Wireless tools - development files

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libiw-dev_30~pre9-13_i386.deb
Package name libiw-dev
Package version 30~pre9
Package release 13
Package architecture i386
Package type deb
Category devel::lang:c devel::library implemented-in::c libdevel network::configuration role::devel-lib role::program
Homepage http://www.hpl.hp.com/personal/Jean_Tourrilhes/Linux/Tools.html
License -
Maintainer Guus Sliepen <guus@debian.org>
Download size 39.47 KB
Installed size 116.00 KB
Wireless tools are used to manipulate the Linux Wireless Extensions. The
Wireless Extension is an interface allowing you to set Wireless LAN specific
parameters and get the specific stats.
This package contains the header files and static version of libiw.

Alternatives

Package Version Architecture Repository
libiw-dev_30~pre9-13_amd64.deb 30~pre9 amd64 Debian Main
libiw-dev - - -

Requires

Name Value
libc6-dev -
libiw30 = 30~pre9-13

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libiw-dev_30~pre9-13_i386.deb
Source Package wireless-tools

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libiw-dev deb package:
    # sudo apt-get install libiw-dev

Files

Path
/usr/include/iwlib.h
/usr/include/wireless.h
/usr/lib/i386-linux-gnu/libiw.a
/usr/lib/i386-linux-gnu/libiw.so
/usr/share/doc/libiw-dev/README.gz
/usr/share/doc/libiw-dev/changelog.Debian.gz
/usr/share/doc/libiw-dev/copyright

Changelog

2018-09-15 - Guus Sliepen <guus@debian.org>
wireless-tools (30~pre9-13) unstable; urgency=medium
* Call /sbin/ip instead of ifconfg in if-pre-up script. (Closes: 908886)
* Bump debian/compat to 11.
* Change Priority to optional.
* Bump Standards-Version.
2016-10-05 - Guus Sliepen <guus@debian.org>
wireless-tools (30~pre9-12) unstable; urgency=medium
[ Helmut Grohne ]
* Fix FTCBFS: Also use dh_auto_build for the udeb pass. Closes: #839800
2016-04-30 - Guus Sliepen <guus@debian.org>
wireless-tools (30~pre9-11) unstable; urgency=medium
* Add ConditionPathExists=/etc/iftab to ifrename.service. Closes: #823028
* Fix Documentation URL in ifrename.service.
* Bump Standards-Version.
2016-04-24 - Guus Sliepen <guus@debian.org>
wireless-tools (30~pre9-10) unstable; urgency=medium
* Fix libiw.so symlink in the libiw-dev package. Closes: #822391
2016-03-24 - Guus Sliepen <guus@debian.org>
wireless-tools (30~pre9-9) unstable; urgency=medium
[ Elliot Mitchell ]
* Support multiple 802.11 tool scripts for ifupdown. Closes: #154367
- By default, the if-pre-up and if-post-down scripts will now check
if the interface actually supports wireless-tools, otherwise they
will exit without an error. Closes: #445356
[ A. Costa ]
* Fixed a typo in iwlist.8. Closes: #683635
[ Guus Sliepen ]
* Convert debian/rules to dh.
* Bump Standards-Version.
* Bump debian/compat.
* Source /lib/lsb/init-functions in ifrename's init script.
* Add a systemd service file for ifrename.
2011-12-23 - Guus Sliepen <guus@debian.org>
wireless-tools (30~pre9-8) unstable; urgency=low
* Add type to IMPORT keyword in ifrename's udev rules file. Closes: #650606
2011-11-14 - Guus Sliepen <guus@debian.org>
wireless-tools (30~pre9-7) unstable; urgency=low
* Add missing Build-Depend on dpkg-dev. Closes: #644744
* Set key values after setting default key and key mode. Closes: #624603
2011-10-02 - Guus Sliepen <guus@debian.org>
wireless-tools (30~pre9-6) unstable; urgency=low
* Apply patch from Riku Voipio to support multiarch. Closes: #642434
* Bump Standards-Version.
* Provide build-arch and build-indep targets in debian/rules. 
* Use /usr/share/dpkg/default.mk in debian/rules.
* Allow CFLAGS to be set from debian/rules.
2010-07-04 - Guus Sliepen <guus@debian.org>
wireless-tools (30~pre9-5) unstable; urgency=low
* Apply patch from Steve Langesak clarifying the iftab manpage.
Closes: #528324
* Bump Standards-Version.
* Only build wireless-tools on Linux.
2010-01-23 - Guus Sliepen <guus@debian.org>
wireless-tools (30~pre9-4) unstable; urgency=low
* Let ifrename udev rules be priority 19 instead of 019. Closes: #560801
* Use udev rules from upstream. Closes: #556441
* Depend on ${misc:Depends}.

See Also

Package Description
libiw30_30~pre9-13_i386.deb Wireless tools - library
libixion-0.14-0_0.14.1-4_i386.deb general purpose formula parser & interpreter library
libixion-dev_0.14.1-4_i386.deb general purpose formula parser & interpreter library -- development
libixion-doc_0.14.1-4_all.deb general purpose formula parser & interpreter library -- documentation
libixml10_1.8.4-2_i386.deb Portable SDK for UPnP Devices, version 1.8 (ixml shared library)
libixp-dev_0.6~20121202+hg148-2+b1_i386.deb simple 9P client-/server-library (development)
libixp0_0.6~20121202+hg148-2+b1_i386.deb simple 9P client-/server-library
libixp_0.6~20121202+hg148-2_all.deb transitional dummy package for libixp-dev
libj2ssh-java-doc_0.2.9-5_all.deb Java library for the SSH protocol - documentation and examples
libj2ssh-java_0.2.9-5_all.deb Java library for the SSH protocol
libjack-dev_0.125.0-3_i386.deb JACK Audio Connection Kit (development files)
libjack-jackd2-0_1.9.12~dfsg-2_i386.deb JACK Audio Connection Kit (libraries)
libjack-jackd2-dev_1.9.12~dfsg-2_i386.deb JACK Audio Connection Kit (development files)
libjack0_0.125.0-3_i386.deb JACK Audio Connection Kit (libraries)
libjackrabbit-java_2.18.0+r2.14.6-1_all.deb content repository implementation (JCR API)
Advertisement
Advertisement