libifp-dev_1.0.0.2-5+b2_i386.deb


Advertisement

Description

libifp-dev - communicate with iRiver iFP audio devices (development files)

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libifp-dev_1.0.0.2-5+b2_i386.deb
Package name libifp-dev
Package version 1.0.0.2
Package release 5+b2
Package architecture i386
Package type deb
Category devel::library hardware::usb libdevel role::devel-lib role::program works-with-format::mp3 works-with::audio
Homepage http://ifp-driver.sourceforge.net/libifp/
License -
Maintainer Debian QA Group <packages@qa.debian.org>
Download size 48.05 KB
Installed size 150.00 KB
This package contains files used to develop or compile programs that
use libifp.
libifp allows you to communicate with iRiver iFP audio devices. It
provides a high-level interface to upload and download files to and
from the device, as well as other functions like battery status and
firmware updating.

Alternatives

Package Version Architecture Repository
libifp-dev_1.0.0.2-5+b2_amd64.deb 1.0.0.2 amd64 Debian Main
libifp-dev - - -

Requires

Name Value
libifp4 = 1.0.0.2-5+b2

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libifp-dev_1.0.0.2-5+b2_i386.deb
Source Package libifp

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libifp-dev deb package:
    # sudo apt-get install libifp-dev

Files

Path
/usr/include/ifp.h
/usr/lib/libifp.a
/usr/lib/libifp.so
/usr/share/doc/libifp-dev/changelog.Debian.gz
/usr/share/doc/libifp-dev/changelog.Debian.i386.gz
/usr/share/doc/libifp-dev/changelog.gz
/usr/share/doc/libifp-dev/copyright
/usr/share/man/man3/ifp.h.3.gz

Changelog

2011-04-10 - Ralf Treinen <treinen@debian.org>
libifp (1.0.0.2-5) unstable; urgency=low
* QA upload.
* source format 3.0 (quilt)
* debian/libifp-dev.install: do not install *.la files (closes: #621655)
* Add dependencies on ${misc:Depends}
* Add build-dependency on autotools-dev, always copy in config.{sub,guess} 
since the ones provided in the tarball are outdated.
* Install manpage via debian/ifp-line-libifp.manpages, some
simplifications in debian/rules.
2009-10-19 - Barry deFreese <bdefreese@debian.org>
libifp (1.0.0.2-4) unstable; urgency=low
* QA upload.
+ Set maintainer to Debian QA Group <packages@qa.debian.org>.
* Move Section: libs from libifp to source package stanza.
* Add Homepage field.
* Add watch file.
* Make clean not ignore errors.
* Replace deprecated Source-Version depends with binary:Version.
* Copy in config.{guess,sub} on configure, rm them on clean.
* Bump Standards Version to 3.8.3. (No changes needed).
2006-05-30 - Joe Wreschnig <piman@debian.org>
libifp (1.0.0.2-3) unstable; urgency=low
* README.Debian: plugdev, not pmp-common. (Closes: #355051)
* debian/control: Standards-Version 3.7.2.
2006-01-05 - Joe Wreschnig <piman@debian.org>
libifp (1.0.0.2-2) unstable; urgency=low
* Remove pmp-common from recommends.
* Switched to debhelper compatibility level 5.
2005-10-14 - Joe Wreschnig <piman@debian.org>
libifp (1.0.0.2-1) unstable; urgency=low
* New upstream version. (Closes: #340244)
* Pass --with-libusb to ./configure.
* Patch examples/ifpline.c to support df -h. (See: #318624)
* src/comp.c (ifp_selftest): Directory listing failure is a
warning, not an error. (Closes: #331568)
* Provide/Conflict/Replace ifp-line (since it is removed).
* Standards-Version 3.6.2.
2005-05-12 - Joe Wreschnig <piman@debian.org>
libifp (1.0.0.1-2) unstable; urgency=low
* Check --help before opening the device. (Closes: #308811)
* libifp-dev: Recommend libusb-dev.
2005-02-20 - Joe Wreschnig <piman@debian.org>
libifp (1.0.0.1-1) unstable; urgency=low
* New upstream release.
2004-12-14 - Joe Wreschnig <piman@debian.org>
libifp (1.0.0.0-1) unstable; urgency=low
* Initial Release. (Closes: #285705)

See Also

Package Description
libifp4_1.0.0.2-5+b2_i386.deb communicate with iRiver iFP audio devices
libifstat-dev_1.1-8.1+b1_i386.deb Ifstat Development Files
libigdgmm-dev_18.4.1+ds1-1_i386.deb Intel Graphics Memory Management Library -- development files
libigdgmm5_18.4.1+ds1-1_i386.deb Intel Graphics Memory Management Library -- shared library
libignition-cmake-dev_0.6.1-1_i386.deb Ignition Robotics CMake Library - Development files
libignition-common-dev_1.1.1-1_i386.deb Collection of useful code used by robotics apps - Dev files
libignition-common_1.1.1-1_i386.deb Collection of useful code used by robotics apps - Shared library
libignition-fuel-tools1-1_1.0.0+dfsg4-5+b1_i386.deb Ignition fuel-tools classes and functions - Shared library
libignition-fuel-tools1-dev_1.0.0+dfsg4-5+b1_i386.deb Ignition fuel-tools classes and functions - Development files
libignition-math2-dev_2.9.0+dfsg1-1_i386.deb Ignition Robotics Math Library - Development files
libignition-math2_2.9.0+dfsg1-1_i386.deb Ignition Robotics Math Library - Shared library
libignition-math4-dev_4.0.0+dfsg1-5_i386.deb Ignition Robotics Math Library - Development files
libignition-math4_4.0.0+dfsg1-5_i386.deb Ignition Robotics Math Library - Shared library
libignition-msgs-dev_1.0.0+dfsg1-5+b1_i386.deb Set of message definitions used by robotics apps - Dev files
libignition-msgs_1.0.0+dfsg1-5+b1_i386.deb Set of message definitions used by robotics apps - Shared library
Advertisement
Advertisement