libgxps2_0.3.1-1_i386.deb


Advertisement

Description

libgxps2 - handling and rendering XPS documents (library)

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libgxps2_0.3.1-1_i386.deb
Package name libgxps2
Package version 0.3.1
Package release 1
Package architecture i386
Package type deb
Category libs role::shared-lib
Homepage https://wiki.gnome.org/libgxps
License -
Maintainer Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>
Download size 57.17 KB
Installed size 174.00 KB
OpenXPS or XPS stands for XML Paper Specification. It is based on XML and it's
a new electronic paper format originally developed by Microsoft and it serves
as a PDF alternative. XPS files are usually created using "Microsoft XPS
Document Writer" in Windows environments. It is now standardized as an open
standard document format.
Quoting Wikipedia:
An XPS file is in fact a Unicoded ZIP archive using the Open Packaging
Conventions, containing the files which make up the document. These include an
XML markup file for each page, text, embedded fonts, raster images, 2D vector
graphics, as well as the digital rights management information. The contents
of an XPS file can be examined simply by opening it in an application which
supports ZIP files.
The OpenXPS document format specification supports features such as color
gradients, transparencies, CMYK color spaces, printer calibration,
multiple-ink systems and print schemas.
This package contains the library. It is being used by evince to read XPS
documents.

Alternatives

Package Version Architecture Repository
libgxps2_0.3.1-1_amd64.deb 0.3.1 amd64 Debian Main
libgxps2 - - -

Requires

Name Value
libarchive13 >= 3.0.4
libc6 >= 2.11
libcairo2 >= 1.10.0
libfreetype6 >= 2.2.1
libglib2.0-0 >= 2.37.3
libjpeg62-turbo >= 1.3.1
liblcms2-2 >= 2.2+git20110628
libpng16-16 >= 1.6.2-1
libtiff5 >= 4.0.3

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libgxps2_0.3.1-1_i386.deb
Source Package libgxps

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libgxps2 deb package:
    # sudo apt-get install libgxps2

Files

Path
/usr/lib/i386-linux-gnu/libgxps.so.2
/usr/lib/i386-linux-gnu/libgxps.so.2.2.3
/usr/share/doc/libgxps2/AUTHORS
/usr/share/doc/libgxps2/NEWS.gz
/usr/share/doc/libgxps2/README
/usr/share/doc/libgxps2/TODO
/usr/share/doc/libgxps2/changelog.Debian.gz
/usr/share/doc/libgxps2/copyright

Changelog

2019-01-05 - Jeremy Bicha <jbicha@debian.org>
libgxps (0.3.1-1) unstable; urgency=medium
* New upstream release
- This release also includes the fixes we cherry-picked in 0.3.0-3 for
CVE-2018-10767 (Closes: #898133)
* Drop all patches: applied in new release
* Bump minimum meson to 0.43.0
2018-12-28 - Jeremy Bicha <jbicha@debian.org>
libgxps (0.3.0-4) unstable; urgency=medium
* Restore -Wl,-O1 to our LDFLAGS
* debian/libgxps2.symbols: Add Build-Depends-Package
* Bump Standards-Version to 4.3.0
2018-10-14 - Jeremy Bicha <jbicha@debian.org>
libgxps (0.3.0-3) unstable; urgency=medium
* Update Vcs fields for migration to https://salsa.debian.org/
* Use debian/libgxps-utils.manpages instead of dh_install
* Bump Standards-Version to 4.2.1
* Cherry-pick docs-Fix-OUTPUT-FILE-description.patch:
- fix typo in manpages (Closes: #887615)
* Cherry-pick gxps-archive-Ensure-gxps_archive_read_entry-fills-the-GEr.patch
& gxps-archive-Handle-errors-returned-by-archive_read_data.patch:
- Fix heap buffer overflow in ft_font_face_hash of gxps-fonts.c
CVE-2018-10733 (Closes: #897954)
* Cherry-pick gxps-images-fix-integer-overflow-in-png-decoder.patch:
- Fix an integer overflow
* Cherry-pick gxps-images-clear-the-error-before-trying-to-load-an-imag.patch:
- clear an error so that fallback image loading works
2017-12-18 - Jeremy Bicha <jbicha@debian.org>
libgxps (0.3.0-2) unstable; urgency=medium
* Update Vcs fields for conversion to git
* Add debian/gbp.conf
* Bump Standards-Version to 4.1.2
* Bump debhelper compat to 11
* Build with all hardening flags
2017-08-09 - Jeremy Bicha <jbicha@ubuntu.com>
libgxps (0.3.0-1) unstable; urgency=medium
* New upstream release.
- Includes fix for CVE-2017-11590 (Closes: #870183)
* Build with meson.
* Bump debhelper compat to 10.
* Bump Standards-Version to 4.0.1.
2017-03-20 - Michael Biebl <biebl@debian.org>
libgxps (0.2.5-1) unstable; urgency=medium
* New upstream release.
* Be more specific about which versions of libglib2.0-dev and libcairo2-dev
we require.
* Drop private symbols from libgxps2.symbols. Those are no longer exported
by upstream. Removing those symbols is safe as they were never part of the
public API and no other package was using it.
2016-06-22 - Michael Biebl <biebl@debian.org>
libgxps (0.2.4-1) unstable; urgency=medium
* New upstream release.
* Convert from cdbs to dh.
* Set pkg-gnome-maintainers@lists.alioth.debian.org as Maintainer, list
Savvas Radevic as Uploader.
* Install typelib files into multiarch paths.
* Mark gir1.2-gxps-0.1 and libgxps-dev as Multi-Arch: same.
* Bump Standards-Version to 3.9.8.
2015-09-17 - Andreas Henriksson <andreas@fatal.se>
libgxps (0.2.3.2-1) unstable; urgency=medium
* Team upload.
* New upstream release.
2015-08-24 - Andreas Henriksson <andreas@fatal.se>
libgxps (0.2.3.1-1) unstable; urgency=medium
* Team upload.
* New upstream release.
* Drop debian/patches/fix-build-with-libpng16.patch
- now part of upstream release.
* Update debian/libgxps2.symbols with new additions.
2014-04-02 - Andreas Henriksson <andreas@fatal.se>
libgxps (0.2.2-3) unstable; urgency=low
* Team upload
[ Jeremy Bicha ]
* Update homepage
[ Andreas Henriksson ]
* Add debian/patches/fix-build-with-libpng16.patch (Closes: #743387)

See Also

Package Description
libgxw-dev_0.36.1-1+b1_i386.deb Guitarix - GTK+ library (development files)
libgxw0_0.36.1-1+b1_i386.deb Guitarix - GTK+ library
libgxwmm-dev_0.36.1-1+b1_i386.deb Guitarix - GTK+ C++ widget library (development files)
libgxwmm0_0.36.1-1+b1_i386.deb Guitarix - GTK+ C++ widget library
libgyoto7-dev_1.3.1-1_i386.deb development files for libgyoto
libgyoto7_1.3.1-1_i386.deb Gyoto framework main library an standard plug-in
libgzstream-dev_1.5+dfsg-4_i386.deb provide functionality of zlib C-library in a C++ iostream (development)
libgzstream0_1.5+dfsg-4_i386.deb provide functionality of zlib C-library in a C++ iostream
libh2-java-doc_1.4.197-4_all.deb H2 Database Engine (documentation)
libh2-java_1.4.197-4_all.deb H2 Database Engine
libh2o-dev-common_2.2.5+dfsg2-2+deb10u1_all.deb H2O library headers
libh2o-dev_2.2.5+dfsg2-2+deb10u1_i386.deb dev helpers of the H2O library compiled with libuv
libh2o-evloop-dev_2.2.5+dfsg2-2+deb10u1_i386.deb dev helpers of the H2O library compiled with its own event loop
libh2o-evloop0.13_2.2.5+dfsg2-2+deb10u1_i386.deb H2O library compiled with its own event loop
libh2o0.13_2.2.5+dfsg2-2+deb10u1_i386.deb H2O library compiled with libuv
Advertisement
Advertisement