libgvnc-1.0-dev_0.9.0-1.1_i386.deb


Advertisement

Description

libgvnc-1.0-dev - VNC GObject wrapper (development files)

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libgvnc-1.0-dev_0.9.0-1.1_i386.deb
Package name libgvnc-1.0-dev
Package version 0.9.0
Package release 1.1
Package architecture i386
Package type deb
Category devel::library libdevel role::devel-lib
Homepage https://wiki.gnome.org/Projects/gtk-vnc
License -
Maintainer Debian Libvirt Maintainers <pkg-libvirt-maintainers@lists.alioth.debian.org>
Download size 63.18 KB
Installed size 275.00 KB
It is built using coroutines, allowing it to be completely asynchronous while
remaining single threaded. It supports RFB protocols 3.3 through 3.8 and the
VeNCrypt authentication extension providing SSL/TLS encryption with x509
certificate authentication.
The core library is written in C and a bindings for other languages are
available via GObject introspection. The networking layer supports connections
over both IPv4 and IPv6.
This package contains the development headers for libgvnc-1.0 and
Vala bindings.

Alternatives

Package Version Architecture Repository
libgvnc-1.0-dev_0.9.0-1.1_amd64.deb 0.9.0 amd64 Debian Main
libgvnc-1.0-dev - - -

Requires

Name Value
libcairo2-dev >= 1.2.0
libglib2.0-dev -
libgnutls28-dev -
libgvnc-1.0-0 = 0.9.0-1.1

Replaces

Name Value
libgtk-vnc-1.0-dev <= 0.4.3-1

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libgvnc-1.0-dev_0.9.0-1.1_i386.deb
Source Package gtk-vnc

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libgvnc-1.0-dev deb package:
    # sudo apt-get install libgvnc-1.0-dev

Files

Path
/usr/include/gvnc-1.0/gvnc.h
/usr/include/gvnc-1.0/vncaudio.h
/usr/include/gvnc-1.0/vncaudioformat.h
/usr/include/gvnc-1.0/vncaudiosample.h
/usr/include/gvnc-1.0/vncbaseaudio.h
/usr/include/gvnc-1.0/vncbaseframebuffer.h
/usr/include/gvnc-1.0/vnccolormap.h
/usr/include/gvnc-1.0/vncconnection.h
/usr/include/gvnc-1.0/vncconnectionenums.h
/usr/include/gvnc-1.0/vnccursor.h
/usr/include/gvnc-1.0/vncframebuffer.h
/usr/include/gvnc-1.0/vncpixelformat.h
/usr/include/gvnc-1.0/vncutil.h
/usr/include/gvncpulse-1.0/gvncpulse.h
/usr/include/gvncpulse-1.0/vncaudiopulse.h
/usr/lib/i386-linux-gnu/libgvnc-1.0.so
/usr/lib/i386-linux-gnu/libgvncpulse-1.0.so
/usr/lib/i386-linux-gnu/pkgconfig/gvnc-1.0.pc
/usr/lib/i386-linux-gnu/pkgconfig/gvncpulse-1.0.pc
/usr/share/doc/libgvnc-1.0-dev/changelog.Debian.gz
/usr/share/doc/libgvnc-1.0-dev/changelog.gz
/usr/share/doc/libgvnc-1.0-dev/copyright
/usr/share/gir-1.0/GVnc-1.0.gir
/usr/share/gir-1.0/GVncPulse-1.0.gir
/usr/share/vala/vapi/gvnc-1.0.vapi
/usr/share/vala/vapi/gvncpulse-1.0.vapi

Changelog

2019-03-21 - Steinar H. Gunderson <sesse@debian.org>
gtk-vnc (0.9.0-1.1) unstable; urgency=high
* Non-maintainer upload.
* fix-unit-test-race.diff: New patch, fixes a race condition in unit tests
which would cause FTBFS, especially on builds with only a single CPU.
(Closes: #909417)
2018-08-30 - Guido Günther <agx@sigxcpu.org>
gtk-vnc (0.9.0-1) unstable; urgency=medium
* [ffcc52b] New upstream version 0.9.0
* [a4bcc35] Drop PyGTK specific bindings.
Use GObject introspection instead. (Closes: #885376)
* [4e767fd] Bump build-deps. Upstream requires newer versions.
* [1842f7f] d/copyright: drop copyright of now gone files
* [855b8e1] d/control: Use salsa URL
* [dbf297c] Rediff patches
* [511748f] gvnc-1.0.pc.in: Use GLIB_REQUIRED
2018-03-27 - Guido Günther <agx@sigxcpu.org>
gtk-vnc (0.7.2-1) unstable; urgency=medium
* New upstream version 0.7.2
* [268c8ce] gbp.conf: use id-length to correlate git commits to changelog
entries
* [222b710] Bump standards version
* [4a63e15] Drop debug packages
* [f4213bf] d/watch: Use https
2017-08-01 - Guido Günther <agx@sigxcpu.org>
gtk-vnc (0.7.1-1) unstable; urgency=medium
* [a223999] New upstream version 0.7.1
* [16c4865] Drop patches included in this release
security/Don-t-accept-color-map-entries-for-true-color-pixel-forma.patch
security/Correctly-validate-color-map-range-indexes.patch
security/Fix-bounds-checking-for-RRE-hextile-copyrect-encodings.patch
Link-against-GIO_LIBS-explicitly.patch
* [3b8e281] Add new symbols
2017-02-10 - Guido Günther <agx@sigxcpu.org>
gtk-vnc (0.6.0-3) unstable; urgency=medium
* [b8d9918] CVE-2017-5884: Fix bounds checking for RRE, hextile & copyrect
encodings
* [ca87ace] CVE-2017-5885: Correctly validate color map range indexes
(Closes: #854450)
* [0e71020] Link against GIO_LIBS explicitly to fix build failure
* [7d3fdde] Rediff patches to make them more git-format-patch compatible
2017-01-08 - Joao Eriberto Mota Filho <eriberto@debian.org>
gtk-vnc (0.6.0-2) unstable; urgency=medium
* Team upload.
* Added changes from Ubuntu to add multiarch and avoid a FTBFS.
* Migrations:
- debian/copyright to 1.0 format.
- DH level to 10.
* Used wrap-and-sort -ast.
* debian/control:
- Added a Homepage field.
- Add dh-python to Build-Depends field.
- Fixed duplicate descriptions.
- Fixed the GObject word.
- Removed a dot from short description.
- Removed a MIA co-maintainer.
- Removed unneeded build dependency autotools-dev (using dh-autoreconf
now).
- Updated Vcs-* fields.
* debian/gvncviewer.install: added a manpage for gvnccapture.
* debian/patches/Add-m4.patch: created to add '-I m4' option to Makefile.am.
* debian/rules:
- Added DEB_BUILD_MAINT_OPTIONS variable to improve the GCC hardening.
- Removed no longer necessary autoreconf addon.
* debian/watch:
- Bumped to version 4.
- Removed an extra line.
2016-09-09 - Guido Günther <agx@sigxcpu.org>
gtk-vnc (0.6.0-1) unstable; urgency=medium
* [2f71b54] gbp.conf: Follow DEP14
* [a10053d] New upstream version 0.6.0
Closes: #836854
* [c58efd2] Fixup gbp section name
* [5be7c29] Bump standards version
2014-08-30 - Andreas Metzler <ametzler@debian.org>
gtk-vnc (0.5.3-1.2) unstable; urgency=medium
* Non-maintainer upload.
* Upload to unstable.
* Use dh-autoreconf (Patch by Breno Leitao). Closes: #746403
2014-08-15 - Andreas Metzler <ametzler@debian.org>
gtk-vnc (0.5.3-1.1) experimental; urgency=medium
* Non-maintainer upload.
* Change (build-)dependencies from libgnutls-dev to libgnutls28-dev and add
a build-dependency on libgcrypt20-dev. Closes: #745946
* Upload to experimental to test buildability.
2014-05-04 - Laurent Léonard <laurent@open-minds.org>
gtk-vnc (0.5.3-1) unstable; urgency=medium
* [66e3bf7] Imported Upstream version 0.5.3
* [c1d21eb] Redo patch
* [f5c94bf] Update symbols

See Also

Package Description
libgvpr2_2.40.1-6_i386.deb rich set of graph drawing tools - gvpr library
libgweather-3-15_3.28.2-2_i386.deb GWeather shared library
libgweather-3-dev_3.28.2-2_i386.deb GWeather development files
libgweather-common_3.28.2-2_all.deb GWeather common files
libgwengui-cpp0_4.20.0-9_i386.deb C++ bindings for the Gwenhywfar GUI implementation
libgwengui-fox16-0_4.20.0-9_i386.deb Gwenhywfar GUI implementation for the FOX Toolkit
libgwengui-fox16-dev_4.20.0-9_i386.deb Gwenhywfar GUI implementation for the FOX Toolkit (development files)
libgwengui-gtk3-0_4.20.0-9_i386.deb Gwenhywfar GUI implementation for GTK3
libgwengui-gtk3-dev_4.20.0-9_i386.deb Gwenhywfar GUI implementation for GTK3 (development files)
libgwengui-qt5-0_4.20.0-9_i386.deb Gwenhywfar GUI implementation for Qt5
libgwengui-qt5-dev_4.20.0-9_i386.deb Gwenhywfar GUI implementation for Qt 5 (development files)
libgwenhywfar-core-dev_4.20.0-9_i386.deb OS abstraction layer (core development files)
libgwenhywfar-data_4.20.0-9_all.deb OS abstraction layer - data files
libgwenhywfar-doc_4.20.0-9_all.deb OS abstraction layer (API documentation)
libgwenhywfar60-dev_4.20.0-9_i386.deb OS abstraction layer (meta package)
Advertisement
Advertisement