libguytools2-dev_2.0.5-3_i386.deb


Advertisement

Description

libguytools2-dev - development files for libguytools being a small programming toolbox

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libguytools2-dev_2.0.5-3_i386.deb
Package name libguytools2-dev
Package version 2.0.5
Package release 3
Package architecture i386
Package type deb
Category devel::library libdevel role::devel-lib
Homepage http://sourceforge.net/projects/libguytools/
License -
Maintainer Debian Security Tools <team+pkg-security@tracker.debian.org>
Download size 9.32 KB
Installed size 51.00 KB
Includes modules for configuration file handling, error handling, logging and
system information retrieval. A signal handler enables applications to do stack
backtracing in case of segmentation faults. This package provides the
development files for libguytools2.

Alternatives

Package Version Architecture Repository
libguytools2-dev_2.0.5-3_amd64.deb 2.0.5 amd64 Debian Main
libguytools2-dev - - -

Requires

Name Value
libguytools2 = 2.0.5-3

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libguytools2-dev_2.0.5-3_i386.deb
Source Package libguytools2

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libguytools2-dev deb package:
    # sudo apt-get install libguytools2-dev

Files

Path
/usr/include/libguytools2/toolcfg.h
/usr/include/libguytools2/toolconstants.h
/usr/include/libguytools2/toolerror.h
/usr/include/libguytools2/toolglobalid.h
/usr/include/libguytools2/toollog.h
/usr/include/libguytools2/toolsignal.h
/usr/include/libguytools2/toolsysinfo.h
/usr/include/libguytools2/tooltarget.h
/usr/include/libguytools2/tooltypes.h
/usr/lib/libguytools.so
/usr/share/doc/libguytools2-dev/changelog.Debian.gz
/usr/share/doc/libguytools2-dev/changelog.gz
/usr/share/doc/libguytools2-dev/copyright

Changelog

2018-05-28 - Michael Prokop <mika@debian.org>
libguytools2 (2.0.5-3) unstable; urgency=medium
* Fix missing qt5-qmake:native in the .dsc file, caused
by using dpkg-source from Debian/jessie. Thanks for
spotting, Helmut Grohne. (Closes: #898281)
2018-05-18 - Michael Prokop <mika@debian.org>
libguytools2 (2.0.5-2) unstable; urgency=medium
[ Raphaƫl Hertzog ]
* [4d477b3] Update team maintainer address to Debian Security Tools
<team+pkg-security@tracker.debian.org>
* [22b552e] Update Vcs-Git and Vcs-Browser for the move to
salsa.debian.org
* [a380c67] Update Vcs-* fields to match renamed git repository and
source package name
[ Michael Prokop ]
* [1f3de7a] Apply patch to fix FTCBFS. Thanks to Helmut Grohne
<helmut@subdivi.de> for bugreport + patch (Closes: #898281)
2018-01-06 - Michael Prokop <mika@debian.org>
libguytools2 (2.0.5-1) unstable; urgency=medium
* [541d758] New upstream version 2.0.5
* [1b1a34a] Bump Standards-Version to 4.1.3
* [ce03cf4] Bump debian/compat to 9
* [cf738ee] Switch from Qt4 to Qt5 (Closes: #875011)
* [1b47f1f] Update debian/libguytools2.links for new upstream release
* [bf69142] debian: wrap-and-sort -a -t -s
2015-08-18 - Michael Prokop <mika@debian.org>
libguytools2 (2.0.4-1) unstable; urgency=medium
* [8a3ce49] Add debian/watch file
* [430eaf9] Imported Upstream version 2.0.4
* [6befbe1] Add support for arm64. Thanks to Martin Michlmayr
<tbm@hp.com> + Guy <develop@faert.net> (Closes: #791985)
2015-04-30 - Michael Prokop <mika@debian.org>
libguytools2 (2.0.3-1) unstable; urgency=medium
* [9468d10] Imported Upstream version 2.0.3
* [86ea3e2] debian/source/format: use 3.0 (quilt)
* [6cba8ba] Bump Standards-Version to 3.9.6
* [8e5f877] Update /usr/lib/libguytools.so.2 symlink
* [8fdd0d4] Update Vcs-{git,Browser} headers
2012-01-11 - Konstantinos Margaritis <markos@debian.org>
libguytools2 (2.0.1-1.1) unstable; urgency=low
* NMU, added armhf to the arch list. (Closes: #623134)
2011-02-16 - Michael Prokop <mika@debian.org>
libguytools2 (2.0.1-1) unstable; urgency=low
* Initial release of new libguytools version.

See Also

Package Description
libguytools2_2.0.5-3_i386.deb libguytools is a small programming toolbox
libgv-guile_2.40.1-6_i386.deb Guile bindings for graphviz
libgv-lua_2.40.1-6_i386.deb Lua bindings for graphviz
libgv-perl_2.40.1-6_i386.deb Perl bindings for graphviz
libgv-php7_2.40.1-6_i386.deb PHP7 bindings for graphviz
libgv-ruby_2.40.1-6_i386.deb Ruby bindings for graphviz
libgv-tcl_2.40.1-6_i386.deb Tcl bindings for graphviz
libgvc6-plugins-gtk_2.40.1-6_i386.deb rich set of graph drawing tools - gtk plugins
libgvc6_2.40.1-6_i386.deb rich set of graph drawing tools - gvc library
libgvnc-1.0-0_0.9.0-1.1_i386.deb VNC GObject wrapper (runtime libraries)
libgvnc-1.0-dev_0.9.0-1.1_i386.deb VNC GObject wrapper (development files)
libgvpr2_2.40.1-6_i386.deb rich set of graph drawing tools - gvpr library
libgweather-3-15_3.28.2-2_i386.deb GWeather shared library
libgweather-3-dev_3.28.2-2_i386.deb GWeather development files
libgweather-common_3.28.2-2_all.deb GWeather common files
Advertisement
Advertisement