libgtkdatabox0-libglade_0.9.3.1-1_i386.deb


Advertisement

Description

libgtkdatabox0-libglade - Gtk+ library to display large amounts of numerical data (glade lib)

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libgtkdatabox0-libglade_0.9.3.1-1_i386.deb
Package name libgtkdatabox0-libglade
Package version 0.9.3.1
Package release 1
Package architecture i386
Package type deb
Category science uitoolkit::gtk
Homepage http://sourceforge.net/projects/gtkdatabox
License -
Maintainer Debian Science Maintainers <debian-science-maintainers@lists.alioth.debian.org>
Download size 22.07 KB
Installed size 47.00 KB
One or more data sets of thousands of data points (X and Y coordinate) may be
displayed and updated in split seconds. The widget is therefore used in many
scientific and private projects that need to show quickly changing data live.
GtkDatabox offers the ability to zoom into and out of the data and to navigate
through your data by scrolling.
In addition to rulers and a simple coordinate cross, GtkDatabox now also allows
you to add one (or even more) configurable grids like on an oscilloscope.
Data may be presented as dots, lines connecting the data, or vertical bars.
The widget allows you to easily transform pixel coordinates into data
coordinates, thus allowing you to easily create powerful applications for
data analysis.
Libraries for run-time GUI loading with libglade

Alternatives

Package Version Architecture Repository
libgtkdatabox0-libglade_0.9.3.1-1_amd64.deb 0.9.3.1 amd64 Debian Main
libgtkdatabox0-libglade - - -

Requires

Name Value
libatk1.0-0 >= 1.12.4
libc6 >= 2.3.6-6~
libcairo2 >= 1.2.4
libfontconfig1 >= 2.12.6
libfreetype6 >= 2.2.1
libgdk-pixbuf2.0-0 >= 2.22.0
libglade2-0 >= 1:2.6.4-2~
libglib2.0-0 >= 2.16.0
libgtk2.0-0 >= 2.8.0
libgtkdatabox0 >= 0.9.3.1
libpango-1.0-0 >= 1.14.0
libpangocairo-1.0-0 >= 1.14.0
libpangoft2-1.0-0 >= 1.14.0
libxml2 >= 2.6.27

Conflicts

Name Value
libgtkdatabox-0.9.2-0-libglade -
libgtkdatabox-0.9.3-0-libglade -

Replaces

Name Value
libgtkdatabox-0.9.2-0-libglade -
libgtkdatabox-0.9.3-0-libglade -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libgtkdatabox0-libglade_0.9.3.1-1_i386.deb
Source Package libgtkdatabox

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libgtkdatabox0-libglade deb package:
    # sudo apt-get install libgtkdatabox0-libglade

Files

Path
/usr/lib/i386-linux-gnu/libglade/2.0/libdatabox.a
/usr/lib/i386-linux-gnu/libglade/2.0/libdatabox.so
/usr/share/doc/libgtkdatabox0-libglade/changelog.Debian.gz
/usr/share/doc/libgtkdatabox0-libglade/changelog.gz
/usr/share/doc/libgtkdatabox0-libglade/copyright

Changelog

2019-01-13 - Andreas Tille <tille@debian.org>
libgtkdatabox (1:0.9.3.1-1) unstable; urgency=medium
* New upstream version
* debhelper 12
* Point Vcs fields to salsa.debian.org
* Standards-Version: 4.3.0
* Drop useless get-orig-source target
* Remove trailing whitespace in debian/changelog
* Remove trailing whitespace in debian/control
* Do not parse d/changelog
* Fix upstream build system to use proper SONAME (this prevents us
from always changing package name for every single nano upgrade)
* Adapt package names to SONAME
* Add symbols file
* Drop unused lintian override
2016-12-12 - Andreas Tille <tille@debian.org>
libgtkdatabox (1:0.9.3.0+dfsg-3) unstable; urgency=medium
* Add further missing conflicts to renamed package
Closes: #843931
* debhelper 10
* d/watch: version=4
2016-11-15 - Andreas Tille <tille@debian.org>
libgtkdatabox (1:0.9.3.0+dfsg-2) unstable; urgency=medium
* Glade has moved to Multiarch
Closes: #843670
* Add conflicts for version renamed glade package
Closes: #843931
2016-10-19 - Andreas Tille <tille@debian.org>
libgtkdatabox (1:0.9.3.0+dfsg-1) unstable; urgency=medium
* New upstream version
* Compression done in d/watch
* cme fix dpkg-control
* unversioned development+doc packages
* bump version of shared library package
* fix spelling in long description
* source package now section science
Closes: #798062
* delete useless autogenerated doxygen files
* hardening=+bindnow
* cme fix dpkg-copyright
* fix lintian overrides
2014-07-27 - Andreas Tille <tille@debian.org>
libgtkdatabox (1:0.9.2.0+dfsg-1) unstable; urgency=medium
* Use dh-autoreconf to update autoconf files (Thanks for the patch to
Breno Leitao <brenohl@br.ibm.com>)
Closes:  #755729
* Exclude compressed jquery.js from upstream source (its not used anyway)
* Use dh_links instead of dh_linktrees since jquery.js was removed
* debian/control: Fix capitalisation of API
2014-01-19 - Andreas Tille <tille@debian.org>
libgtkdatabox (1:0.9.2.0-4) unstable; urgency=low
* Use --multiarch to make sure library is correctly installed into
/usr/lib/<architecture-tripplet>
* Drop d-devlibdeps call which is redundant because automatically
called in d-shlibmove
* cme fix dpkg-control
* debian/rules: Regard multi-arch builds
Closes: #735795
* debian/libgtkdatabox-0.9.2-0.lintian-overrides: adapt override to
multi-arch location
2013-05-23 - Andreas Tille <tille@debian.org>
libgtkdatabox (1:0.9.2.0-3) unstable; urgency=low
[ Daniele E. Domenichelli ]
* Add 05_explicitly_link_libm.patch
* Add 06_gladeui-2.0.patch
* debian/control
- Add quilt to b-d
- Change b-d from libgladeui-1-dev to libgladeui-dev
Closes: #709242
* debian/rules
- Fix installed files glade3 -> glade
[ Andreas Tille ]
* debian/control:
- Explicit Build-Dependency from quilt is not needed.
- Standards-Version: 3.9.4 (no changes needed)
2013-05-18 - Andreas Tille <tille@debian.org>
libgtkdatabox (1:0.9.2.0-2) unstable; urgency=low
* debian/control: Add proper conflicts betwen new -doc package and
old -dev package containing the same files
Closes: #708667
2013-05-10 - Andreas Tille <tille@debian.org>
libgtkdatabox (1:0.9.2.0-1) unstable; urgency=low
* New upstream version
Removed unneeded patche: 03_deprecated_GTK.patch
Refreshed remaining patches
* Reflect move to Git by changing Vcs fields
* debian/control:
- Remove DM-Upload-Allowed
- Standards-Version: 3.9.4 (no changes needed)
- Priority: s/extra/optional/
- Normalised
- different short descriptions
- new binary package featuring API documentation separately
* debian/rules: New version does not contain docs/reference
any more so no need for extra handling

See Also

Package Description
libgtkdatabox0_0.9.3.1-1_i386.deb Gtk+ library to display large amounts of numerical data
libgtkdsv-3-0_3.8.5-1_i386.deb GTK+ syntax highlighting widget - D bindings
libgtkdsv-3-dev_3.8.5-1_i386.deb GTK+ syntax highlighting widget - development files for D
libgtkextra-3.0-doc_3.3.4-1_all.deb documentation for libgtkextra-x11-3.0
libgtkextra-3.0_3.3.4-1_i386.deb useful set of widgets for creating GUI's for GTK+
libgtkextra-dev_3.3.4-1_i386.deb development files for libgtkextra-x11-3.0
libgtkgl2.0-1_2.0.1-2.2_i386.deb OpenGL context support for GTK+ (shared libraries)
libgtkgl2.0-dev_2.0.1-2.2_i386.deb OpenGL context support for GTK+ (development files)
libgtkglext1-dev_1.2.0-9_i386.deb OpenGL Extension to GTK+ (development files)
libgtkglext1-doc_1.2.0-9_all.deb OpenGL Extension to GTK+ (documentation)
libgtkglext1_1.2.0-9_i386.deb OpenGL Extension to GTK+ (shared libraries)
libgtkglextmm-x11-1.2-0v5_1.2.0-8_i386.deb C++ bindings for GtkGLExt (Shared libraries)
libgtkglextmm-x11-1.2-dev_1.2.0-8_i386.deb C++ bindings for GtkGLExt (Development files)
libgtkglextmm-x11-1.2-doc_1.2.0-8_all.deb C++ bindings for GtkGLExt (Documentation)
libgtkhex-3-0_3.18.3-5_i386.deb GNOME Hex editor for files (shared library)
Advertisement
Advertisement