libgtkada18_18-2_i386.deb


Advertisement

Description

libgtkada18 - Ada binding for the GTK+ GUI (dynamic library)

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libgtkada18_18-2_i386.deb
Package name libgtkada18
Package version 18
Package release 2
Package architecture i386
Package type deb
Category libs role::shared-lib
Homepage https://www.adacore.com/community
License -
Maintainer Ludovic Brenta <lbrenta@debian.org>
Download size 1.90 MB
Installed size 9.01 MB
GtkAda is a library that allows programmers to write GTK+ applications in the
Ada programming language.
This library will let you run Ada applications compiled with GTK+.

Alternatives

Package Version Architecture Repository
libgtkada18_18-2_amd64.deb 18 amd64 Debian Main
libgtkada18 - - -

Requires

Name Value
libc6 >= 2.4
libcairo2 >= 1.10.0
libfontconfig1 >= 2.12.6
libgcc1 >= 1:3.0
libgdk-pixbuf2.0-0 >= 2.22.0
libglib2.0-0 >= 2.41.2
libgnat-8 >= 8.2.0-8
libgtk-3-0 >= 3.13.7
libpango-1.0-0 >= 1.36.0
libpangocairo-1.0-0 >= 1.14.0

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libgtkada18_18-2_i386.deb
Source Package libgtkada

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libgtkada18 deb package:
    # sudo apt-get install libgtkada18

Files

Path
/usr/lib/i386-linux-gnu/libgtkada.so.18
/usr/share/doc/libgtkada18/changelog.Debian.gz
/usr/share/doc/libgtkada18/changelog.gz
/usr/share/doc/libgtkada18/copyright

Changelog

2018-10-27 - Nicolas Boulenguez <nicolas@debian.org>
libgtkada (18-2) unstable; urgency=medium
* Rebuild in unstable for gnat-8 transition.
2018-06-09 - Nicolas Boulenguez <nicolas@debian.org>
libgtkada (18-1) experimental; urgency=medium
* New upstream release. No package renaming in experimental.
2018-05-07 - Nicolas Boulenguez <nicolas@debian.org>
libgtkada (17.0.2017-4) experimental; urgency=medium
* Rebuild with gnat-8.
Rename shared library and -dev packages per Debian Ada policy.
Drop obsolete Break/Replace with older -dev.
* Delete watch file. Explain why in README.source.
* Update upstream Home page.
* Let run time test produce more debug information.
2018-04-24 - Nicolas Boulenguez <nicolas@debian.org>
libgtkada (17.0.2017-3) unstable; urgency=medium
* Break+Replace: previous -dev per Ada policy. Closes: #892148.
* Standards-Version: 4.1.4.
2018-02-28 - Nicolas Boulenguez <nicolas@debian.org>
libgtkada (17.0.2017-3~exp1) experimental; urgency=medium
* update-gtk-gir.diff: use obsolete Gtk-3.0.gir with recent libgtk-dev.
Implies a new ALI version because the generated Ada have changed, but
also a new SO version: the new enumeration values will be passed to
existing callbacks by recent GTK runtimes.
* Debhelper 11. Move docs to /u/s/doc/libgtkada*-dev.
* Remove trailing whitespaces in this changelog.
* Build-Depend: drop obsolete restriction on dpkg-dev version.
* Standards-Version: 4.1.3 without changes.
* Update Vcs-Mtn to new monotone URI format.
* Remove duplicate build flags.
* Example archive: stop embedding backup file and unreproducible data.
2017-08-10 - Nicolas Boulenguez <nicolas@debian.org>
libgtkada (17.0.2017-2) unstable; urgency=medium
* Upload to unstable.
* Standards-Version: 4.0.1 (no changes).
* No need to Break/Replace previous -dev depending on previous gnat.
2017-07-07 - Nicolas Boulenguez <nicolas@debian.org>
libgtkada (17.0.2017-1) experimental; urgency=medium
* New upstream release built with gnat-7. No ALI/SO bump in experimental.
* Debhelper 10.
Let dh and dh_autoreconf generate ./configure.
Remove explicit rules targets leading dh to run ./configure twice.
* Standards-Version: 4.0.0.
DEB_BUILD_OPTIONS=nodoc. HTTPS copyright format URL.
* Drop obsolete preinst script and Break/Replace: libgtkada2-doc.
* usr-bin-gnatchop-856274.diff to work-around gnat bug #856274.
* Sort testgtk tar options, thanks to Steve Langasek. Closes: #831001.
* gnat-7 handles SOURCE_DATE_EPOCH directly.
* Allow -doc package to satisfy Multi-Arch: foreign dependencies.
* Move manpage from excluded docs/ to debian/.
* Patch testgtk.gpr for usage outside source tree without opengl.
2016-08-18 - Nicolas Boulenguez <nicolas@debian.org>
libgtkada (16.1.0-1) experimental; urgency=medium
* New upstream release.
Bump SO version, rename/break/replace -dev package per Ada policy.
* Upstream drops support for gtkada-config and pkg-config.
-dev does not Depend: -bin for gtkada-config nor Suggest: pkg-config.
* Build-Depend: libfontconfig1-dev because of new binding.
* build_flags.diff: remove part refused upstream.
* Ensure that ./configure uses gnatgcc instead of gcc.
* Enable PIE in hardening flags for executables.
* Do not bother touching timestamps for C sources.
* Make watch file more readable with version 4.
2016-04-26 - Nicolas Boulenguez <nicolas@debian.org>
libgtkada (3.8.3-1) unstable; urgency=medium
* Build with gnat-6, gprbuild >= 2015, upload to unstable.
* Enable all hardening flags, but PIE because we build a shared library.
Let LDFLAGS also affect local libraries in linker command line.
* Switch from manual -dbg packages to automatic -dbgsym packages.
* Standards-Version: 3.9.8 (no changes).

See Also

Package Description
libgtkd-3-0_3.8.5-1_i386.deb GTK+ graphical user interface library - D bindings
libgtkd-3-dev_3.8.5-1_i386.deb GTK+ graphical user interface library - development files for D
libgtkdatabox-dev_0.9.3.1-1_i386.deb Gtk+ library to display large amounts of numerical data (development)
libgtkdatabox-doc_0.9.3.1-1_all.deb Gtk+ library to display large amounts of numerical data (API doc)
libgtkdatabox0-glade_0.9.3.1-1_i386.deb Gtk+ library to display large amounts of numerical data (glade API)
libgtkdatabox0-libglade_0.9.3.1-1_i386.deb Gtk+ library to display large amounts of numerical data (glade lib)
libgtkdatabox0_0.9.3.1-1_i386.deb Gtk+ library to display large amounts of numerical data
libgtkdsv-3-0_3.8.5-1_i386.deb GTK+ syntax highlighting widget - D bindings
libgtkdsv-3-dev_3.8.5-1_i386.deb GTK+ syntax highlighting widget - development files for D
libgtkextra-3.0-doc_3.3.4-1_all.deb documentation for libgtkextra-x11-3.0
libgtkextra-3.0_3.3.4-1_i386.deb useful set of widgets for creating GUI's for GTK+
libgtkextra-dev_3.3.4-1_i386.deb development files for libgtkextra-x11-3.0
libgtkgl2.0-1_2.0.1-2.2_i386.deb OpenGL context support for GTK+ (shared libraries)
libgtkgl2.0-dev_2.0.1-2.2_i386.deb OpenGL context support for GTK+ (development files)
libgtkglext1-dev_1.2.0-9_i386.deb OpenGL Extension to GTK+ (development files)
Advertisement
Advertisement