libgpiv3_0.6.1-7+b1_i386.deb


Advertisement

Description

libgpiv3 - library for Particle Image Velocimetry (PIV)

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libgpiv3_0.6.1-7+b1_i386.deb
Package name libgpiv3
Package version 0.6.1
Package release 7+b1
Package architecture i386
Package type deb
Category libs role::shared-lib
Homepage http://libgpiv.sourceforge.net/
License -
Maintainer Debian QA Group <packages@qa.debian.org>
Download size 86.40 KB
Installed size 273.00 KB
This library contains functions for evaluating images from a fluid
flow by means of Particle Image Velocimetry (PIV).
PIV is a way to film the wind or liquid flows. It uses a sequence of
at least two images that are recorded with a well controlled
separation time in-between. Tracer particles that are resident in the
fluid may be illuminated by a light source, mostly a laser, that has
been re-shaped into a sheet of light. In this way, the average
displacement and the deformation of the image texture is
obtained. Applying this analyses on small samples of the images on a
(rectangular) grid results into an instantaneous velocity field of
the fluid flow. PIV may also be applied for other purposes, like
deformations and vibrations of solid surfaces.
This library includes the core functions for image recording,
processing, interrogation, PIV data validation, post-processing,
input/output functions and memory allocation.

Alternatives

Package Version Architecture Repository
libgpiv3_0.6.1-7+b1_amd64.deb 0.6.1 amd64 Debian Main
libgpiv3 - - -

Requires

Name Value
libc6 >= 2.7
libfftw3-double3 >= 3.3.5
libglib2.0-0 >= 2.35.9
libgomp1 >= 4.9
libgpiv3-common -
libgsl23 >= 2.5
libgslcblas0 >= 2.4
libhdf5-103 -
libpng16-16 >= 1.6.2-1

Conflicts

Name Value
libgpiv-mpi3 -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libgpiv3_0.6.1-7+b1_i386.deb
Source Package libgpiv

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libgpiv3 deb package:
    # sudo apt-get install libgpiv3

Files

Path
/usr/lib/i386-linux-gnu/libgpiv.so.3
/usr/lib/i386-linux-gnu/libgpiv.so.3.0.0
/usr/share/doc/libgpiv3/changelog.Debian.gz
/usr/share/doc/libgpiv3/changelog.Debian.i386.gz
/usr/share/doc/libgpiv3/changelog.gz
/usr/share/doc/libgpiv3/copyright

Changelog

2017-09-01 - Steve Langasek <vorlon@debian.org>
libgpiv (0.6.1-7) unstable; urgency=medium
* Fix libgpiv3-dev to depend on either of the conflicting implementations,
not both.  Closes: #869549.
2017-07-23 - Tobias Frost <tobi@debian.org>
libgpiv (0.6.1-6) unstable; urgency=medium
* QA upload.
* wrap-and-sort
* Bump d/compat to level 10
* Rebuild d/rules in short debhelper format
* Enable multiarch
* Remove dh_make boilerplate code from d/watch (fiexs lintian warning)
* d/control: Add conflicts for library variants
* d/control: Add Build-Depends-Indep for arch-independent build, remove
doxygen from Build-Depend
2017-07-23 - Tobias Frost <tobi@debian.org>
libgpiv (0.6.1-5) unstable; urgency=medium
* QA upload.
* Change maintainer to the QA group.
* New patch 05-doxygen.diff
- fix out-of-debian patched files
- fix privacy breach lintian error.
* Change to automatic debug package.
* Add CVS-* fields to d/control, pointing to collab-maint
* Do not embedd doxygen's md5 files in the -doc package
* Set d/source/format to 3.0 (quilt)
2016-10-30 - Gilles Filippini <pini@debian.org>
libgpiv (0.6.1-4.4) unstable; urgency=medium
* Non-maintainer upload.
* New patch 04-avoid-bool-keyword.diff to fix FTBFS against HDF5 1.10
(closes: #841962)
2016-01-07 - Tobias Frost <tobi@debian.org>
libgpiv (0.6.1-4.3) unstable; urgency=medium
* Non-maintainer upload.
* Fix FTBFS with libpng16, using patch from Nobuhiro (Closes: #650489)
* Update build dependencies for GSL 2.x", patch from Bas (Closes: #807207)
2015-06-14 - akira <marivalenm@gmail.com>
libgpiv (0.6.1-4.2) unstable; urgency=medium
* Non-maintainer upload.
* Remove $datetime from doxygen_footer.html to make package reproducible (closes: #788737)
2014-08-06 - Gilles Filippini <pini@debian.org>
libgpiv (0.6.1-4.1) unstable; urgency=low
* Non-maintainer upload.
* Support hdf5 1.8.13 new packaging layout (closes: #756674).
2012-02-01 - Gerber van der Graaf <gerber_graaf@users.sourceforge.net>
libgpiv (0.6.1-4) unstable; urgency=low
* Adapted Hdf5 calls to libhdf5-1.8.8 API. Closes: #657199
2009-10-09 - Gerber van der Graaf <gerber_graaf@users.sourceforge.net>
libgpiv (0.6.1-3) unstable; urgency=low
* Repairs failing to install, trying to overwrite other packages 
files. Closes: #540494
* Repairs unrealistic interrogation results, due to OMP. Closes: #545830
2008-11-22 - Gerber van der Graaf <gerber_graaf@users.sourceforge.net>
libgpiv (0.6.1-1) unstable; urgency=low
* New upstream release
* Added Message Passing Interface (MPI) version of library package

See Also

Package Description
libgpm-dev_1.20.7-5_i386.deb General Purpose Mouse - development files
libgpm2_1.20.7-5_i386.deb General Purpose Mouse - shared library
libgpod-cil-dev_0.8.3-13_i386.deb CLI bindings for libgpod -- development files
libgpod-cil_0.8.3-13_i386.deb CLI bindings for libgpod
libgpod-common_0.8.3-13_i386.deb common files for libgpod
libgpod-dev_0.8.3-13_i386.deb development files for libgpod
libgpod-doc_0.8.3-13_all.deb documentation for libgpod
libgpod4_0.8.3-13_i386.deb library to read and write songs and artwork to an iPod
libgportugol-dev_1.1-5_i386.deb Development files for the G-Portugol library
libgportugol0_1.1-5_i386.deb G-Portugol library
libgpr18_2018-6_i386.deb support for programs processing GNAT projects (runtime)
libgpr2-dev_2018-6_i386.deb support for programs processing GNAT projects (development)
libgps-dev_3.17-7_i386.deb Global Positioning System - development files
libgps-point-perl_0.20-2_all.deb module providing an object interface for a GPS point
libgps23_3.17-7_i386.deb Global Positioning System - library
Advertisement
Advertisement