libgpg-error-dev_1.35-1_i386.deb


Advertisement

Description

libgpg-error-dev - GnuPG development runtime library (developer tools)

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libgpg-error-dev_1.35-1_i386.deb
Package name libgpg-error-dev
Package version 1.35
Package release 1
Package architecture i386
Package type deb
Category devel::library libdevel role::devel-lib security::cryptography suite::gnu
Homepage https://www.gnupg.org/related_software/libgpg-error/
License -
Maintainer Debian GnuPG Maintainers <pkg-gnupg-maint@lists.alioth.debian.org>
Download size 126.65 KB
Installed size 442.00 KB
Library that defines common error values, messages, and common
runtime functionality for all GnuPG components.  Among these are GPG,
GPGSM, GPGME, GPG-Agent, libgcrypt, pinentry, SmartCard Daemon and
possibly more in the future.
It will likely be renamed "gpgrt" in the future.
This package contains the headers and other files needed to compile
against this library.

Alternatives

Package Version Architecture Repository
libgpg-error-dev_1.35-1_amd64.deb 1.35 amd64 Debian Main
libgpg-error-dev - - -

Requires

Name Value
libgpg-error0 = 1.35-1

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libgpg-error-dev_1.35-1_i386.deb
Source Package libgpg-error

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libgpg-error-dev deb package:
    # sudo apt-get install libgpg-error-dev

Files

Path
/usr/bin/gpg-error-config
/usr/bin/gpgrt-config
/usr/include/i386-linux-gnu/gpg-error.h
/usr/include/i386-linux-gnu/gpgrt.h
/usr/lib/i386-linux-gnu/libgpg-error.a
/usr/lib/i386-linux-gnu/libgpg-error.la
/usr/lib/i386-linux-gnu/libgpg-error.so
/usr/lib/i386-linux-gnu/pkgconfig/gpg-error.pc
/usr/share/aclocal/gpg-error.m4
/usr/share/aclocal/gpgrt.m4
/usr/share/doc/libgpg-error-dev/README.gz
/usr/share/doc/libgpg-error-dev/TODO.Debian
/usr/share/doc/libgpg-error-dev/changelog.Debian.gz
/usr/share/doc/libgpg-error-dev/changelog.gz
/usr/share/doc/libgpg-error-dev/copyright
/usr/share/doc/libgpg-error-dev/errorref.txt.gz
/usr/share/info/gpgrt.info.gz
/usr/share/lintian/overrides/libgpg-error-dev
/usr/share/man/man1/gpg-error-config.1.gz
/usr/share/man/man1/gpgrt-config.1.gz

Changelog

2019-01-31 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
libgpg-error (1.35-1) unstable; urgency=medium
* New upstream version
* refresh patches
* Standards-Version: bump to 4.3.0 (no changes needed)
* move to debhelper 12
* updated symbols
2018-12-14 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
libgpg-error (1.33-3) unstable; urgency=medium
* mark libgpg-error-mingw-w64-dev Multi-Arch: foreign
(thanks, Multiarch hinter!)
* avoid the -unknown suffix in gpgrt version string
* added new "build" autopkgtest
2018-12-14 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
libgpg-error (1.33-2) unstable; urgency=medium
* fix up autopkgtest
2018-12-14 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
libgpg-error (1.33-1) unstable; urgency=medium
* New upstream release
* Re-export upstream signing key without extra signatures.
* refresh patches
* ship correct manpages for gpgrt-config
* update symbols file
* add Build-Depends-Package to symbols file
* ship gpg-error.pc for pkg-config
* remember that we ship l10n files from the windows 64-bit build
* remember that we do not ship gpgrt-config.1 from the arch-indep builds
2018-10-19 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
libgpg-error (1.32-3) unstable; urgency=medium
* indicate that libgpg-error-l10n Enhances: libgpg-error0
* ship l10n files from arch-indep build (Closes: #911377)
2018-10-12 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
libgpg-error (1.32-2) unstable; urgency=medium
[ Sven Joachim ]
* Move the translation files to a new libgpg-error-l10n package
(Closes: #872806)
[ Wookey ]
* Add support for arm64ilp32 (Closes: #869605)
[ Daniel Kahn Gillmor ]
* Standards-Version: bumped to 4.2.1 (no changes needed)
2018-07-13 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
libgpg-error (1.32-1) unstable; urgency=medium
* new upstream release
* fixup patch
* Standards-Version: bump to 4.1.5 (no changes needed)
2018-05-02 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
libgpg-error (1.31-1) unstable; urgency=medium
* new upstream release
2018-05-01 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
libgpg-error (1.30-1) unstable; urgency=medium
* new upstream release
* drop patches already upstream
2018-04-16 - Daniel Kahn Gillmor <dkg@fifthhorseman.net>
libgpg-error (1.29-4) unstable; urgency=medium
* split out new gpgrt-tools package (Closes: #895770)
* clean up package descriptions

See Also

Package Description
libgpg-error-l10n_1.35-1_all.deb library of error values and messages in GnuPG (localization files)
libgpg-error-mingw-w64-dev_1.35-1_all.deb library of error values and messages in GnuPG (Windows development)
libgpg-error0_1.35-1_i386.deb GnuPG development runtime library
libgpgme++2v5_4.14.10-11_i386.deb C++ wrapper library for GPGME
libgpgme-dev_1.12.0-6_i386.deb GPGME - GnuPG Made Easy (development files)
libgpgme11_1.12.0-6_i386.deb GPGME - GnuPG Made Easy (library)
libgpgmepp-dev_1.12.0-6_i386.deb C++ and Qt bindings for GPGME (development files)
libgpgmepp-doc_1.12.0-6_all.deb C++ and Qt bindings for GPGME (documentation for developers)
libgpgmepp6_1.12.0-6_i386.deb C++ wrapper library for GPGME
libgphobos-7-dev_7.4.0-6_i386.deb Phobos D standard library
libgphobos-8-dev-amd64-cross_8.3.0-2cross1_all.deb Phobos D standard library
libgphobos-8-dev-armel-cross_8.3.0-2cross1_all.deb Phobos D standard library
libgphobos-8-dev-armhf-cross_8.3.0-2cross1_all.deb Phobos D standard library
libgphobos-8-dev-i386-cross_8.3.0-2cross1_all.deb Phobos D standard library
libgphobos-8-dev-x32-cross_8.3.0-2cross2_all.deb Phobos D standard library
Advertisement
Advertisement