libglib-object-introspection-perl_0.047-1_i386.deb


Advertisement

Description

libglib-object-introspection-perl - Perl bindings for gobject-introspection libraries

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libglib-object-introspection-perl_0.047-1_i386.deb
Package name libglib-object-introspection-perl
Package version 0.047
Package release 1
Package architecture i386
Package type deb
Category devel::lang:perl devel::library implemented-in::c implemented-in::perl perl role::devel-lib
Homepage https://metacpan.org/release/Glib-Object-Introspection
License -
Maintainer Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>
Download size 69.66 KB
Installed size 234.00 KB
GObject is an abstraction layer that allows programming with an object
paradigm that is compatible with many languages. It is a part of Glib,
the core library used to build GTK+ and GNOME.
This package contains Glib::Object::Introspection, the Perl binding
generator for libraries that support gobject-introspection, such as
GTK+, WebKit, libsoup and many more.
To use perli11ndoc, the Perl introspection documentation tool, the
-dev version of the introspected library must be installed. For
example, perli11ndoc can only show documentation for libgtk3-perl if
libgtk-3-dev is installed.

Alternatives

Package Version Architecture Repository
libglib-object-introspection-perl_0.047-1_amd64.deb 0.047 amd64 Debian Main
libglib-object-introspection-perl - - -

Requires

Name Value
libc6 >= 2.4
libffi6 >= 3.0.4
libgirepository-1.0-1 >= 1.33.10
libglib-perl >= 3:1.320
libglib2.0-0 >= 2.24.0
perl >= 5.28.1-4
perlapi-5.28.1 -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libglib-object-introspection-perl_0.047-1_i386.deb
Source Package libglib-object-introspection-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libglib-object-introspection-perl deb package:
    # sudo apt-get install libglib-object-introspection-perl

Files

Path
/usr/bin/perli11ndoc
/usr/lib/i386-linux-gnu/perl5/5.28/Glib/Object/Introspection.pm
/usr/lib/i386-linux-gnu/perl5/5.28/Glib/Object/Introspection/Install/Files.pm
/usr/lib/i386-linux-gnu/perl5/5.28/auto/Glib/Object/Introspection/Introspection.so
/usr/share/doc/libglib-object-introspection-perl/README
/usr/share/doc/libglib-object-introspection-perl/changelog.Debian.gz
/usr/share/doc/libglib-object-introspection-perl/changelog.gz
/usr/share/doc/libglib-object-introspection-perl/copyright
/usr/share/man/man3/Glib::Object::Introspection.3pm.gz

Changelog

2019-02-05 - intrigeri <intrigeri@debian.org>
libglib-object-introspection-perl (0.047-1) unstable; urgency=medium
* Import new upstream release.
2018-10-21 - intrigeri <intrigeri@debian.org>
libglib-object-introspection-perl (0.046-1) unstable; urgency=medium
* Import new upstream release.
* Declare compliance with policy 4.2.1.
* Bump debhelper compatibility level to 11.
2018-05-25 - intrigeri <intrigeri@debian.org>
libglib-object-introspection-perl (0.045-1) unstable; urgency=medium
[ oldtechaa ]
* Document that the base library devel packages must be installed.
(Closes: #891339)
* Add libxml-libxml-perl to Suggests, needed for perli11ndoc.
(Closes: #891334)
[ intrigeri ]
* Import new upstream release.
* Update upstream repo location.
* Declare compliance with Standards-Version 4.1.4.
2018-03-03 - intrigeri <intrigeri@debian.org>
libglib-object-introspection-perl (0.044-2) unstable; urgency=medium
[ Damyan Ivanov ]
* declare conformance with Policy 4.1.3 (no changes needed)
[ Salvatore Bonaccorso ]
* Update Vcs-* headers for switch to salsa.debian.org
[ intrigeri ]
* Drop runtime dependency on libextutils-depends-perl
and libextutils-pkgconfig-perl (Closes: #891891).
* Update Lintian overrides wrt. renamed tag.
2017-11-11 - Damyan Ivanov <dmn@debian.org>
libglib-object-introspection-perl (0.044-1) unstable; urgency=medium
* Team upload
* New upstream version 0.044
* declare conformance with Policy 4.1.1 (no changes needed)
2017-06-24 - intrigeri <intrigeri@debian.org>
libglib-object-introspection-perl (0.043-2) unstable; urgency=medium
[ gregor herrmann ]
* autopkgtests: build test libraries before running smoke test.
(Closes: #865725)
[ intrigeri ]
* Declare compliance with Standards-Version 4.0.0 (no change required).
* Bump debhelper compatibility level to 10,
adjust build-dependencies accordingly.
2017-06-23 - intrigeri <intrigeri@debian.org>
libglib-object-introspection-perl (0.043-1) unstable; urgency=medium
* Import new upstream release.
2016-12-24 - intrigeri <intrigeri@debian.org>
libglib-object-introspection-perl (0.042-1) unstable; urgency=medium
* Import new upstream release.
* Drop Fix-occuring-typo-in-POD.patch: applied upstream.
2016-11-27 - intrigeri <intrigeri@debian.org>
libglib-object-introspection-perl (0.041-1) unstable; urgency=medium
[ Salvatore Bonaccorso ]
* debian/control: Use HTTPS transport protocol for Vcs-Git URI
[ gregor herrmann ]
* debian/copyright: change Copyright-Format 1.0 URL to HTTPS.
* debian/upstream/metadata: change GitHub/CPAN URL(s) to HTTPS.
[ intrigeri ]
* Import new upstream release.
* Bump Standards-Version to 3.9.8: no change required.
* Fix-occuring-typo-in-POD.patch: new patch.
2016-01-02 - intrigeri <intrigeri@debian.org>
libglib-object-introspection-perl (0.040-2) unstable; urgency=medium
* Upload to unstable.

See Also

Package Description
libglib-perl_1.329-1_i386.deb interface to the GLib and GObject libraries
libglib2.0-0_2.58.3-2+deb10u1_i386.deb GLib library of C routines
libglib2.0-bin_2.58.3-2+deb10u1_i386.deb Programs for the GLib library
libglib2.0-cil-dev_2.12.40-2_i386.deb CLI binding for the GLib utility library 2.12
libglib2.0-cil_2.12.40-2_i386.deb CLI binding for the GLib utility library 2.12
libglib2.0-data_2.58.3-2+deb10u1_all.deb Common files for GLib library
libglib2.0-dev-bin_2.58.3-2+deb10u1_i386.deb Development utilities for the GLib library
libglib2.0-dev_2.58.3-2+deb10u1_i386.deb Development files for the GLib library
libglib2.0-doc_2.58.3-2+deb10u1_all.deb Documentation files for the GLib library
libglib2.0-tests_2.58.3-2+deb10u1_i386.deb GLib library of C routines - installed tests
libglib3.0-cil-dev_2.99.3-3_i386.deb CLI binding for the GLib utility library 2.12
libglib3.0-cil_2.99.3-3_i386.deb CLI binding for the GLib library of C routines
libglibd-2.0-0_2.0.2-1_i386.deb GLib library of C routines - D bindings
libglibd-2.0-dev_2.0.2-1_i386.deb GLib library of C routines - development files for D
libglibmm-2.4-1v5_2.58.0-2_i386.deb C++ wrapper for the GLib toolkit (shared libraries)
Advertisement
Advertisement