libglademm-2.4-1v5_2.6.7-6_i386.deb


Advertisement

Description

libglademm-2.4-1v5 - C++ wrappers for libglade2 (shared library)

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libglademm-2.4-1v5_2.6.7-6_i386.deb
Package name libglademm-2.4-1v5
Package version 2.6.7
Package release 6
Package architecture i386
Package type deb
Category oldlibs role::shared-lib
Homepage http://www.gtkmm.org/
License -
Maintainer Adrian Bunk <bunk@debian.org>
Download size 25.28 KB
Installed size 69.00 KB
Libglade is a library which enables an application to build its graphical
interface from an XML file (generated by Glade) at runtime. libglademm is
the C++ wrapper for libglade.
libglade and libglademm have been deprecated since 2009. New code should
use GtkBuilder (part of Gtk 3), or its C++ wrapper in gtkmm.
This package contains shared libraries.
This package is for legacy applications and no longer used by GNOME.

Alternatives

Package Version Architecture Repository
libglademm-2.4-1v5_2.6.7-6_amd64.deb 2.6.7 amd64 Debian Main
libglademm-2.4-1v5 - - -

Requires

Name Value
libatk1.0-0 >= 1.12.4
libatkmm-1.6-1v5 >= 2.24.0
libc6 >= 2.4
libcairo2 >= 1.2.4
libcairomm-1.0-1v5 >= 1.12.0
libfontconfig1 >= 2.12.6
libfreetype6 >= 2.2.1
libgcc1 >= 1:3.0
libgdk-pixbuf2.0-0 >= 2.22.0
libglade2-0 >= 1:2.6.4-2~
libglib2.0-0 >= 2.16.0
libglibmm-2.4-1v5 >= 2.54.0
libgtk2.0-0 >= 2.8.0
libgtkmm-2.4-1v5 >= 1:2.24.0
libpango-1.0-0 >= 1.14.0
libpangocairo-1.0-0 >= 1.14.0
libpangoft2-1.0-0 >= 1.14.0
libpangomm-1.4-1v5 >= 2.40.0
libsigc++-2.0-0v5 >= 2.2.0
libstdc++6 >= 5.2
libxml2 >= 2.6.27

Conflicts

Name Value
libglademm-2.4-1 -
libglademm-2.4-1c2 -
libglademm-2.4-1c2a -

Replaces

Name Value
libglademm-2.4-1 -
libglademm-2.4-1c2 -
libglademm-2.4-1c2a -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libglademm-2.4-1v5_2.6.7-6_i386.deb
Source Package libglademm2.4

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libglademm-2.4-1v5 deb package:
    # sudo apt-get install libglademm-2.4-1v5

Files

Path
/usr/lib/i386-linux-gnu/libglademm-2.4.so.1
/usr/lib/i386-linux-gnu/libglademm-2.4.so.1.0.5
/usr/share/doc/libglademm-2.4-1v5/AUTHORS
/usr/share/doc/libglademm-2.4-1v5/NEWS.gz
/usr/share/doc/libglademm-2.4-1v5/README
/usr/share/doc/libglademm-2.4-1v5/changelog.Debian.gz
/usr/share/doc/libglademm-2.4-1v5/changelog.gz
/usr/share/doc/libglademm-2.4-1v5/copyright

Changelog

2018-08-31 - Adrian Bunk <bunk@debian.org>
libglademm2.4 (2.6.7-6) unstable; urgency=medium
* New maintainer. (Closes: #885078, #896598)
* Use multiarch paths, patch from Helmut Grohne. (Closes: #850873)
* Switch from -dbg to -dbgsym.
* Update the package descriptions for the deprecated status.
* Switch to source format 3.0 (quilt).
* debhelper compat 6 -> 7.
2015-08-18 - Simon McVittie <smcv@debian.org>
libglademm2.4 (2.6.7-5) unstable; urgency=medium
* Team upload.
* Rename libglademm-2.4-1c2a to libglademm-2.4-1v5 for the
g++-5 ABI transition. (Starts transition: #795920)
- bump build-dependency on gtkmm to a g++-5-transitioned version
* Move source and library packages to oldlibs. libglade has been
officially deprecated since 2009.
2014-09-09 - Andreas Henriksson <andreas@fatal.se>
libglademm2.4 (2.6.7-4) unstable; urgency=medium
Brown paper bag release.
* (svn) add debian/patch/series so patch(es) are actually applied
- missing in last upload.
* The new debian/patches/series also enables the old existing
patch debian/patches/10_devhelp_index_path_fix.patch
which was unused before but still looks valid and applies.
2014-09-09 - Andreas Henriksson <andreas@fatal.se>
libglademm2.4 (2.6.7-3) unstable; urgency=low
[ Emilio Pozuelo Monfort ]
* debian/control.in,
debian/rules:
+ Remove the chrpath hack, it's been fixed in libtool.
[ Josselin Mouette ]
* Update repository URL.
[ Daniel Schepler ]
* Update libtool at build time using dh-autoreconf, in order to fix a
build failure on x32. (Closes: #702355)
2009-05-15 - Deng Xiyue <manphiz-guest@users.alioth.debian.org>
libglademm2.4 (2.6.7-2) unstable; urgency=low
* `make -C examples clean` after `make install` to prevent shipping
unexpected files.
* Add README.Debian with instructions to build examples.
* Update debian/copyright to conform to latest DEP 5.
+ Fix incorrect license.
+ Point to versioned license files.
* Update Standard-Version to 3.8.1.
* libglademm-2.4-dbg is in section debug as per new override.
2008-09-24 - Deng Xiyue <manphiz-guest@users.alioth.debian.org>
libglademm2.4 (2.6.7-1) unstable; urgency=low
[ Deng Xiyue ]
* Refined debian/rules to set variables SHARED_PKG and DOC_PKG by sed
from debian/control and use variable SHVER for shlibs version, and
refine and reformat corresponding rules accordingly.
* Fix section in doc-base reference.
* Add `DM-Upload-Allowed: yes' field.  Thanks Loïc for advocacy.
* Add dpkg-dev >= 1.14.16 to Build-Depends for DM usage.
* Remove doc-base from Build-Depends as it's not b-deped on.
* Add ${shlibs:Depends} to all Depends fields as recommended.
* Use machine-interpretable format for debian/copyright.
* Use chrpath to get rid of rpath on 64bit machines.  Build-Depends on
chrpath accordingly, and add rules to debian/rules.
* New upstream release.  Only Windoze build improvement and more examples.
* Update Standard-Version to 3.8.0.  No change needed.
[ Loic Minier ]
* Properly anchor package name regexp.
* Fix package names regexp s/glad/glade.
2008-02-13 - Deng Xiyue <manphiz-guest@users.alioth.debian.org>
libglademm2.4 (2.6.6-1) unstable; urgency=low
* New upstream release.
+ Bump libglade2-dev dependency to >=1:2.6.1 as per configure.in.
+ Upstream no longer ships empty README file, so remove corresponding
exclude rules from debian/rules.
* Correct copyright holder and correct license pointer to
/usr/share/common-licenses/LGPL-2.1 in debian/copyright.
* Refined debian/watch to check for number based version, and update
watch version to 3.
* Bump compat level to 6, let debhelper >= 6 accordingly, and let
cdbs >= 0.4.51 to avoid empty -dbg bug.
* Remove 70_relibtoolize.patch, as it is seemed unneeded now.
* Change libgtkmm-2.4-dev dependency to >= 1:2.6.0 as per upstream configure
script, and drop the -1 postfix as per lintian.
* Add ${shlibs:Depends} to -dev package.

See Also

Package Description
libglademm-2.4-dev_2.6.7-6_i386.deb C++ wrappers for libglade2 (development files)
libglademm-2.4-doc_2.6.7-6_all.deb C++ wrappers for libglade2 (documentation)
libgladeui-2-6_3.22.1-3_i386.deb GTK+ User Interface Build core library
libgladeui-common_3.22.1-3_all.deb GTK+ User Interface Build core library (common files)
libgladeui-dev_3.22.1-3_i386.deb GTK+ User Interface Build core library (development files)
libgladeui-doc_3.22.1-3_all.deb GTK+ User Interface Build core library (documentation)
libglapi-mesa_18.3.6-2_i386.deb free implementation of the GL API -- shared library
libglazedlists-java-doc_1.9.1-2_all.deb java list transformation library (documentation)
libglazedlists-java_1.9.1-2_all.deb java list transformation library
libglbinding-dev_2.1.1-2_i386.deb development files for glbinding
libglbinding2_2.1.1-2_i386.deb cross-platform C++ binding for OpenGL
libglbsp-dev_2.24-4_i386.deb node builder library for OpenGL-based Doom-style games (headers)
libglbsp3_2.24-4_i386.deb node builder library for OpenGL-based Doom-style games
libglc-dev_0.7.2-6_i386.deb Implementation of SGI's OpenGL Character Renderer (GLC)
libglc0_0.7.2-6_i386.deb QuesoGLC OpenGL Character Renderer (GLC) implementation
Advertisement
Advertisement