libgitlab-api-v4-perl_0.16-1_all.deb


Advertisement

Description

libgitlab-api-v4-perl - GitLab API v4 module and command-line client

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libgitlab-api-v4-perl_0.16-1_all.deb
Package name libgitlab-api-v4-perl
Package version 0.16
Package release 1
Package architecture all
Package type deb
Category perl
Homepage https://metacpan.org/release/GitLab-API-v4
License -
Maintainer Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>
Download size 68.31 KB
Installed size 482.00 KB
GitLab::API::v4 provides a one-to-one interface with the GitLab API v4.
Detailed information in GitLab's API can be found at
http://doc.gitlab.com/ce/api/README.html.
This package also includes the gitlab-api-v4 command-line interface (CLI).

Alternatives

Package Version Architecture Repository
libgitlab-api-v4-perl_0.16-1_all.deb 0.16 all Debian Main
libgitlab-api-v4-perl - - -

Requires

Name Value
libconst-fast-perl >= 0.014
libhttp-tiny-multipart-perl -
libhttp-tiny-perl >= 0.59
libio-prompter-perl >= 0.004014
libjson-perl >= 2.59
liblog-any-adapter-screen-perl >= 0.13
liblog-any-perl >= 1.703
libmoo-perl >= 2.003000
libnamespace-clean-perl >= 0.27
libpath-tiny-perl >= 0.079
libstrictures-perl >= 2.000003
libtry-tiny-perl >= 0.28
libtype-tiny-perl >= 1.002001
liburi-perl >= 1.62
perl -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libgitlab-api-v4-perl_0.16-1_all.deb
Source Package libgitlab-api-v4-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libgitlab-api-v4-perl deb package:
    # sudo apt-get install libgitlab-api-v4-perl

Files

Path
/usr/bin/gitlab-api-v4
/usr/share/bash-completion/completions/gitlab-api-v4
/usr/share/doc/libgitlab-api-v4-perl/NEWS.Debian.gz
/usr/share/doc/libgitlab-api-v4-perl/changelog.Debian.gz
/usr/share/doc/libgitlab-api-v4-perl/changelog.gz
/usr/share/doc/libgitlab-api-v4-perl/copyright
/usr/share/lintian/overrides/libgitlab-api-v4-perl
/usr/share/man/man1/gitlab-api-v4.1p.gz
/usr/share/man/man3/GitLab::API::v4.3pm.gz
/usr/share/man/man3/GitLab::API::v4::Config.3pm.gz
/usr/share/man/man3/GitLab::API::v4::Constants.3pm.gz
/usr/share/man/man3/GitLab::API::v4::Paginator.3pm.gz
/usr/share/man/man3/GitLab::API::v4::RESTClient.3pm.gz
/usr/share/perl5/GitLab/API/v4.pm
/usr/share/perl5/GitLab/API/v4/Config.pm
/usr/share/perl5/GitLab/API/v4/Constants.pm
/usr/share/perl5/GitLab/API/v4/Paginator.pm
/usr/share/perl5/GitLab/API/v4/RESTClient.pm

Changelog

2019-02-19 - gregor herrmann <gregoa@debian.org>
libgitlab-api-v4-perl (0.16-1) unstable; urgency=medium
* Import upstream version 0.16.
* Update upstream contact.
* Update build dependencies.
* Update a lintian override (changed line number).
* debian/rules: add a manual target to test module regeneration.
2019-02-15 - gregor herrmann <gregoa@debian.org>
libgitlab-api-v4-perl (0.15-2) unstable; urgency=medium
* Add bash completion for gitlab-api-v4:
+ Add debian/utils/make-mapping.py by Dmitry Bogatov: Script to generate
bash completion for gitlab-api-v4 from the Perl module and the Gitlab
API documentation.
+ debian/copyright: add Dmitry Bogatov for debian/utils/make-mapping.py.
+ Add debian/utils/update-shell-completions as a wrapper to download the
gitlab package and call the script for creating the bash completion.
Also hook it up as a manual target in debian/rules.
+ Install the bash completion file. Add a build dependency on bash-
completion, add dh_bash-completion to debian/rules, and create a
debian/libgitlab-api-v4-perl.bash-completion file.
Thanks to Dmitry Bogatov for the bug report and the generation script.
Closes: #913055
2019-01-10 - gregor herrmann <gregoa@debian.org>
libgitlab-api-v4-perl (0.15-1) unstable; urgency=medium
* Import upstream version 0.15.
* Update years of upstream and packaging copyright.
* Declare compliance with Debian Policy 4.3.0.
* Bump debhelper compatibility level to 11.
* Update (build) dependency on dual-lifed HTTP::Tiny.
* Add a pointer about breaking changes in the gitlab-api-v4 script
to debian/NEWS.
2018-12-09 - gregor herrmann <gregoa@debian.org>
libgitlab-api-v4-perl (0.14-1) unstable; urgency=medium
* Import upstream version 0.14.
2018-11-09 - Xavier Guimard <yadd@debian.org>
libgitlab-api-v4-perl (0.13-1) unstable; urgency=medium
* Team upload
* Import upstream version 0.13
* Update lintian-overrides
2018-09-17 - gregor herrmann <gregoa@debian.org>
libgitlab-api-v4-perl (0.12-1) unstable; urgency=medium
* Import upstream version 0.12.
* Update lintian override (change line number), and add new overrides for
the two library vs. application tags.
2018-09-02 - gregor herrmann <gregoa@debian.org>
libgitlab-api-v4-perl (0.11-1) unstable; urgency=medium
[ Laurent Baillet ]
* fix lintian wrong-path-for-interpreter error
[ gregor herrmann ]
* Import upstream version 0.11.
* Build-depend on perl 5.21.8 for MIME::Base64 3.15.
* Declare compliance with Debian Policy 4.2.1.
2018-06-06 - gregor herrmann <gregoa@debian.org>
libgitlab-api-v4-perl (0.10-1) unstable; urgency=medium
* Import upstream version 0.10.
* Drop delete_project_hook.patch, fixed upstream.
2018-06-04 - gregor herrmann <gregoa@debian.org>
libgitlab-api-v4-perl (0.09-1) unstable; urgency=medium
* Import upstream version 0.09.
* Update (build) dependencies.
* Refresh delete_project_hook.patch.
* Update lintian override (line number).
2018-06-02 - gregor herrmann <gregoa@debian.org>
libgitlab-api-v4-perl (0.08-2) unstable; urgency=medium
* Add patch to work around failure in delete_project_hook().

See Also

Package Description
libgivaro-dev_4.0.4-2_i386.deb arithmetic and algebraic computations - development files
libgivaro-doc_4.0.4-2_all.deb Documentation for Givaro
libgivaro9_4.0.4-2_i386.deb arithmetic and algebraic computations
libgiza0_1.1.0-1_i386.deb Lightweight scientific plotting library (shared library)
libgjs-dev_1.54.3-1_i386.deb Mozilla-based javascript bindings for the GNOME platform
libgjs0g_1.54.3-1_i386.deb Mozilla-based javascript bindings for the GNOME platform
libgkarrays-dev_2.1.0+dfsg-2_i386.deb library to query large collection of NGS sequences (development)
libgkarrays1_2.1.0+dfsg-2_i386.deb library to query large collection of NGS sequences
libgkeyfile-cil-dev_0.1-5_all.deb GObject-based wrapper library for GKeyFile -- CLI development files
libgkeyfile1.0-cil_0.1-5_all.deb GObject-based wrapper library for GKeyFile -- CLI bindings
libgl1-mesa-dev_18.3.6-2_i386.deb free implementation of the OpenGL API -- GLX development files
libgl1-mesa-dri_18.3.6-2_i386.deb free implementation of the OpenGL API -- DRI modules
libgl1-mesa-glx_18.3.6-2_i386.deb transitional dummy package
libgl1_1.1.0-1_i386.deb Vendor neutral GL dispatch library -- legacy GL support
libgl2ps-dev_1.4.0+dfsg1-2_i386.deb Lib providing high quality vector output for OpenGL application, dev files
Advertisement
Advertisement