libgit-wrapper-perl_0.048-1_all.deb


Advertisement

Description

libgit-wrapper-perl - Perl module to wrap git command-line interface

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libgit-wrapper-perl_0.048-1_all.deb
Package name libgit-wrapper-perl
Package version 0.048
Package release 1
Package architecture all
Package type deb
Category devel::lang:perl devel::library implemented-in::perl perl role::shared-lib
Homepage https://metacpan.org/release/Git-Wrapper
License -
Maintainer Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>
Download size 33.88 KB
Installed size 77.00 KB
Git::Wrapper provides an API for git that uses Perl data structures for
argument passing, instead of CLI-style --options as Git does.
Except as documented, every git subcommand is available as a method on
a Git::Wrapper object. Replace any hyphens in the git command with
underscores.

Alternatives

Package Version Architecture Repository
libgit-wrapper-perl_0.048-1_all.deb 0.048 all Debian Main
libgit-wrapper-perl - - -

Requires

Name Value
git -
libfile-chdir-perl -
libsort-versions-perl -
perl -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libgit-wrapper-perl_0.048-1_all.deb
Source Package libgit-wrapper-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libgit-wrapper-perl deb package:
    # sudo apt-get install libgit-wrapper-perl

Files

Path
/usr/share/doc/libgit-wrapper-perl/changelog.Debian.gz
/usr/share/doc/libgit-wrapper-perl/changelog.gz
/usr/share/doc/libgit-wrapper-perl/copyright
/usr/share/man/man3/Git::Wrapper.3pm.gz
/usr/share/man/man3/Git::Wrapper::Exception.3pm.gz
/usr/share/man/man3/Git::Wrapper::File::RawModification.3pm.gz
/usr/share/man/man3/Git::Wrapper::Log.3pm.gz
/usr/share/man/man3/Git::Wrapper::Status.3pm.gz
/usr/share/man/man3/Git::Wrapper::Statuses.3pm.gz
/usr/share/perl5/Git/Wrapper.pm
/usr/share/perl5/Git/Wrapper/Exception.pm
/usr/share/perl5/Git/Wrapper/Log.pm
/usr/share/perl5/Git/Wrapper/Status.pm
/usr/share/perl5/Git/Wrapper/Statuses.pm
/usr/share/perl5/Git/Wrapper/File/RawModification.pm

Changelog

2018-03-31 - gregor herrmann <gregoa@debian.org>
libgit-wrapper-perl (0.048-1) unstable; urgency=medium
* Team upload.
[ Alex Muntada ]
* Remove inactive pkg-perl members from Uploaders.
[ Salvatore Bonaccorso ]
* Update Vcs-* headers for switch to salsa.debian.org
[ gregor herrmann ]
* Import upstream version 0.048.
* Refresh 0001-Fix-test-9-in-basic.t-with-Git-2.9.patch (offset).
* Update years of packaging copyright.
* Declare compliance with Debian Policy 4.1.3.
* Bump debhelper compatibility level to 10.
2016-10-09 - Angel Abad <angel@debian.org>
libgit-wrapper-perl (0.047-1) unstable; urgency=medium
[ gregor herrmann ]
* Remove Tim Retout from Uploaders. Thanks for your work!
[ Angel Abad ]
* New upstream version 0.047
* debian/copyright: Update years.
* debian/control: Remove version libpath-class-perl in B-D-I.
* debian/patches/spelling.patch: Remove, applied upstream
* debian/patches/0001-Fix-test-9-in-basic.t-with-Git-2.9.patch:
Refresh patch.
2016-08-19 - gregor herrmann <gregoa@debian.org>
libgit-wrapper-perl (0.045-2) unstable; urgency=medium
* Team upload.
[ Salvatore Bonaccorso ]
* debian/control: Use HTTPS transport protocol for Vcs-Git URI
[ gregor herrmann ]
* debian/copyright: change Copyright-Format 1.0 URL to HTTPS.
* Add patch from upstream bug for compatibility with Git >= 2.9.0.
(Closes: #834793)
* Add patch to fix a typo in the documentation.
* Update years of packaging copyright.
* Declare compliance with Debian Policy 3.9.8.
2015-07-29 - Lucas Kanashiro <kanashiro.duarte@gmail.com>
libgit-wrapper-perl (0.045-1) unstable; urgency=medium
* Team upload.
* Import upstream version 0.045
* Set debhelper >= 9
2015-07-04 - gregor herrmann <gregoa@debian.org>
libgit-wrapper-perl (0.044-1) unstable; urgency=medium
* Team upload.
* Import upstream version 0.044.
* Update years of packaging copyright.
* Update (build) dependencies.
* Mark package as autopkgtest-able.
2014-11-14 - Angel Abad <angel@debian.org>
libgit-wrapper-perl (0.038-1) unstable; urgency=medium
* Imported Upstream version 0.038
* debian/copyright: Update debian/* years
2014-10-11 - gregor herrmann <gregoa@debian.org>
libgit-wrapper-perl (0.037-2) unstable; urgency=medium
* Team upload.
[ Salvatore Bonaccorso ]
* Update Vcs-Browser URL to cgit web frontend
[ gregor herrmann ]
* Add debian/upstream/metadata
* Drop patch no-devel-checkbin.patch,
libdevel-checkbin-perl is packaged now.
Add build dependency on libdevel-checkbin-perl.
* Add debian/upstream/metadata
* Declare compliance with Debian Policy 3.9.6.
2014-08-13 - Salvatore Bonaccorso <carnil@debian.org>
libgit-wrapper-perl (0.037-1) unstable; urgency=medium
* Team upload.
* Imported Upstream version 0.037
* Refresh no-devel-checkbin.patch patch
2014-07-31 - gregor herrmann <gregoa@debian.org>
libgit-wrapper-perl (0.035-1) unstable; urgency=medium
* Team upload.
* New upstream release.
2014-07-25 - Salvatore Bonaccorso <carnil@debian.org>
libgit-wrapper-perl (0.034-1) unstable; urgency=medium
* Team upload.
* Imported Upstream version 0.034
* Adjust (build-)dependency for File::pushd.
Make unversioned Build-Depends-Indep and Depends on libfile-pushd-perl
versioned to (>= 1.005).
* Wrap and sort fields in debian/control file
* Refresh no-devel-checkbin.patch patch

See Also

Package Description
libgit2-27_0.27.7+dfsg.1-0.2_i386.deb low-level Git library
libgit2-dev_0.27.7+dfsg.1-0.2_i386.deb low-level Git library (development files)
libgit2-glib-1.0-0_0.27.7-1_i386.deb glib wrapper library around the libgit2 git access library
libgit2-glib-1.0-dev_0.27.7-1_i386.deb glib wrapper library around the libgit2 git access library - development files
libgit2-glib-1.0-doc_0.27.7-1_all.deb glib wrapper library around the libgit2 git access library - documentation
libgitlab-api-v4-perl_0.16-1_all.deb GitLab API v4 module and command-line client
libgivaro-dev_4.0.4-2_i386.deb arithmetic and algebraic computations - development files
libgivaro-doc_4.0.4-2_all.deb Documentation for Givaro
libgivaro9_4.0.4-2_i386.deb arithmetic and algebraic computations
libgiza0_1.1.0-1_i386.deb Lightweight scientific plotting library (shared library)
libgjs-dev_1.54.3-1_i386.deb Mozilla-based javascript bindings for the GNOME platform
libgjs0g_1.54.3-1_i386.deb Mozilla-based javascript bindings for the GNOME platform
libgkarrays-dev_2.1.0+dfsg-2_i386.deb library to query large collection of NGS sequences (development)
libgkarrays1_2.1.0+dfsg-2_i386.deb library to query large collection of NGS sequences
libgkeyfile-cil-dev_0.1-5_all.deb GObject-based wrapper library for GKeyFile -- CLI development files
Advertisement
Advertisement