libgig-dev_4.1.0~repack-2_i386.deb


Advertisement

Description

libgig-dev - development files for libgig

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libgig-dev_4.1.0~repack-2_i386.deb
Package name libgig-dev
Package version 4.1.0~repack
Package release 2
Package architecture i386
Package type deb
Category devel::lang:c++ devel::library libdevel role::devel-lib
Homepage https://www.linuxsampler.org/libgig/
License -
Maintainer Debian Multimedia Maintainers <pkg-multimedia-maintainers@lists.alioth.debian.org>
Download size 56.12 KB
Installed size 269.00 KB
libgig is a C++ library for loading, modifying and creating Gigasampler
files and DLS (Downloadable Sounds) Level 1/2 files.
Since the Gigasampler / GigaStudio and DLS formats are based ontop
of the binary RIFF container format, this library also provides
convenient access to RIFF files in general.
This package also contains a Linux/POSIX ported version of libakai,
which provides support for reading Akai formatted medias (CDRoms, HDs,
Zip disks).
Currently Akai S1000, S01, S2000 and S3000 series are supported.
This package contains the header files needed for development with
libgig. You will need this only if you intend to compile programs
that use this library.

Alternatives

Package Version Architecture Repository
libgig-dev_4.1.0~repack-2_amd64.deb 4.1.0~repack amd64 Debian Main
libgig-dev - - -

Requires

Name Value
libakai0 = 4.1.0~repack-2
libgig8 = 4.1.0~repack-2

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libgig-dev_4.1.0~repack-2_i386.deb
Source Package libgig

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libgig-dev deb package:
    # sudo apt-get install libgig-dev

Files

Path
/usr/include/libgig/Akai.h
/usr/include/libgig/DLS.h
/usr/include/libgig/Korg.h
/usr/include/libgig/RIFF.h
/usr/include/libgig/SF.h
/usr/include/libgig/Serialization.h
/usr/include/libgig/gig.h
/usr/lib/i386-linux-gnu/libakai.so
/usr/lib/i386-linux-gnu/libgig.so
/usr/lib/i386-linux-gnu/pkgconfig/akai.pc
/usr/lib/i386-linux-gnu/pkgconfig/gig.pc
/usr/share/doc/libgig-dev/changelog.Debian.gz
/usr/share/doc/libgig-dev/changelog.gz
/usr/share/doc/libgig-dev/copyright

Changelog

2018-01-03 - Jaromír Mikeš <mira.mikes@seznam.cz>
libgig (4.1.0~repack-2) unstable; urgency=medium
* Upload to unstable.
* Set dh/compat 11.
* Bump Standards.
* Fix paths in doc-base file.
2018-01-01 - Jaromír Mikeš <mira.mikes@seznam.cz>
libgig (4.1.0~repack-1) experimental; urgency=medium
* Improve filter option in gbp.conf file.
* New upstream version 4.1.0
* Introduce postclone.sh script to ignore .pc/ dir.
* Patches refreshed/removed.
* Use secure uri in watch file.
* Bump soname for libgig.
* Use secure uri for homepage.
2017-10-13 - Jaromír Mikeš <mira.mikes@seznam.cz>
libgig (4.0.0-5) unstable; urgency=medium
* Add patch to fix CVE-2017-12951. (Closes: #877651)
* Add patch to fix CVE-2017-12954. (Closes: #877652)
* Bump Standards.
* Update Vcs to use git instead of cgit.
2017-08-29 - Paul Brossier <piem@debian.org>
libgig (4.0.0-4) unstable; urgency=medium
* debian/patches/CVE-2017-12952.diff: fix some crashes
2017-07-03 - Jaromír Mikeš <mira.mikes@seznam.cz>
libgig (4.0.0-3) unstable; urgency=medium
* Bump Standards.
* Sign tags.
* Update copyright file.
* Avoid useless linking.
* 4.0.0 release (Closes: #850179)
2017-06-25 - Jaromír Mikeš <mira.mikes@seznam.cz>
libgig (4.0.0-2) unstable; urgency=medium
* Upload to unstable. (Closes: #847081)
2016-12-01 - Jaromír Mikeš <mira.mikes@seznam.cz>
libgig (4.0.0-1) experimental; urgency=medium
[ Alessio Treglia ]
* Imported Upstream version 4.0.0 (Closes: #834436)
* Refresh patchset
[ Jaromír Mikeš ]
* debian/control
* Add myself as uploader.
* Rename package to libgig7.
* Make libgig-dev Multi-Arch: same.
* Fix VCS fields.
* Fix spelling in description.
* Bump Standards.
* Split package - separate libakai0 package.
* Remove not needed Breaks/Replaces.
* debian/patches
* Removed 03-deletechuncklist.patch - upstream request.
* Not patch Makefile.in and configure file.
* Add spelling patch.
* Add patch to fix install path.
* Update 01-Makefile.patch.
* Not patch Makefile.in and configure file.
* debian/rules
* Set dh/compat 10.
* Drop autoreconf - not needed with compat 10.
* Fix hardening.
* Fix .gitignore file.
* Remove postrm postinst scripts.
* Remove libgig-dev.doc-base file.
* Install only one upstream changelog.
* Update copyright file.
* Get rid of autom4te.cache files by gbp.conf
* Drop d/Makefile.* files.
* Don't sign tags.
2015-08-05 - Sebastian Ramacher <sramacher@debian.org>
libgig (3.3.0-5) unstable; urgency=medium
* Team upload.
* Upload to unstable.
2015-07-28 - Sebastian Ramacher <sramacher@debian.org>
libgig (3.3.0-4) experimental; urgency=medium
* Team upload.
* Rename libgig6 for GCC 5 transition. (Closes: #791124)
* debian/control:
- Bump Standards-Version to 3.9.6
- Remove obsolete Conflicts + Replaces.
- Bump debhelper B-D to >= 9.
- Mark libgig6v5 as M-A: same.
* debian/compat: Bump to 9.
2014-03-31 - Paul Brossier <piem@debian.org>
libgig (3.3.0-3) unstable; urgency=medium
* debian/rules: do not install changelog twice
* debian/rules: use dpkg-buildflags
* debian/control: bump standards-version
* debian/rules: cleaner clean
* debian/rules: build dos in indep, make jquery.js a link
* debian/control: libgig-doc depends on libjs-jquery
* debian/patches/03-deletechuncklist.patch: fix riftree segfault (closes:
#716265)

See Also

Package Description
libgig-doc_4.1.0~repack-2_all.deb HTML documentation for libgig
libgig8_4.1.0~repack-2_i386.deb library for loading and modifying Gigasampler and DLS files
libgimp2.0-dev_2.10.8-2_i386.deb Headers and other files for compiling plugins for GIMP
libgimp2.0-doc_2.10.8-2_all.deb Developers' Documentation for the GIMP library
libgimp2.0_2.10.8-2_i386.deb Libraries for the GNU Image Manipulation Program
libginac-dev_1.7.5-1_i386.deb GiNaC symbolic framework development files
libginac6_1.7.5-1_i386.deb GiNaC symbolic framework runtime library
libgio-cil_2.22.3-3_all.deb CLI binding for the GIO I/O stack 2.22
libgio2.0-cil-dev_2.22.3-3_all.deb CLI binding for the GIO I/O stack 2.22
libgio3.0-cil-dev_2.99.3-3_i386.deb CLI binding for GIO 2.24
libgio3.0-cil_2.99.3-3_i386.deb CLI binding for the GIO libraries 2.24
libgirara-dev_0.3.2-1_i386.deb library for minimalistic user interfaces (development files)
libgirara-doc_0.3.2-1_all.deb library for minimalistic user interfaces (documentation)
libgirara-gtk3-3_0.3.2-1_i386.deb library for minimalistic user interfaces (shared libraries)
libgirepository-1.0-1_1.58.3-2_i386.deb Library for handling GObject introspection data (runtime library)
Advertisement
Advertisement