libgenome-dev_1.3.11+svn20110227.4616-2_i386.deb


Advertisement

Description

libgenome-dev - toolkit for developing bioinformatic related software (devel)

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libgenome-dev_1.3.11+svn20110227.4616-2_i386.deb
Package name libgenome-dev
Package version 1.3.11+svn20110227.4616
Package release 2
Package architecture i386
Package type deb
Category devel::library libdevel role::devel-lib
Homepage https://sourceforge.net/projects/libgenome/
License -
Maintainer Debian Med Packaging Team <debian-med-packaging@lists.alioth.debian.org>
Download size 196.78 KB
Installed size 1.14 MB
libGenome is a freely available toolkit for developing bioinformatic related
software in C++.  It is intended to take the hassle out of performing common
tasks on genetic sequence and annotation data.
Among other things, libGenome can help you:
* Read and write Multi-FastA format files
* Read and write GenBank flat file database entries
* Append, chop, truncate, reverse, complement, translate, and otherwise
mangle sequence data
* Access annotation in GenBank flat files
This is the development package containing the statically linked
library and the header files.

Alternatives

Package Version Architecture Repository
libgenome-dev_1.3.11+svn20110227.4616-2_amd64.deb 1.3.11+svn20110227.4616 amd64 Debian Main
libgenome-dev - - -

Requires

Name Value
libgenome0 = 1.3.11+svn20110227.4616-2

Provides

Name Value
libgenome-1.3-dev -

Conflicts

Name Value
libgenome-1.3-dev -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libgenome-dev_1.3.11+svn20110227.4616-2_i386.deb
Source Package libgenome

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libgenome-dev deb package:
    # sudo apt-get install libgenome-dev

Files

Path
/usr/include/libGenome/IntervalSequenceTree.h
/usr/include/libGenome/OmpGuard.h
/usr/include/libGenome/gnABISource.h
/usr/include/libGenome/gnBaseFeature.h
/usr/include/libGenome/gnBaseFilter.h
/usr/include/libGenome/gnBaseHeader.h
/usr/include/libGenome/gnBaseQualifier.h
/usr/include/libGenome/gnBaseSource.h
/usr/include/libGenome/gnBaseSpec.h
/usr/include/libGenome/gnClone.h
/usr/include/libGenome/gnCompare.h
/usr/include/libGenome/gnContigSpec.h
/usr/include/libGenome/gnDNASequence.h
/usr/include/libGenome/gnDataBaseSource.h
/usr/include/libGenome/gnDebug.h
/usr/include/libGenome/gnDefs.h
/usr/include/libGenome/gnException.h
/usr/include/libGenome/gnExceptionCode.h
/usr/include/libGenome/gnFASSource.h
/usr/include/libGenome/gnFastTranslator.h
/usr/include/libGenome/gnFeature.h
/usr/include/libGenome/gnFileContig.h
/usr/include/libGenome/gnFileSource.h
/usr/include/libGenome/gnFilter.h
/usr/include/libGenome/gnFragmentSpec.h
/usr/include/libGenome/gnGBKSource.h
/usr/include/libGenome/gnGenomeSpec.h
/usr/include/libGenome/gnLocation.h
/usr/include/libGenome/gnMultiSpec.h
/usr/include/libGenome/gnPosSpecificTranslator.h
/usr/include/libGenome/gnProteinSequence.h
/usr/include/libGenome/gnRAWSource.h
/usr/include/libGenome/gnRNASequence.h
/usr/include/libGenome/gnSEQSource.h
/usr/include/libGenome/gnSequence.h
/usr/include/libGenome/gnSetup.h
/usr/include/libGenome/gnSourceFactory.h
/usr/include/libGenome/gnSourceHeader.h
/usr/include/libGenome/gnSourceQualifier.h
/usr/include/libGenome/gnSourceSpec.h
/usr/include/libGenome/gnStringHeader.h
/usr/include/libGenome/gnStringQualifier.h
/usr/include/libGenome/gnStringSpec.h
/usr/include/libGenome/gnStringTools.h
/usr/include/libGenome/gnTranslator.h
/usr/include/libGenome/gnVersion.h
/usr/lib/i386-linux-gnu/libGenome.a
/usr/lib/i386-linux-gnu/libGenome.so
/usr/lib/i386-linux-gnu/pkgconfig/libGenome.pc
/usr/share/doc/libgenome-dev/README.Debian
/usr/share/doc/libgenome-dev/changelog.Debian.gz
/usr/share/doc/libgenome-dev/changelog.gz
/usr/share/doc/libgenome-dev/copyright

Changelog

2018-08-13 - Graham Inggs <ginggs@debian.org>
libgenome (1.3.11+svn20110227.4616-2) unstable; urgency=medium
* Update symbols for GCC 8 and make them amd64-only (Closes: #905566)
2018-07-18 - Andreas Tille <tille@debian.org>
libgenome (1.3.11+svn20110227.4616-1) unstable; urgency=medium
* New upstream SVN checkout
* Rewrote get-orig-source to fetch source tarball from SVN
* Drop version number from package name
* Add symbols file
* debhelper 11
* Point Vcs fields to salsa.debian.org
* Standards-Version: 4.1.5
2017-10-05 - Andreas Tille <tille@debian.org>
libgenome (1.3.1-10) unstable; urgency=medium
* Moved packaging from SVN to Git
* Use fake watch file since source is checked out from SVN (upstream
does not provide release downloads)
* debhelper 10
* Standards-Version: 4.1.1 (no changes needed)
2016-08-12 - Andreas Tille <tille@debian.org>
libgenome (1.3.1-9) unstable; urgency=medium
* Add Multi-Arch: same and Pre-Depends: ${misc:Pre-Depends}
according to https://wiki.debian.org/Multiarch/Implementation
* Fix gcc-6.1 build issue
Closes: #831188
* hardening=+bindnow
* cme fix dpkg-control
* Fixed homepage
* Drop unused overrides
2015-08-08 - Andreas Tille <tille@debian.org>
libgenome (1.3.1-8) unstable; urgency=medium
* d/rules: drop unneeded override libgomp1-dev
* Rename library packages for g++5 ABI transition.
(thanks to Steve Langasek <steve.langasek@ubuntu.com> for the patch)
Closes: #791121
* cme fix dpkg-control
* Versioned Build-Depends d-shlibs (>= 0.61) to support --v5 option
2014-06-13 - Andreas Tille <tille@debian.org>
libgenome (1.3.1-7) unstable; urgency=medium
* debian/rules: override libgomp1-dev dependency by nothing
Closes: #751295
2014-04-13 - Andreas Tille <tille@debian.org>
libgenome (1.3.1-6) unstable; urgency=medium
* use dh-autoreconf
Closes: #744609
* debian/rules: simplify d-shlibs call
2013-12-06 - Andreas Tille <tille@debian.org>
libgenome (1.3.1-5) unstable; urgency=low
* symbols control file does more harm than good - deactivating
Closes: #731485
* d/lintian-overrides: override missing symbols control file warning
2013-11-07 - Andreas Tille <tille@debian.org>
libgenome (1.3.1-4) unstable; urgency=low
* debian/control:
- cme fix dpkg-control
- canonical Vcs fields
- debhelper 9
- remove doxygen from Build-Depends since we do not create the
documentation anyway (see remark in README.Debian
- drop cdbs from Build-Depends
* debian/rules: switch from cdbs to dh
* provide symbols file
* debian/copyright: DEP5
2010-04-29 - Andreas Tille <tille@debian.org>
libgenome (1.3.1-3) unstable; urgency=low
* Standards-Version: 3.8.4 (no changes needed)
* Using Dpkg source format version ‘3.0 (quilt)’ (debian/source/format)
* debian/rules: fix override exception for d-shlibmove:
--override s/libstdc\+\+6-dev// (needs escaping the '+')

See Also

Package Description
libgenome-model-tools-music-perl_0.04-4_all.deb module for finding mutations of significance in cancer
libgenome-perl_0.06-5_all.deb pipelines, tools, and data management for genomics
libgenome0_1.3.11+svn20110227.4616-2_i386.deb toolkit for developing bioinformatic related software
libgenometools0-dev_1.5.10+ds-3_i386.deb development files for GenomeTools
libgenometools0_1.5.10+ds-3_i386.deb versatile genome analysis library
libgentlyweb-utils-java-doc_1.5-2_all.deb Documentation - java utility library used by josql
libgentlyweb-utils-java_1.5-2_all.deb java utility library used by josql
libgeo-coder-googlev3-perl_0.17-1_all.deb Perl module providing access to Google Maps v3 Geocoding API
libgeo-coder-osm-perl_0.03-2_all.deb Geocode addresses with the OpenStreetMap Nominatim API
libgeo-constants-perl_0.06-1_all.deb standard constants used by Geo perl packages
libgeo-coordinates-itm-perl_0.02-2_all.deb conversion module between lat/lon and Irish Transverse Mercator
libgeo-coordinates-osgb-perl_2.20-1_all.deb converting module between Lat/Lon and the British National Grid
libgeo-coordinates-utm-perl_0.11-2_all.deb Perl extension for Latitiude Longitude conversions
libgeo-distance-perl_0.20-4_all.deb calculate distances and closest locations
libgeo-distance-xs-perl_0.13-2+b5_i386.deb calculate distances and closest locations (XS version)
Advertisement
Advertisement