libgda-5.0-common_5.2.8-1_all.deb


Advertisement

Description

libgda-5.0-common - data abstraction library based on GLib -- common files

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libgda-5.0-common_5.2.8-1_all.deb
Package name libgda-5.0-common
Package version 5.2.8
Package release 1
Package architecture all
Package type deb
Category database
Homepage http://www.gnome-db.org/
License -
Maintainer Debian GNOME Maintainers <pkg-gnome-maintainers@lists.alioth.debian.org>
Download size 933.04 KB
Installed size 8.16 MB
libgda is a (relatively small) database abstraction/access library
integrated on the GLib object model. It can be used as a metadata
extractor, to get information about all database objects in a common
way, and as an ODBC-like wrapper to access data in different engines
through an easier API.
This package contains common files for libgda.

Alternatives

Package Version Architecture Repository
libgda-5.0-common_5.2.8-1_all.deb 5.2.8 all Debian Main
libgda-5.0-common - - -

Requires

Name Value
libjs-jquery -
python:any -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libgda-5.0-common_5.2.8-1_all.deb
Source Package libgda5

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libgda-5.0-common deb package:
    # sudo apt-get install libgda-5.0-common

Files

Path
/etc/libgda-5.0/config
/usr/share/doc/libgda-5.0-common/changelog.Debian.gz
/usr/share/doc/libgda-5.0-common/changelog.gz
/usr/share/doc/libgda-5.0-common/copyright
/usr/share/libgda-5.0/information_schema.xml
/usr/share/libgda-5.0/mysql_specs_add_column.xml
/usr/share/libgda-5.0/mysql_specs_comment_column.xml
/usr/share/libgda-5.0/mysql_specs_comment_table.xml
/usr/share/libgda-5.0/mysql_specs_create_db.xml
/usr/share/libgda-5.0/mysql_specs_create_index.xml
/usr/share/libgda-5.0/mysql_specs_create_table.xml
/usr/share/libgda-5.0/mysql_specs_create_view.xml
/usr/share/libgda-5.0/mysql_specs_drop_column.xml
/usr/share/libgda-5.0/mysql_specs_drop_db.xml
/usr/share/libgda-5.0/mysql_specs_drop_index.xml
/usr/share/libgda-5.0/mysql_specs_drop_table.xml
/usr/share/libgda-5.0/mysql_specs_drop_view.xml
/usr/share/libgda-5.0/mysql_specs_dsn.xml
/usr/share/libgda-5.0/mysql_specs_rename_table.xml
/usr/share/libgda-5.0/postgres_specs_add_column.xml
/usr/share/libgda-5.0/postgres_specs_create_db.xml
/usr/share/libgda-5.0/postgres_specs_create_index.xml
/usr/share/libgda-5.0/postgres_specs_create_role.xml
/usr/share/libgda-5.0/postgres_specs_create_table.xml
/usr/share/libgda-5.0/postgres_specs_create_user.xml
/usr/share/libgda-5.0/postgres_specs_create_view.xml
/usr/share/libgda-5.0/postgres_specs_drop_column.xml
/usr/share/libgda-5.0/postgres_specs_drop_db.xml
/usr/share/libgda-5.0/postgres_specs_drop_index.xml
/usr/share/libgda-5.0/postgres_specs_drop_role.xml
/usr/share/libgda-5.0/postgres_specs_drop_table.xml
/usr/share/libgda-5.0/postgres_specs_drop_user.xml
/usr/share/libgda-5.0/postgres_specs_drop_view.xml
/usr/share/libgda-5.0/postgres_specs_dsn.xml
/usr/share/libgda-5.0/postgres_specs_rename_table.xml
/usr/share/libgda-5.0/sqlite_specs_add_column.xml
/usr/share/libgda-5.0/sqlite_specs_create_db.xml
/usr/share/libgda-5.0/sqlite_specs_create_index.xml
/usr/share/libgda-5.0/sqlite_specs_create_table.xml
/usr/share/libgda-5.0/sqlite_specs_create_view.xml
/usr/share/libgda-5.0/sqlite_specs_drop_db.xml
/usr/share/libgda-5.0/sqlite_specs_drop_index.xml
/usr/share/libgda-5.0/sqlite_specs_drop_table.xml
/usr/share/libgda-5.0/sqlite_specs_drop_view.xml
/usr/share/libgda-5.0/sqlite_specs_dsn.xml
/usr/share/libgda-5.0/sqlite_specs_rename_table.xml
/usr/share/libgda-5.0/web_specs_auth.xml
/usr/share/libgda-5.0/web_specs_dsn.xml
/usr/share/libgda-5.0/dtd/libgda-array.dtd
/usr/share/libgda-5.0/dtd/libgda-paramlist.dtd
/usr/share/libgda-5.0/dtd/libgda-server-operation.dtd
/usr/share/libgda-5.0/gda_trml2html/__init__.py
/usr/share/libgda-5.0/gda_trml2html/trml2html.py
/usr/share/libgda-5.0/gda_trml2html/utils.py
/usr/share/libgda-5.0/gda_trml2pdf/__init__.py
/usr/share/libgda-5.0/gda_trml2pdf/color.py
/usr/share/libgda-5.0/gda_trml2pdf/trml2pdf.py
/usr/share/libgda-5.0/gda_trml2pdf/utils.py
/usr/share/libgda-5.0/php/README
/usr/share/libgda-5.0/php/gda-clean.php
/usr/share/libgda-5.0/php/gda-config.php
/usr/share/libgda-5.0/php/gda-exception.php
/usr/share/libgda-5.0/php/gda-front.php
/usr/share/libgda-5.0/php/gda-meta.php
/usr/share/libgda-5.0/php/gda-secure-config.php
/usr/share/libgda-5.0/php/gda-setup.php
/usr/share/libgda-5.0/php/gda-tester.php
/usr/share/libgda-5.0/php/gda-utils.php
/usr/share/libgda-5.0/php/gda-worker.php
/usr/share/libgda-5.0/web/cnc.js
/usr/share/libgda-5.0/web/gda-print.css
/usr/share/libgda-5.0/web/gda.css
/usr/share/libgda-5.0/web/irb.css
/usr/share/libgda-5.0/web/irb.js
/usr/share/libgda-5.0/web/jquery.js
/usr/share/libgda-5.0/web/md5.js
/usr/share/libgda-5.0/web/mouseapp_2.js
/usr/share/libgda-5.0/web/mouseirb_2.js
/usr/share/locale/ar/LC_MESSAGES/libgda-5.0.mo
/usr/share/locale/az/LC_MESSAGES/libgda-5.0.mo
/usr/share/locale/bs/LC_MESSAGES/libgda-5.0.mo
/usr/share/locale/ca/LC_MESSAGES/libgda-5.0.mo
/usr/share/locale/ca@valencia/LC_MESSAGES/libgda-5.0.mo
/usr/share/locale/cs/LC_MESSAGES/libgda-5.0.mo
/usr/share/locale/da/LC_MESSAGES/libgda-5.0.mo
/usr/share/locale/de/LC_MESSAGES/libgda-5.0.mo
/usr/share/locale/dz/LC_MESSAGES/libgda-5.0.mo
/usr/share/locale/el/LC_MESSAGES/libgda-5.0.mo
/usr/share/locale/en_CA/LC_MESSAGES/libgda-5.0.mo
/usr/share/locale/en_GB/LC_MESSAGES/libgda-5.0.mo
/usr/share/locale/eo/LC_MESSAGES/libgda-5.0.mo
/usr/share/locale/es/LC_MESSAGES/libgda-5.0.mo
/usr/share/locale/eu/LC_MESSAGES/libgda-5.0.mo
/usr/share/locale/fa/LC_MESSAGES/libgda-5.0.mo
/usr/share/locale/fi/LC_MESSAGES/libgda-5.0.mo
/usr/share/locale/fr/LC_MESSAGES/libgda-5.0.mo
/usr/share/locale/ga/LC_MESSAGES/libgda-5.0.mo
/usr/share/locale/gl/LC_MESSAGES/libgda-5.0.mo
/usr/share/locale/hr/LC_MESSAGES/libgda-5.0.mo
/usr/share/locale/hu/LC_MESSAGES/libgda-5.0.mo
/usr/share/locale/id/LC_MESSAGES/libgda-5.0.mo
/usr/share/locale/it/LC_MESSAGES/libgda-5.0.mo
/usr/share/locale/ja/LC_MESSAGES/libgda-5.0.mo
/usr/share/locale/ko/LC_MESSAGES/libgda-5.0.mo
/usr/share/locale/lt/LC_MESSAGES/libgda-5.0.mo
/usr/share/locale/lv/LC_MESSAGES/libgda-5.0.mo
/usr/share/locale/mk/LC_MESSAGES/libgda-5.0.mo
/usr/share/locale/ml/LC_MESSAGES/libgda-5.0.mo
/usr/share/locale/ms/LC_MESSAGES/libgda-5.0.mo
/usr/share/locale/nb/LC_MESSAGES/libgda-5.0.mo
/usr/share/locale/ne/LC_MESSAGES/libgda-5.0.mo
/usr/share/locale/nl/LC_MESSAGES/libgda-5.0.mo
/usr/share/locale/oc/LC_MESSAGES/libgda-5.0.mo
/usr/share/locale/pa/LC_MESSAGES/libgda-5.0.mo
/usr/share/locale/pt/LC_MESSAGES/libgda-5.0.mo
/usr/share/locale/pt_BR/LC_MESSAGES/libgda-5.0.mo
/usr/share/locale/ru/LC_MESSAGES/libgda-5.0.mo
/usr/share/locale/rw/LC_MESSAGES/libgda-5.0.mo
/usr/share/locale/sk/LC_MESSAGES/libgda-5.0.mo
/usr/share/locale/sl/LC_MESSAGES/libgda-5.0.mo
/usr/share/locale/sq/LC_MESSAGES/libgda-5.0.mo
/usr/share/locale/sr/LC_MESSAGES/libgda-5.0.mo
/usr/share/locale/sr@latin/LC_MESSAGES/libgda-5.0.mo
/usr/share/locale/sv/LC_MESSAGES/libgda-5.0.mo
/usr/share/locale/tg/LC_MESSAGES/libgda-5.0.mo
/usr/share/locale/tr/LC_MESSAGES/libgda-5.0.mo
/usr/share/locale/uk/LC_MESSAGES/libgda-5.0.mo
/usr/share/locale/vi/LC_MESSAGES/libgda-5.0.mo
/usr/share/locale/zh_CN/LC_MESSAGES/libgda-5.0.mo
/usr/share/locale/zh_HK/LC_MESSAGES/libgda-5.0.mo
/usr/share/locale/zh_TW/LC_MESSAGES/libgda-5.0.mo
/usr/share/python/runtime.d/libgda-5.0-common.rtupdate

Changelog

2018-12-27 - Jeremy Bicha <jbicha@debian.org>
libgda5 (5.2.8-1) unstable; urgency=medium
* New upstream release
* Use Files-Excluded for the jquery copy
* Add don-t-install-jquery.patch:
- Don't install jquery file that we have excluded.
* Update debian/watch to only look for stable version 5 releases
* Drop patches applied in new release:
- 0001-Convert-files-to-Unicode.patch
- Accept-SQLITE_INDEX_CONSTRAINT_LIKE-from-sqlite.patch
- remove_builddate.patch
- vala_version.patch
* Bump minimum libsqlite3-dev to 3.10.12
* Build-Depend on libgee-0.8-dev, now required for the vala bindings
* Use --disable-gdaui-gi
* Explicitly disable libsecret
* Add -Wl,-O1 to our LDFLAGS
* Bump Standards-Version to 4.3.0
2018-09-15 - Jeremy Bicha <jbicha@debian.org>
libgda5 (5.2.4-11) unstable; urgency=medium
* Update vala_version.patch for vala 0.42 (Closes: #907941)
* Bump Standards-Version to 4.2.1
2018-03-29 - Jeremy Bicha <jbicha@debian.org>
libgda5 (5.2.4-10) unstable; urgency=medium
[ Simon McVittie ]
* d/control.in: Update Vcs-* for migration from Alioth svn to
salsa.debian.org git
* d/gbp.conf: Add
* d/patches: Refresh through gbp pq, filling in missing authors
and dates from d/changelog
[ Jeremy Bicha ]
* Ignore build test failures since the tests don't pass reliably
and no one is volunteering to fix them
2018-02-28 - Jeremy Bicha <jbicha@debian.org>
libgda5 (5.2.4-9) unstable; urgency=medium
* Use dh_auto_test --no-parallel instead of -- -j1 to fix FTBFS
2018-02-28 - Jeremy Bicha <jbicha@debian.org>
libgda5 (5.2.4-8) unstable; urgency=medium
* Update vala_version.patch for vala 0.40 (Closes: #891738)
2018-02-11 - Jeremy Bicha <jbicha@debian.org>
libgda5 (5.2.4-7) unstable; urgency=medium
* Update vala_version.patch for vala 0.38
* Update 0001-Convert-files-to-Unicode.patch to fix FTBFS
* Drop glib-2.54-ftbfs.patch: Incorporated into Unicode patch
* Bump debhelper compat to 11
2017-09-12 - Jordi Mallach <jordi@debian.org>
libgda5 (5.2.4-6) unstable; urgency=medium
* Fix FTBFS for -arch-dep builds.
* Drop unneeded B-D on dh-autoreconf with debhelper compat 10.
2017-09-12 - Jordi Mallach <jordi@debian.org>
libgda5 (5.2.4-5) unstable; urgency=medium
* Add libgtk-3-doc to B-D-Indep to fix reflinks in generated docs.
* Add missing Build-Dep on dh_python (lintian).
* Add remove_builddate.patch: remove references to GDA_BUILDDATE in
generated documentation to fix build reproducibility.
* Rewrite debian/rules using dh sequencer and move away from CDBS.
* Add vala_version.patch: make configure search for vala-0.36.
* Pass --enable-vala, add Build-Depend on valac and install generated
.vapi file in -dev (LP: #1016727).
* Add libgda-5.0-4.docs to install AUTHORS, NEWS and README, which were
installed by default with CDBS.
* Mark relevant packages as Multi-Arch: same or foreign.
* Bump debhelper Build-Dep to >= 10.
* Update Standards-Version to 4.1.0.
* Stop using $SONAME substitution.
* Remove Piotr from Uploaders. Thanks for your past contributions.
The Uploaders list is now up to date (closes: #857484).
2017-09-04 - Jordi Mallach <jordi@debian.org>
libgda5 (5.2.4-4) unstable; urgency=medium
[ Emilio Pozuelo Monfort ]
* debian/rules: If the test suite fails, print the actual errors.
[ Jordi Mallach ]
* Add patches from Adrian Bunk to fix FTBFS issues with new glib,
by converting files with mixed encoding to UTF-8 (closes: #870741).
* Drop libgda-5.0-4-dbg in favour of dbgsym and pass the corresponding
--dbgsym-migration arg to dh_strip.
2016-11-20 - Emilio Pozuelo Monfort <pochu@debian.org>
libgda5 (5.2.4-3) unstable; urgency=medium
* Build-depend on default-libmysqlclient-dev instead of libmysqlclient-dev.

See Also

Package Description
libgda-5.0-dev_5.2.8-1_i386.deb data abstraction library based on GLib -- development files
libgda-5.0-doc_5.2.8-1_all.deb data abstraction library based on GLib -- documentation files
libgda-5.0-mysql_5.2.8-1_i386.deb MySQL provider for libgda database abstraction library
libgda-5.0-postgres_5.2.8-1_i386.deb PostgreSQL provider for libgda database abstraction library
libgdal-dev_2.4.0+dfsg-1+b1_i386.deb Geospatial Data Abstraction Library - Development files
libgdal-doc_2.4.0+dfsg-1_all.deb Documentation for the Geospatial Data Abstraction Library
libgdal-grass_2.4.0-3_i386.deb GRASS extension for the GDAL library
libgdal-java_2.4.0+dfsg-1+b1_i386.deb Java bindings to the Geospatial Data Abstraction Library
libgdal-perl-doc_2.4.0+dfsg-1_all.deb Documentation for GDAL Perl bindings
libgdal-perl_2.4.0+dfsg-1+b1_i386.deb Perl bindings to the Geospatial Data Abstraction Library
libgdal20_2.4.0+dfsg-1+b1_i386.deb Geospatial Data Abstraction Library
libgdamm-5.0-13_4.99.11-3_i386.deb C++ wrappers for libgda5
libgdamm5.0-dev_4.99.11-3_i386.deb C++ wrappers for libgda5 (library headers)
libgdamm5.0-doc_4.99.11-3_all.deb C++ wrappers for libgda5 (documentation)
libgdata-cil-dev_2.2.0.0-2_all.deb Google GData CLI client library
Advertisement
Advertisement