libgambit4-dev_4.8.8-3.1_i386.deb


Advertisement

Description

libgambit4-dev - Header file and link for the Gambit shared library

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libgambit4-dev_4.8.8-3.1_i386.deb
Package name libgambit4-dev
Package version 4.8.8
Package release 3.1
Package architecture i386
Package type deb
Category devel::library libdevel role::devel-lib
Homepage http://gambitscheme.org
License -
Maintainer Abdelhakim Qbaich <abdelhakim@qbaich.com>
Download size 48.03 KB
Installed size 371.00 KB
The package includes gambit.h and the libgambit.so, libgambitgsi.so
and libgambitgsc.so links.

Alternatives

Package Version Architecture Repository
libgambit4-dev_4.8.8-3.1_amd64.deb 4.8.8 amd64 Debian Main
libgambit4-dev - - -

Requires

Name Value
libgambit4 = 4.8.8-3.1

Replaces

Name Value
libgambc4-dev -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libgambit4-dev_4.8.8-3.1_i386.deb
Source Package gambc

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libgambit4-dev deb package:
    # sudo apt-get install libgambit4-dev

Files

Path
/usr/include/gambit-not408008.h
/usr/include/gambit.h
/usr/lib/i386-linux-gnu/gambit4/libgambit.so
/usr/lib/i386-linux-gnu/gambit4/libgambitgsc.so
/usr/lib/i386-linux-gnu/gambit4/libgambitgsi.so
/usr/share/doc/libgambit4-dev/changelog.Debian.gz
/usr/share/doc/libgambit4-dev/copyright

Changelog

2018-09-27 - Adrian Bunk <bunk@debian.org>
gambc (4.8.8-3.1) unstable; urgency=medium
* Non-maintainer upload.
* Add the missing Breaks. (Closes: #879917)
2018-01-11 - Abdelhakim Qbaich <abdelhakim@qbaich.com>
gambc (4.8.8-3) unstable; urgency=medium
* Some buildd/linting warning fixed
* Running tests serially (Closes: #886604, #501414)
2017-12-31 - Abdelhakim Qbaich <abdelhakim@qbaich.com>
gambc (4.8.8-2) unstable; urgency=medium
* Fixed some lintian warnings/errors
* Repository moved to salsa
* Removed suggestion of deprecated package r5rs-doc
* libgambit4 replaces libgambc4 (Closes: #879917)
2017-10-02 - Abdelhakim Qbaich <abdelhakim@qbaich.com>
gambc (4.8.8-1) experimental; urgency=medium
* New upstream release (Closes: #677709, #618273)
* Updated to debhelper Compatibility Level 10
* Updated to Standards-Version 4.0.1
* Updated to 3.0 (quilt) format
* Libraries renamed to libgambit4 and libgambit4-dev
* Proper copyright file
* Hardening in build options
* Updated watch file to take into account future versions
* Simplified the debian/ files
2008-07-07 - Kurt B. Kaiser <kbk@shore.net>
gambc (4.2.8-1) unstable; urgency=low
* New upstream release
* Upstream has split shared lib into three; modify packaging to match
* Fix typo in gambc Suggests: r5rs-doc, move to gambc-doc (Closes: #449609)
* Split deb build into arch-dependent and arch-independent
* Simplify clean target's autoconf run commands
* Update watch file to revised tarball naming pattern (Closes: #450131)
* Update copyright
* Bootstrap gambit before modifying _gsc.c to reduce patch hackery
* libgambc4-dev becomes libdevel - optional
* Was FTBFS on GNU/kFreeBSD: missing OS detection (Closes: #414024)
* Was FTBFS on second attempt (Closes: #424288)
* debian/rules: Move "-Wl,-z,defs" from CFLAGS to LDFLAGS to avoid a lot
of irrelevant linker messages
* Fix debian-rules-ignores-make-clean-error
* Add XS-DM-Upload-Allowed field to control
* Update to Standards-Version 3.7.3
* Update to debhelper Compatibility Level 6
* Accept ubuntu patch: use update-alternatives when installing scheme-r5rs
* Update gsi.1: Copyright, available documentation, enhance description
* 4.2.6-1 was on mentors.debian.net for 10 days but never uploaded
* Fix bashism in debian/rules (Closes: #478383)
* 4.2.6-2 was on mentors.debian.net for 60 days but never uploaded
* Change /usr/lib/ installation dir from gambc4.0 to gambc4
* Run autoconf on autobuilders - simplify the configuration in
debian/rules and remove the lintian overrides for changes to
config.sub, config.guess, and configure
* Update to Standards Version 3.8.0
* Revise debian/copyright to reflect that the text of the Apache 2.0
License is now included in the Debian system distribution.
* Add Vcs-Svn and Vcs-Browser fields to debian/control
* CFLAGS now handled by dpkg-buildpackage
* autotools-dev dropped autoconf dependency, add autoconf to builddeps
* Update debian/rules to reflect current way of passing arch to configure
* Improve clean target: do a distclean in all dirs except gsc/
2006-11-19 - Kurt B. Kaiser <kbk@shore.net>
gambc (4.0~b20-1) unstable; urgency=low
* New upstream release
* First Debian release, previous was Alioth only (Closes: #283299)
* Fix and update watch file
* Use configure option --enable-single-host for performance improvement
* Update Standards-Version and debhelper compatibility level
* Switch to building a shared library (libgambc4), and split package
* Split out the documentation for the extensive user manual into gambc-doc
2006-03-12 - Kurt B. Kaiser <kbk@shore.net>
gambc (4.0.b17-1) unstable; urgency=low
* Initial release (Closes: #283299)

See Also

Package Description
libgambit4_4.8.8-3.1_i386.deb Shared libraries for the Gambit interpreter and compiler
libgamin-dev_0.1.10-5+b1_i386.deb Development files for the gamin client library
libgamin0_0.1.10-5+b1_i386.deb Client library for the gamin file and directory monitoring system
libgaminggear-common_0.15.1-9_all.deb Functionalities for gaming input devices, common files
libgaminggear-dev_0.15.1-9_i386.deb Functionalities for gaming input devices (devel)
libgaminggear-doc_0.15.1-9_all.deb Functionalities for gaming input devices (documentation)
libgaminggear0_0.15.1-9_i386.deb Functionalities for gaming input devices
libgammu-dev_1.40.0-1_i386.deb mobile phone management library (development files)
libgammu-i18n_1.40.0-1_all.deb mobile phone management library (i18n files)
libgammu8_1.40.0-1_i386.deb mobile phone management library
libganglia1-dev_3.6.0-7+b2_i386.deb cluster monitoring toolkit - development libraries
libganglia1_3.6.0-7+b2_i386.deb cluster monitoring toolkit - shared libraries
libganv-1-1v5_1.4.2~dfsg0-2_i386.deb canvas widget for graph-based interfaces
libganv-dev_1.4.2~dfsg0-2_i386.deb canvas widget for graph-based interfaces (development files)
libganymed-ssh2-java_250-3_all.deb pure Java implementation of the SSH-2 protocol
Advertisement
Advertisement