libg3d-plugins_0.0.8-26_i386.deb


Advertisement

Description

libg3d-plugins - plugins for the LibG3D library

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libg3d-plugins_0.0.8-26_i386.deb
Package name libg3d-plugins
Package version 0.0.8
Package release 26
Package architecture i386
Package type deb
Category libs role::shared-lib
Homepage http://automagically.de/g3dviewer/
License -
Maintainer Sven Eckelmann <sven@narfation.org>
Download size 108.11 KB
Installed size 523.00 KB
LibG3D is a framework for loading 3d model files from files or memory. It can
also load associated data like textures.
This package contains plugins for the LibG3D library, so that files can be
loaded.
It can handle:
* 3D Studio (.3ds, .prj)
* LightWave (.lw, .lwb, .lwo)
* Alias Wavefront (.obj)
* Impulse TurboSilver / Imagine (.iob)
* AutoCAD (.dxf)
* Quake II Models (.md2)
* Quake III Models (.md3)
* Neutral File Format (.nff)
* 3D Metafile (.3dmf, .3mf, .b3d)
* Caligari TrueSpace Objects (.cob)
* Quick3D Objects & Scenes (.q3o, q3s)
* VRML 1.0 files (.wrl, .vrml)
* AC3D objects (.ac, .acc)
* LeoCAD Models (.lcd)
* Racer car models (.ar, .dof)
* Ultimate Stunts car models (.glb)
* VDrift car models (.joe, .car)
* COLLADA (.dae)
* Keyhole Markup Language model container (.kmz)
* ASCII Scene Exporter (.ase)
* LDraw (.dat, .mpd)

Alternatives

Package Version Architecture Repository
libg3d-plugins_0.0.8-26_amd64.deb 0.0.8 amd64 Debian Main
libg3d-plugins - - -

Requires

Name Value
libc6 >= 2.4
libg3d0 = 0.0.8-26
libglib2.0-0 >= 2.24.0
libgsf-1-114 >= 1.14.8
libxml2 >= 2.7.4

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libg3d-plugins_0.0.8-26_i386.deb
Source Package libg3d

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libg3d-plugins deb package:
    # sudo apt-get install libg3d-plugins

Files

Path
/usr/lib/i386-linux-gnu/libg3d/plugins/image/img_bmp.so
/usr/lib/i386-linux-gnu/libg3d/plugins/image/img_dds.so
/usr/lib/i386-linux-gnu/libg3d/plugins/image/img_sgi.so
/usr/lib/i386-linux-gnu/libg3d/plugins/import/imp_3dmf.so
/usr/lib/i386-linux-gnu/libg3d/plugins/import/imp_3ds.so
/usr/lib/i386-linux-gnu/libg3d/plugins/import/imp_ac3d.so
/usr/lib/i386-linux-gnu/libg3d/plugins/import/imp_ar.so
/usr/lib/i386-linux-gnu/libg3d/plugins/import/imp_ase.so
/usr/lib/i386-linux-gnu/libg3d/plugins/import/imp_cob.so
/usr/lib/i386-linux-gnu/libg3d/plugins/import/imp_dae.so
/usr/lib/i386-linux-gnu/libg3d/plugins/import/imp_dxf.so
/usr/lib/i386-linux-gnu/libg3d/plugins/import/imp_glb.so
/usr/lib/i386-linux-gnu/libg3d/plugins/import/imp_heightfield.so
/usr/lib/i386-linux-gnu/libg3d/plugins/import/imp_iob.so
/usr/lib/i386-linux-gnu/libg3d/plugins/import/imp_joe.so
/usr/lib/i386-linux-gnu/libg3d/plugins/import/imp_kmz.so
/usr/lib/i386-linux-gnu/libg3d/plugins/import/imp_ldraw.so
/usr/lib/i386-linux-gnu/libg3d/plugins/import/imp_leocad.so
/usr/lib/i386-linux-gnu/libg3d/plugins/import/imp_lwo.so
/usr/lib/i386-linux-gnu/libg3d/plugins/import/imp_md2.so
/usr/lib/i386-linux-gnu/libg3d/plugins/import/imp_md3.so
/usr/lib/i386-linux-gnu/libg3d/plugins/import/imp_nff.so
/usr/lib/i386-linux-gnu/libg3d/plugins/import/imp_obj.so
/usr/lib/i386-linux-gnu/libg3d/plugins/import/imp_q3o.so
/usr/lib/i386-linux-gnu/libg3d/plugins/import/imp_vrml.so
/usr/share/doc/libg3d-plugins/AUTHORS
/usr/share/doc/libg3d-plugins/README.gz
/usr/share/doc/libg3d-plugins/TODO
/usr/share/doc/libg3d-plugins/changelog.Debian.gz
/usr/share/doc/libg3d-plugins/changelog.gz
/usr/share/doc/libg3d-plugins/copyright
/usr/share/lintian/overrides/libg3d-plugins

Changelog

2018-10-20 - Sven Eckelmann <sven@narfation.org>
libg3d (0.0.8-26) unstable; urgency=medium
* debian/control:
- Add Multi-Arch tags to packages without maintainer scripts and equal
common files
* Disable false positive lintian error about libc-less plugins
2018-10-18 - Sven Eckelmann <sven@narfation.org>
libg3d (0.0.8-25) unstable; urgency=medium
* Upgraded to policy 4.2.1
- remove get-orig-source rule from debian/rules
* debian/rules
- Drop (now default) parameter --parallel for dch
* debian/control:
- update to debhelper 10
- drop dependency to dh-autoreconf
- Move VCS-* to salsa.debian.org
* Switch upstream URLs to github.com
2017-12-09 - Sven Eckelmann <sven@narfation.org>
libg3d (0.0.8-24) unstable; urgency=medium
* run dh_auto_configure for both arch and indep packages to make sure that
documentation is build during arch while the indep packages aren't build
with documentation (Closes: #883882)
2017-12-09 - Sven Eckelmann <sven@narfation.org>
libg3d (0.0.8-23) unstable; urgency=medium
[ Sven Eckelmann ]
* Fix lintian overrides on i386
* Upgraded to policy 4.1.2, no changes required
* debian/copyright:
- Update copyright years
* debian/rules
- Remove ddeb migration conflict against pre-stretch package
- only run dh_autoreconf once
[ Helmut Grohne ]
* Fix FTCBFS: Do not build documentation during arch-only. (Closes: #883882)
2016-01-31 - Sven Eckelmann <sven@narfation.org>
libg3d (0.0.8-22) unstable; urgency=medium
* debian/copyright:
- Update copyright years
- Fix LGPL-2.1 full name
* Override the lintian warning about unfortified functions
* debian/patches:
- Add Fix-spelling-errors.patch, Fix spelling errors
* debian/control
- Change Vcs-Git and Vcs-Browser to https://
* Change debian URLs to https://
* Sort debian control files with `wrap-and-sort -abst`
2015-12-30 - Sven Eckelmann <sven@narfation.org>
libg3d (0.0.8-21) unstable; urgency=medium
* Upgraded to policy 3.9.6, no changes required
* Update years in debian/copyright
* debian/patches:
- Move patches to alternative DEP-3 format and manage them with gbp pq
* Change debian/upstream/metadata to point to libg3d upstream URLs
* debian/control, debian/rules:
- Drop libg3d-dbg in favor of -dbgsym package
- Drop obsolete XS-Testsuite field
2014-08-30 - Sven Eckelmann <sven@narfation.org>
libg3d (0.0.8-20) unstable; urgency=medium
* Upload to unstable
2014-08-30 - Sven Eckelmann <sven@narfation.org>
libg3d (0.0.8-19) experimental; urgency=low
* debian/watch
- Verify new upstream versions using GPG key 06FD8C6B46E3D322BAD4
* debian/copyright:
- Update e-mail address of Marek Lindner
- Add Simon Wunderlich
* Upgraded to policy 3.9.5, no changes required
* Update copyright years in debian/copyright
* debian/rules:
- Use Largefile Support enabled C API
2013-03-06 - Sven Eckelmann <sven@narfation.org>
libg3d (0.0.8-18) experimental; urgency=low
[ Sven Eckelmann ]
* Upgraded to policy 3.9.4, no changes required
* Remove obsolete DM-Upload-Allowed in debian/control
[ Vibhav Pant ]
* Add simple autopkgtest to package (Closes: #702424)
2012-04-28 - Sven Eckelmann <sven@narfation.org>
libg3d (0.0.8-17) unstable; urgency=low
* Enable all hardening flags in debian/rules
* Upgraded to policy 3.9.3, no changes required
* debian/patches:
- Add implicit_declaration.patch, Fix implicit declarations of
functions
* Use buildflags.mk to set security flags in debian/rules
* Use DEB_LDFLAGS_MAINT_APPEND to add --as-needed linker flag
* Upgrade debhelper compat to v9

See Also

Package Description
libg3d0_0.0.8-26_i386.deb library for loading and manipulating 3D model files
libg810-led-dev_0.3.3-2_i386.deb Logitech keyboard LED configuration library (development)
libg810-led0_0.3.3-2_i386.deb Logitech keyboard LED configuration library (runtime)
libga-dev_2.4.7-4_i386.deb C++ Library of Genetic Algorithm Components
libga2_2.4.7-4_i386.deb C++ Library of Genetic Algorithm Components
libgadap-dev_2.0-11_i386.deb Development and static libraries for GADAP
libgadu-dev_1.12.2-3_i386.deb Gadu-Gadu protocol library - development files
libgadu-doc_1.12.2-3_all.deb Gadu-Gadu protocol library - documentation
libgadu3_1.12.2-3_i386.deb Gadu-Gadu protocol library - runtime files
libgail-3-0_3.24.5-1_i386.deb GNOME Accessibility Implementation Library -- shared libraries
libgail-3-dev_3.24.5-1_i386.deb GNOME Accessibility Implementation Library -- development files
libgail-3-doc_3.24.5-1_all.deb documentation files of the Gail library
libgail-common_2.24.32-3_i386.deb GNOME Accessibility Implementation Library -- common modules
libgail-dev_2.24.32-3_i386.deb GNOME Accessibility Implementation Library -- development files
libgail-doc_2.24.32-3_all.deb documentation files of the Gail library
Advertisement
Advertisement