libfs-dev_1.0.7-1+b2_i386.deb


Advertisement

Description

libfs-dev - X11 Font Services library (development headers)

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libfs-dev_1.0.7-1+b2_i386.deb
Package name libfs-dev
Package version 1.0.7
Package release 1+b2
Package architecture i386
Package type deb
Category devel::lang:c devel::library implemented-in::c libdevel role::devel-lib works-with::font x11::library
Homepage -
License -
Maintainer Debian X Strike Force <debian-x@lists.debian.org>
Download size 45.44 KB
Installed size 138.00 KB
libFS, the Font Services library, provides various functions useful to
X11 font servers, and clients connecting to font servers.  It is not
used outside of these implementations.
This package contains the development headers for the library found in
libfs6.  Non-developers likely have little use for this package.
More information about X.Org can be found at:
<URL:http://www.X.org>
This module can be found at
git://anongit.freedesktop.org/git/xorg/lib/libFS

Alternatives

Package Version Architecture Repository
libfs-dev_1.0.7-1+b2_amd64.deb 1.0.7 amd64 Debian Main
libfs-dev - - -

Requires

Name Value
libfs6 = 2:1.0.7-1+b2
x11proto-core-dev -
x11proto-fonts-dev -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libfs-dev_1.0.7-1+b2_i386.deb
Source Package libfs

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libfs-dev deb package:
    # sudo apt-get install libfs-dev

Files

Path
/usr/include/X11/fonts/FSlib.h
/usr/lib/i386-linux-gnu/libFS.a
/usr/lib/i386-linux-gnu/libFS.so
/usr/lib/i386-linux-gnu/pkgconfig/libfs.pc
/usr/share/doc/libfs-dev/FSlib.txt.gz
/usr/share/doc/libfs-dev/changelog.Debian.gz
/usr/share/doc/libfs-dev/changelog.Debian.i386.gz
/usr/share/doc/libfs-dev/changelog.gz
/usr/share/doc/libfs-dev/copyright

Changelog

2015-07-26 - Julien Cristau <jcristau@debian.org>
libfs (2:1.0.7-1) unstable; urgency=medium
* Let uscan verify tarball signatures.
* New upstream release.
* Use dh, with compat level 9 and dh-autoreconf.
2014-07-13 - Julien Cristau <jcristau@debian.org>
libfs (2:1.0.6-1) unstable; urgency=medium
* New upstream release.
* Remove Cyril from Uploaders.
* Use dh_prep instead of dh_clean -k.
2013-06-16 - Julien Cristau <jcristau@debian.org>
libfs (2:1.0.5-1) unstable; urgency=low
* New upstream release.
* Bump debhelper compat level to 7.
* Use dpkg-buildflags.
* Disable silent rules.
2013-05-13 - Julien Cristau <jcristau@debian.org>
libfs (2:1.0.4-1+deb7u1) wheezy-security; urgency=high
* Sign extension issue and integer overflow in FSOpenServer()
[CVE-2013-1996]
2012-03-25 - Julien Cristau <jcristau@debian.org>
libfs (2:1.0.4-1) unstable; urgency=low
* New upstream release.
* Delete debian/xsfbs/, it's no longer used in this package.
* Don't require fakeroot for debian/rules clean.
* Remove David Nusinow and Brice Goglin from Uploaders.
* Run autoreconf at build time.
* Add build-arch and build-indep debian/rules targets.
* Build for multiarch.
* Install FSlib.txt in libfs-dev.
* Bump Standards-Version to 3.9.3.
2010-11-19 - Cyril Brulebois <kibi@debian.org>
libfs (2:1.0.3-1) unstable; urgency=low
[ Timo Aaltonen ]
* Drop pre-dependency on x11-common from libfs-dev. This was needed
for upgrades from sarge.
[ Julien Cristau ]
* Remove myself from Uploaders.
* Rename the build directory to not include DEB_BUILD_GNU_TYPE for no
good reason.  Thanks, Colin Watson!
[ Cyril Brulebois ]
* New upstream release.
* Wrap build-deps.
* Switch from --list-missing to --fail-missing for additional safety.
* Exclude libFS.la from dh_install accordingly.
* Add myself to Uploaders.
2009-07-27 - Brice Goglin <bgoglin@debian.org>
libfs (2:1.0.2-1) unstable; urgency=low
* New upstream release.
* Add a link to www.X.org and a reference to the upstream module
in the long description.
* Add README.source, bump Standards-Version to 3.8.2.
* Move the -dbg package to section debug.
* Add myself to Uploaders.
2008-05-25 - Julien Cristau <jcristau@debian.org>
libfs (2:1.0.1-1) unstable; urgency=low
* New upstream release.
* Install the upstream ChangeLog.
* Add upstream URL and missing copyright holders and licenses to
debian/copyright, based on upstream's new COPYING file.
2008-05-11 - Julien Cristau <jcristau@debian.org>
libfs (2:1.0.0-5) unstable; urgency=low
* Remove outdated cvs information from the package descriptions, and add
Vcs-* headers.
* Remove Branden and Fabio from Uploaders with their permission.
* Add myself to Uploaders.
* Bump Standards-Version to 3.7.3.
* Don't build-depend on packages with a -1 debian revision.
* libfs6 and libfs6-dbg don't need to depend on x11-common.
* Use ${binary:Version} instead of the deprecated  ${Source-Version}.
* Add Section control fields for binary packages.
* autoreconf with current autotools to get updated config.{guess,sub}.
2006-08-29 - David Nusinow <dnusinow@debian.org>
libfs (2:1.0.0-4) unstable; urgency=low
[ Andres Salomon ]
* Test for obj-$(DEB_BUILD_GNU_TYPE) before creating it during build;
idempotency fix.
* Run dh_install w/ --list-missing.
[ Drew Parsons ]
* dbg package has priority extra.
[ David Nusinow ]
* Version pre-depends on x11-common to bring things in line with policy
* Policy bump to 3.7.2.0
* Debhelper compat bump to 5

See Also

Package Description
libfs6_1.0.7-1+b2_i386.deb X11 Font Services library
libfsapfs-dev_20190210-1_i386.deb APFS access library -- development files
libfsapfs-utils_20190210-1_i386.deb APFS access library -- Utilities
libfsapfs1_20190210-1_i386.deb APFS access library
libfsntfs-dev_20190104-1_i386.deb NTFS access library -- development files
libfsntfs-utils_20190104-1_i386.deb NTFS access library -- Utilities
libfsntfs1_20190104-1_i386.deb NTFS access library
libfsplib-dev_0.11-2_i386.deb FSP v2 protocol stack library - development files
libfsplib0_0.11-2_i386.deb FSP v2 protocol stack library - shared library
libfst-dev_1.6.3-2_i386.deb weighted finite-state transducers library (development)
libfst-tools_1.6.3-2_i386.deb weighted finite-state transducers library (tools)
libfst8-plugins-base_1.6.3-2_i386.deb weighted finite-state transducers library (base plugins)
libfst8_1.6.3-2_i386.deb weighted finite-state transducers library (runtime)
libfstrcmp-dev_0.7.D001-1.1+b2_i386.deb fuzzy string compare library - development files
libfstrcmp0_0.7.D001-1.1+b2_i386.deb fuzzy string compare library - runtime library
Advertisement
Advertisement