libfcgi-perl_0.78-2+b3_i386.deb


Advertisement

Description

libfcgi-perl - helper module for FastCGI

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libfcgi-perl_0.78-2+b3_i386.deb
Package name libfcgi-perl
Package version 0.78
Package release 2+b3
Package architecture i386
Package type deb
Category devel::lang:perl devel::library implemented-in::c implemented-in::perl perl role::devel-lib web::cgi
Homepage https://metacpan.org/release/FCGI
License -
Maintainer Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>
Download size 40.16 KB
Installed size 109.00 KB
FCGI is a simple Perl module for writing FastCGI applications. FastCGI is a
language-independent, scalable, open extension to CGI that provides faster
performance by keeping programs persistent in memory and allowing them to
handle multiple requests. This module provides the core interface needed to
write these applications.
For complex applications, you should consider a more full-featured solution
such as Plack or Catalyst (see libcatalyst-perl).

Alternatives

Package Version Architecture Repository
libfcgi-perl_0.78-2+b3_amd64.deb 0.78 amd64 Debian Main
libfcgi-perl - - -

Requires

Name Value
libc6 >= 2.15
perl >= 5.28.0-3
perlapi-5.28.0 -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libfcgi-perl_0.78-2+b3_i386.deb
Source Package libfcgi-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libfcgi-perl deb package:
    # sudo apt-get install libfcgi-perl

Files

Path
/usr/lib/i386-linux-gnu/perl5/5.28/FCGI.pm
/usr/lib/i386-linux-gnu/perl5/5.28/auto/FCGI/FCGI.so
/usr/share/doc/libfcgi-perl/changelog.Debian.gz
/usr/share/doc/libfcgi-perl/changelog.Debian.i386.gz
/usr/share/doc/libfcgi-perl/changelog.gz
/usr/share/doc/libfcgi-perl/copyright
/usr/share/doc/libfcgi-perl/examples/echo.pl
/usr/share/doc/libfcgi-perl/examples/remote.pl
/usr/share/doc/libfcgi-perl/examples/threaded.pl
/usr/share/man/man3/FCGI.3pm.gz

Changelog

2016-10-16 - Florian Schlichting <fsfs@debian.org>
libfcgi-perl (0.78-2) unstable; urgency=medium
* Team upload
[ gregor herrmann ]
* Remove Jonathan Yu from Uploaders. Thanks for your work!
[ Florian Schlichting ]
* Add fix for CVE-2012-6687 in bundled libfcgi (closes: #815840)
2016-07-18 - gregor herrmann <gregoa@debian.org>
libfcgi-perl (0.78-1) unstable; urgency=medium
* Team upload.
[ Salvatore Bonaccorso ]
* Update Vcs-Browser URL to cgit web frontend
[ gregor herrmann ]
* Make example scripts executable.
Thanks to Herwin Weststrate for the bug report. (Closes: #778534)
* Mark package as autopkgtest-able.
[ Salvatore Bonaccorso ]
* debian/control: Use HTTPS transport protocol for Vcs-Git URI
[ gregor herrmann ]
* debian/copyright: change Copyright-Format 1.0 URL to HTTPS.
* Add debian/upstream/metadata.
* Import upstream version 0.78.
* debian/copyright: update Upstream-Contact.
* debian/copyright: update copyright years for configure script.
* Set bindnow linker flag in debian/rules.
* Declare compliance with Debian Policy 3.9.8.
2014-08-12 - gregor herrmann <gregoa@debian.org>
libfcgi-perl (0.77-1) unstable; urgency=medium
* Team upload.
* New upstream release.
* Drop debian/clean. Files are now removed by upstream build system.
2014-07-19 - gregor herrmann <gregoa@debian.org>
libfcgi-perl (0.75-1) unstable; urgency=medium
* Team upload.
* New upstream release.
* Drop fix-pod-error.patch, merged upstream.
* Install example scripts.
* Update copyright years for ./configure.
2014-03-09 - intrigeri <intrigeri@debian.org>
libfcgi-perl (0.74-2) unstable; urgency=low
* Team upload.
[ Alessandro Ghedini ]
* Email change: Alessandro Ghedini -> ghedo@debian.org
[ Salvatore Bonaccorso ]
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
* Change search.cpan.org based URIs to metacpan.org based URIs
[ Axel Beckert ]
* debian/copyright: migrate pre-1.0 format to 1.0 using "cme fix dpkg-
copyright"
[ gregor herrmann ]
* Strip trailing slash from metacpan URLs.
[ intrigeri ]
* Bump debhelper compat level to 9.
* Adjust versioned Build-Depends on debhelper to (>= 9.20120312~)
to get hardening build flags.
* Reformat debian/control with cme fix dpkg.
* Declare compatibility with Standards-Version 3.9.5.
2011-09-24 - Alessandro Ghedini <al3xbio@gmail.com>
libfcgi-perl (0.74-1) unstable; urgency=low
* New upstream release
* Drop cve-2011-2766.patch (merged upstream)
2011-09-17 - Damyan Ivanov <dmn@debian.org>
libfcgi-perl (0.73-2) unstable; urgency=high
* Team upload
+ High urgency for fixing a security bug
[ Ansgar Burchardt ]
* debian/control: Convert Vcs-* fields to Git.
[ Salvatore Bonaccorso ]
* debian/copyright: Replace DEP5 Format-Specification URL from
svn.debian.org to anonscm.debian.org URL.
[ Damyan Ivanov ]
* Add patch from upstream bug tracker fixing CVE-2011-2766
Closes: #607479. Thaks to Ferdinand for reporting, Russ Allbery for the
analysis and chansen for the patch.
2011-05-31 - Alessandro Ghedini <al3xbio@gmail.com>
libfcgi-perl (0.73-1) unstable; urgency=low
[ Ansgar Burchardt ]
* Update my email address.
[ Alessandro Ghedini ]
* New upstream release. (Closes: #627806)
* Bump Standards-Version to 3.9.2 (no changes needed)
* Bump debhelper compat level to 8
* Add myself to Uploaders
* Fix dh arguments ordering
* Drop fix-pod-spelling (merged upstream)
* Update upstream copyright year for the configure file
* Add fix-pod-error patch
2010-04-01 - Ansgar Burchardt <ansgar@43-1.org>
libfcgi-perl (0.71-1) unstable; urgency=low
* New upstream release.
* Remove README.source and quilt framework.
2010-03-23 - Krzysztof Krzy┼╝aniak (eloy) <eloy@debian.org>
libfcgi-perl (0.70-2) unstable; urgency=low
* Switch to dpkg-source 3.0 (quilt) format

See Also

Package Description
libfcgi-procmanager-maxrequests-perl_0.2-1_all.deb restrict max number of requests by each child
libfcgi-procmanager-perl_0.28-1_all.deb Perl module to help manage FastCGI applications
libfcgi0ldbl_2.4.0-10_i386.deb shared library of FastCGI
libfcitx-config4_4.2.9.6-5_i386.deb Flexible Input Method Framework - configuration support library
libfcitx-core0_4.2.9.6-5_i386.deb Flexible Input Method Framework - library of core functions
libfcitx-gclient1_4.2.9.6-5_i386.deb Flexible Input Method Framework - D-Bus client library for Glib
libfcitx-qt0_4.2.9.6-5_i386.deb Flexible Input Method Framework - Meta package for Qt library
libfcitx-qt5-1_1.2.3-2+b1_i386.deb Free Chinese Input Toy of X - D-Bus client libraries for Qt5
libfcitx-qt5-data_1.2.3-2_all.deb Free Chinese Input Toy of X - data files for Qt5 integration
libfcitx-qt5-dev_1.2.3-2+b1_i386.deb Free Chinese Input Toy of X - Devel files for libfcitx-qt5
libfcitx-utils0_4.2.9.6-5_i386.deb Flexible Input Method Framework - utility support library
libfcitx5config-dev_0~20181128+ds1-1_i386.deb Fcitx Input Method Framework v5 (config library dev files)
libfcitx5config5_0~20181128+ds1-1_i386.deb Fcitx Input Method Framework v5 (config library)
libfcitx5core-dev_0~20181128+ds1-1_i386.deb Fcitx Input Method Framework v5 (core library dev files)
libfcitx5core5_0~20181128+ds1-1_i386.deb Fcitx Input Method Framework v5 (core library)
Advertisement
Advertisement