liberasurecode-dev_1.6.0-3_i386.deb


Advertisement

Description

liberasurecode-dev - support of multiple erasure code backends - development files

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename liberasurecode-dev_1.6.0-3_i386.deb
Package name liberasurecode-dev
Package version 1.6.0
Package release 3
Package architecture i386
Package type deb
Category devel::library libdevel role::devel-lib
Homepage https://github.com/openstack/liberasurecode
License -
Maintainer Debian OpenStack <team+openstack@tracker.debian.org>
Download size 18.88 KB
Installed size 109.00 KB
Liberasurecode is an erasure code library which can support multiple erasure
code 'backends'. The repository includes a Jerasure for Reed-Solomon
implementation.
This package contains the development files needed to build against the shared
library.

Alternatives

Package Version Architecture Repository
liberasurecode-dev_1.6.0-3_amd64.deb 1.6.0 amd64 Debian Main
liberasurecode-dev - - -

Requires

Name Value
liberasurecode1 = 1.6.0-3

Download

Type URL
Mirror ftp.br.debian.org
Binary Package liberasurecode-dev_1.6.0-3_i386.deb
Source Package liberasurecode

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install liberasurecode-dev deb package:
    # sudo apt-get install liberasurecode-dev

Files

Path
/usr/include/config_liberasurecode.h
/usr/include/erasurecode.h
/usr/include/erasurecode_helpers.h
/usr/include/erasurecode_stdinc.h
/usr/include/erasurecode_version.h
/usr/include/liberasurecode/alg_sig.h
/usr/include/liberasurecode/config_liberasurecode.h
/usr/include/liberasurecode/erasurecode.h
/usr/include/liberasurecode/erasurecode_backend.h
/usr/include/liberasurecode/erasurecode_helpers.h
/usr/include/liberasurecode/erasurecode_helpers_ext.h
/usr/include/liberasurecode/erasurecode_log.h
/usr/include/liberasurecode/erasurecode_postprocessing.h
/usr/include/liberasurecode/erasurecode_preprocessing.h
/usr/include/liberasurecode/erasurecode_stdinc.h
/usr/include/liberasurecode/erasurecode_version.h
/usr/include/liberasurecode/liberasurecode_rs_vand.h
/usr/include/liberasurecode/list.h
/usr/include/liberasurecode/rs_galois.h
/usr/include/liberasurecode/xor_code.h
/usr/include/liberasurecode/xor_hd_code_defs.h
/usr/lib/i386-linux-gnu/libXorcode.so
/usr/lib/i386-linux-gnu/liberasurecode.so
/usr/lib/i386-linux-gnu/liberasurecode_rs_vand.so
/usr/lib/i386-linux-gnu/libnullcode.so
/usr/share/doc/liberasurecode-dev/changelog.Debian.gz
/usr/share/doc/liberasurecode-dev/changelog.gz
/usr/share/doc/liberasurecode-dev/copyright

Changelog

2018-10-01 - Ondřej Nový <onovy@debian.org>
liberasurecode (1.6.0-3) unstable; urgency=medium
* d/control:
- Build depend on libisal on amd64 archs to run unit tests during build
- Build depend on libjerasure to run unit tests during build
2018-09-30 - Ondřej Nový <onovy@debian.org>
liberasurecode (1.6.0-2) unstable; urgency=medium
* Fix building with LD_LIBRARY_PATH set (Closes: #906480)
2018-09-27 - Ondřej Nový <onovy@debian.org>
liberasurecode (1.6.0-1) unstable; urgency=medium
* New upstream release
* d/rules: Use dh_missing --fail-missing and don't build static
* Standards-Version is 4.1.2 now (no changes needed)
* Mark liberasurecode-dev as Multi-Arch: same
* d/control:
- Set Vcs-* to salsa.debian.org
- d/control: Add trailing tilde to min version depend to allow
backports
- Use team+openstack@tracker.debian.org as maintainer
- Add zlib1g-dev into B-D
* d/copyright: Bump my copyright year
* d/tests: Use AUTOPKGTEST_TMP instead of ADTTMP
* d/liberasurecode1.symbols: Update for new upstream release
* Bumped debhelper version to 11
* Add upstream metadata
* Standards-Version is 4.2.1 now (no change)
2017-08-06 - Ondřej Nový <onovy@debian.org>
liberasurecode (1.5.0-1) unstable; urgency=medium
[ Ondřej Nový ]
* New upstream release
* d/copyright: Add more copyright holders
* d/patches/disable-sse.patch: Patch dropped and use --disable-mmi configure
option instead
* Bump required version of libjerasure2
[ Daniel Baumann ]
* Updating vcs fields.
* Updating copyright format url.
* Running wrap-and-sort -bast.
* Updating maintainer field.
* Removing gbp.conf, not used anymore or should be specified in the
developers dotfiles.
* Updating standards version to 4.0.1.
* Deprecating priority extra as per policy 4.0.1.
2016-12-29 - Ondřej Nový <onovy@debian.org>
liberasurecode (1.4.0-2) unstable; urgency=medium
* Remove d/files from source package
2016-12-11 - Ondřej Nový <onovy@debian.org>
liberasurecode (1.4.0-1) unstable; urgency=medium
* New upstream release
* Removed B-D on autoconf-archive and autotools-dev - they are not needed
* debian/tests: Added EC_BACKEND_ISA_L_RS_CAUCHY backend test
2016-11-14 - Ondřej Nový <onovy@debian.org>
liberasurecode (1.3.1-1) unstable; urgency=medium
* New upstream release
* d/{control,copyright}: Use my @debian.org email address
* d/s/options: extend-diff-ignore of .gitreview
* d/control: Using OpenStack's Gerrit as VCS URLs.
* Bumped debhelper version to 10
2016-06-01 - Ondřej Nový <novy@ondrej.org>
liberasurecode (1.2.0-1) unstable; urgency=medium
* New upstream release
* Upstream moved to official Openstack project
* Standards-Version is 3.9.8 now (no change)
* Removed reproducible-build.patch and use-full-soname.patch
(Applied upstream)
* Rebased disable-sse.patch
* Added symbols file
* Debian tests enhancement:
- test encode+decode and compare result
- test EC_BACKEND_FLAT_XOR_HD backend
2016-03-01 - Ondřej Nový <novy@ondrej.org>
liberasurecode (1.1.0-5) unstable; urgency=medium
* Debian tests fixies.
* Added Suggests: libisal2.
2016-02-28 - Ondřej Nový <novy@ondrej.org>
liberasurecode (1.1.0-4) unstable; urgency=medium
* Added myself as uploader.
* Added myself to copyright file.
* Enabled additional hardening (hardening=+all).
* Fixed Vcs URL (https).
* Fixed order in d/copyright.
* Standards-Version is 3.9.7 now (no change).
* Added header to d/patches/reproducible-build.patch
* Added Debian tests.
* Removed shlibs substitution in dependency from liberasurecode-dev
* Added Suggests: libjerasure2.

See Also

Package Description
liberasurecode1_1.6.0-3_i386.deb support of multiple erasure code backends - shared library
liberfa-dev_1.4.0-1_i386.deb Essential Routines for Fundamental Astronomy (development files)
liberfa1_1.4.0-1_i386.deb Essential Routines for Fundamental Astronomy
liberis-1.3-21_1.3.23-7+b1_i386.deb WorldForge client entity library
liberis-1.3-dev_1.3.23-7+b1_i386.deb WorldForge client entity library - development files
liberis-doc_1.3.23-7_all.deb WorldForge client entity library - API documentation
liberror-perl_0.17027-2_all.deb Perl module for error/exception handling in an OO-ish way
libesd-java_0.0.7-4_all.deb Implementation of EsounD in pure Java
libesedb-dev_20181229-3_i386.deb Extensible Storage Engine DB access library -- development files
libesedb-utils_20181229-3_i386.deb Extensible Storage Engine DB access library -- Utilities
libesedb1_20181229-3_i386.deb Extensible Storage Engine DB access library
libesmtp-dev_1.0.6-4.3_i386.deb LibESMTP SMTP client library (development files)
libesmtp6_1.0.6-4.3_i386.deb LibESMTP SMTP client library
libesnacc-dev_1.8.1-1_i386.deb ASN.1 to C or C++ or IDL compiler, development files
libesnacc180_1.8.1-1_i386.deb ASN.1 to C or C++ or IDL compiler, shared libraries
Advertisement
Advertisement