libept1.5.0_1.1+nmu3+b1_i386.deb


Advertisement

Description

libept1.5.0 - High-level library for managing Debian package information

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libept1.5.0_1.1+nmu3+b1_i386.deb
Package name libept1.5.0
Package version 1.1+nmu3+b1
Package release -
Package architecture i386
Package type deb
Category libs role::shared-lib
Homepage -
License -
Maintainer Enrico Zini <enrico@debian.org>
Download size 96.25 KB
Installed size 268.00 KB
The library defines a very minimal framework in which many sources of data
about Debian packages can be implemented and queried together.
The library includes four data sources:
* APT: access the APT database
* Debtags: access the Debtags tag information
* Popcon: access Popcon package scores
* The Xapian index built by apt-xapian-index
This is the shared library.

Alternatives

Package Version Architecture Repository
libept1.5.0_1.1+nmu3+b1_amd64.deb 1.1+nmu3+b1 amd64 Debian Main
libept1.5.0 - - -

Requires

Name Value
libapt-pkg5.0 >= 1.1~exp9
libc6 >= 2.7
libgcc1 >= 1:3.0
libstdc++6 >= 5.2
libxapian30 -

Replaces

Name Value
libept1.4.16 = 1.0.14+b2

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libept1.5.0_1.1+nmu3+b1_i386.deb
Source Package libept

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libept1.5.0 deb package:
    # sudo apt-get install libept1.5.0

Files

Path
/usr/lib/i386-linux-gnu/libept.so.1.aptpkg5.0
/usr/share/doc/libept1.5.0/buildinfo_i386.gz
/usr/share/doc/libept1.5.0/changelog.gz
/usr/share/doc/libept1.5.0/changelog.i386.gz
/usr/share/doc/libept1.5.0/copyright

Changelog

2015-11-28 - Julian Andres Klode <jak@debian.org>
libept (1.1+nmu3) unstable; urgency=medium
* Non-maintainer upload
* Break and replace libept1.4.16 (= 1.0.14+b2) from broken binNMU
(Closes: #806509)
* Include apt-pkg library version in install file for next APT ABI
break
* apt/utils/sys.cc: Define O_PATH as 0 if undefined (for !linux)
2015-11-27 - Julian Andres Klode <jak@debian.org>
libept (1.1+nmu2) unstable; urgency=medium
* Non-maintainer upload
* Upload to unstable for APT 1.1 transition.
2015-09-11 - Julian Andres Klode <jak@debian.org>
libept (1.1+nmu1) experimental; urgency=medium
* Non-maintainer upload with permission from the maintainer.
* Build against APT 1.1
2015-09-10 - Enrico Zini <enrico@debian.org>
libept (1.1) experimental; urgency=medium
* Removed need of tagcoll and wibble
* Removed popcon/ support
2015-08-11 - Enrico Zini <enrico@debian.org>
libept (1.0.14) unstable; urgency=medium
* New version that includes Matthias' changes
* Removed compatibility symlink, not needed anymore
2015-08-09 - Matthias Klose <doko@debian.org>
libept (1.0.13.1) experimental; urgency=medium
* Non maintainer upload.
* Rebuild using GCC 5. Addresses: #777944.
* Tighten dependencies on -dev packages.
* Rename libept1.4.12 to libept1.4.16 for the apt transition.
* Update links and install files.
2015-06-18 - Enrico Zini <enrico@debian.org>
libept (1.0.13) experimental; urgency=medium
[Raúl Sánchez Siles]
* Fix "missing link /usr/lib/libept.so.1.0.5.4.12" Link now depends on
architecture using dh-exec (Closes: #727694)
[Enrico Zini]
* Added cmake_minimum_required. Closes: #788770
* Simplified debtags code
- tag and vocabulary data are loaded only from /var/lib/debtags/
- local patches are not supported anymore
- tag and vocabulary merging are not supported anymore
- removed support for patched collections
* Removed obsolete package ept-cache. Closes: #436748
2014-10-06 - Enrico Zini <enrico@debian.org>
libept (1.0.12.1) unstable; urgency=medium
* Redone parsing of Tag fields, to cope with multiline fields
* Get tag data from /var/lib/debtags/package-tags and
/var/lib/debtags/vocabulary if they are available. Closes: #762347
* Updated standards-version, no changes required.
* Set priority to optional. Closes: #741632
* Migrated to dh_installdeb maintscript support. Closes: #659749
2013-10-24 - Enrico Zini <enrico@debian.org>
libept (1.0.12) unstable; urgency=low
* Fixes a case of sizeof(struct stat) disagreeing between libwibble and
libept on some architectures.
2013-10-24 - Enrico Zini <enrico@debian.org>
libept (1.0.11) unstable; urgency=low
* Added explicit template instantiation with the symbols aptitude needs.
Closes: #727540

See Also

Package Description
libepub-dev_0.2.2-4+b4_i386.deb library to work with the EPUB file format - development files
libepub0_0.2.2-4+b4_i386.deb library to work with the EPUB file format - runtime library
libepubgen-0.1-1_0.1.1-1_i386.deb EPUB generator library
libepubgen-dev_0.1.1-1_i386.deb EPUB generator library -- development
libequinox-app-java_1.4.0+eclipse4.10-1_all.deb Eclipse Equinox Application Container
libequinox-bidi-java_1.1.200+eclipse4.10-1_all.deb Eclipse Equinox Bidirectional Text Support
libequinox-cm-java_1.3.100+eclipse4.10-1_all.deb Eclipse Equinox Configuration Admin
libequinox-common-java_3.10.200+eclipse4.10-1_all.deb Eclipse Equinox Common Utility Bundle
libequinox-concurrent-java_1.1.200+eclipse4.10-1_all.deb Eclipse Equinox Concurrent API
libequinox-console-java_1.3.200+eclipse4.10-1_all.deb Eclipse Equinox Console plug-in
libequinox-coordinator-java_1.3.600+eclipse4.10-1_all.deb Eclipse Equinox Coordinator
libequinox-device-java_1.0.800+eclipse4.10-1_all.deb Eclipse Equinox Device Access Service
libequinox-ds-java_1.5.200+eclipse4.10-1_all.deb Eclipse Equinox Declarative Services
libequinox-event-java_1.5.0+eclipse4.10-1_all.deb Eclipse Equinox Event Admin
libequinox-frameworkadmin-equinox-java_1.1.100+eclipse4.10-1_all.deb Equinox Framework Admin for Equinox
Advertisement
Advertisement