libencode-hanextra-perl_0.23-5+b1_i386.deb


Advertisement

Description

libencode-hanextra-perl - perl module providing extra sets of Chinese character encodings

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libencode-hanextra-perl_0.23-5+b1_i386.deb
Package name libencode-hanextra-perl
Package version 0.23
Package release 5+b1
Package architecture i386
Package type deb
Category devel::lang:perl devel::library implemented-in::c implemented-in::perl perl role::devel-lib role::shared-lib
Homepage https://metacpan.org/release/Encode-HanExtra
License -
Maintainer Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>
Download size 1011.35 KB
Installed size 5.27 MB
Perl 5.7.3 and later ships with an adequate set of Chinese encodings,
including the commonly used CP950, CP936 (also known as GBK),
Big5 (alias for Big5-Eten), Big5-HKSCS, EUC-CN, HZ, and
ISO-IR-165. However, the numbers of Chinese encodings are staggering,
and a complete coverage will easily increase the size of perl distribution
by several megabytes; hence, this module tries to provide the rest of them.
If you are using Perl 5.8 or later, Encode::CN and Encode::TW will
automatically load the extra encodings for you, so there's no need to
explicitly write "use Encode::HanExtra" if you are using one of them
already.

Alternatives

Package Version Architecture Repository
libencode-hanextra-perl_0.23-5+b1_amd64.deb 0.23 amd64 Debian Main
libencode-hanextra-perl - - -

Requires

Name Value
libc6 >= 2.1.3
perl >= 5.28.0-3
perlapi-5.28.0 -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libencode-hanextra-perl_0.23-5+b1_i386.deb
Source Package libencode-hanextra-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libencode-hanextra-perl deb package:
    # sudo apt-get install libencode-hanextra-perl

Files

Path
/usr/lib/i386-linux-gnu/perl5/5.28/Encode/HanExtra.pm
/usr/lib/i386-linux-gnu/perl5/5.28/Encode/TW/Unisys/SOSI1.pm
/usr/lib/i386-linux-gnu/perl5/5.28/Encode/TW/Unisys/SOSI2.pm
/usr/lib/i386-linux-gnu/perl5/5.28/auto/Encode/HanExtra/HanExtra.so
/usr/share/doc/libencode-hanextra-perl/changelog.Debian.gz
/usr/share/doc/libencode-hanextra-perl/changelog.Debian.i386.gz
/usr/share/doc/libencode-hanextra-perl/changelog.gz
/usr/share/doc/libencode-hanextra-perl/copyright
/usr/share/man/man3/Encode::HanExtra.3pm.gz
/usr/share/man/man3/Encode::TW::Unisys::SOSI1.3pm.gz
/usr/share/man/man3/Encode::TW::Unisys::SOSI2.3pm.gz

Changelog

2018-01-21 - intrigeri <intrigeri@debian.org>
libencode-hanextra-perl (0.23-5) unstable; urgency=medium
* Team upload.
[ Salvatore Bonaccorso ]
* debian/control: Use HTTPS transport protocol for Vcs-Git URI
[ gregor herrmann ]
* Change bugtracker URL(s) to HTTPS.
* debian/copyright: change Copyright-Format 1.0 URL to HTTPS.
[ intrigeri ]
* Declare compliance with Standards-Version 4.1.3.
* Bump debhelper compatibility level to 11.
* Enable all hardening build options.
* Declare Rules-Requires-Root: no.
* Add build-dependency on libmodule-install-perl: the embedded copy
is not used with dh compat v11.
* Reformat debian/* with "cme fix dpkg".
2015-06-04 - Niko Tyni <ntyni@debian.org>
libencode-hanextra-perl (0.23-4) unstable; urgency=medium
* Team upload.
[ Salvatore Bonaccorso ]
* Update Vcs-Browser URL to cgit web frontend
[ Niko Tyni ]
* Make the build reproducible by sorting hash keys in Makefile.PL.
(Closes: #787754)
* Declare the package autopkgtestable
2014-04-13 - Florian Schlichting <fsfs@debian.org>
libencode-hanextra-perl (0.23-3) unstable; urgency=low
[ Ansgar Burchardt ]
* debian/control: Convert Vcs-* fields to Git.
[ Salvatore Bonaccorso ]
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
* Change search.cpan.org based URIs to metacpan.org based URIs
[ Axel Beckert ]
* debian/copyright: migrate pre-1.0 format to 1.0 using "cme fix dpkg-
copyright"
[ gregor herrmann ]
* debian/control: remove Nicholas Bamber from Uploaders on request of
the MIA team.
* Strip trailing slash from metacpan URLs.
[ Florian Schlichting ]
* Switch dh compatibility to level 9 to enable passing of hardening flags
* Declare compliance with Debian Policy 3.9.5
* Add copyright paragraph for Module::Install
* Remove extra "perl" from Depends
* Add myself to uploaders and copyright
2010-08-06 - Nicholas Bamber <nicholas@periapt.co.uk>
libencode-hanextra-perl (0.23-2) unstable; urgency=low
* Adding patch headers.
2010-08-05 - Nicholas Bamber <nicholas@periapt.co.uk>
libencode-hanextra-perl (0.23-1) unstable; urgency=low
* Initial Release. (Closes: #381459)

See Also

Package Description
libencode-imaputf7-perl_1.05-2_all.deb modification of UTF-7 encoding for IMAP
libencode-jis2k-perl_0.03-1+b5_i386.deb perl module providing JIS X 0212 (aka JIS 2000) Encodings
libencode-locale-perl_1.05-1_all.deb utility to determine the locale encoding
libencode-perl_3.00-1_i386.deb module providing interfaces between Perl's strings and the system
libencode-zapcp1252-perl_0.33-3_all.deb zap Windows Western gremlin characters
libencoding-fixlatin-perl_1.04-1_all.deb takes mixed encoding input and produces UTF-8 output
libencoding-fixlatin-xs-perl_1.01-3+b1_i386.deb XS implementation layer for Encoding::FixLatin
libend-perl_2009110401-1_all.deb Perl interface to execute code at end of scope
libendless-0-0_0~git20180727+ds-1_i386.deb Endless SDK runtime libraries
libendless-0-common_0~git20180727+ds-1_all.deb common files for the Endless SDK runtime libraries
libendless-bin_0~git20180727+ds-1_i386.deb development tools for the Endless SDK
libendless-dev_0~git20180727+ds-1_i386.deb development files for the Endless SDK
libendless-doc_0~git20180727+ds-1_all.deb documentation files for the Endless SDK
libenet-dev_1.3.13+ds-1_i386.deb thin network communication layer on top of UDP - headers
libenet-doc_1.3.13+ds-1_all.deb thin network communication layer on top of UDP - documentation
Advertisement
Advertisement