libdist-zilla-plugin-test-notabs-perl_0.15-3_all.deb


Advertisement

Description

libdist-zilla-plugin-test-notabs-perl - Dist::Zilla plugin to make sure hard tabs are not used

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libdist-zilla-plugin-test-notabs-perl_0.15-3_all.deb
Package name libdist-zilla-plugin-test-notabs-perl
Package version 0.15
Package release 3
Package architecture all
Package type deb
Category devel::lang:perl devel::library implemented-in::perl perl
Homepage https://metacpan.org/release/Dist-Zilla-Plugin-Test-NoTabs
License -
Maintainer Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>
Download size 13.51 KB
Installed size 39.00 KB
The Dist::Zilla::Plugin::Test::NoTabs plugin runs at the gather files
stage. It provides the file xt/release/no-tabs.t, a standard
Test::NoTabs test.
If needed, custom module and file finders may be provided by
the user.

Alternatives

Package Version Architecture Repository
libdist-zilla-plugin-test-notabs-perl_0.15-3_all.deb 0.15 all Debian Main
libdist-zilla-plugin-test-notabs-perl - - -

Requires

Name Value
libdata-section-perl -
libdist-zilla-perl >= 4.300039
libmoose-perl -
libnamespace-autoclean-perl -
libpath-tiny-perl -
libsub-exporter-formethods-perl -
perl -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libdist-zilla-plugin-test-notabs-perl_0.15-3_all.deb
Source Package libdist-zilla-plugin-test-notabs-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libdist-zilla-plugin-test-notabs-perl deb package:
    # sudo apt-get install libdist-zilla-plugin-test-notabs-perl

Files

Path
/usr/share/doc/libdist-zilla-plugin-test-notabs-perl/CONTRIBUTING
/usr/share/doc/libdist-zilla-plugin-test-notabs-perl/changelog.Debian.gz
/usr/share/doc/libdist-zilla-plugin-test-notabs-perl/changelog.gz
/usr/share/doc/libdist-zilla-plugin-test-notabs-perl/copyright
/usr/share/man/man3/Dist::Zilla::Plugin::NoTabsTests.3pm.gz
/usr/share/man/man3/Dist::Zilla::Plugin::Test::NoTabs.3pm.gz
/usr/share/perl5/Dist/Zilla/Plugin/NoTabsTests.pm
/usr/share/perl5/Dist/Zilla/Plugin/Test/NoTabs.pm

Changelog

2018-10-29 - intrigeri <intrigeri@debian.org>
libdist-zilla-plugin-test-notabs-perl (0.15-3) unstable; urgency=medium
[ Salvatore Bonaccorso ]
* Update Vcs-* headers for switch to salsa.debian.org
[ David Miguel Susano Pinto ]
* Recommend libtest-notabs-perl which is required to run the generated
tests.
[ intrigeri ]
* Bump debhelper compatibility level to 11.
* Stop versioning build-dependency that's satisfied in all currently
supported Debian releases.
* Declare compliance with Debian Policy 4.2.1.
2017-06-24 - intrigeri <intrigeri@debian.org>
libdist-zilla-plugin-test-notabs-perl (0.15-2) unstable; urgency=medium
[ Salvatore Bonaccorso ]
* debian/control: Use HTTPS transport protocol for Vcs-Git URI
[ gregor herrmann ]
* debian/copyright: change Copyright-Format 1.0 URL to HTTPS.
[ intrigeri ]
* Declare compliance with Standards-Version 4.0.0 (no change required).
* Bump debhelper compat level to 10, adjust build-dependencies accordingly.
2015-07-04 - gregor herrmann <gregoa@debian.org>
libdist-zilla-plugin-test-notabs-perl (0.15-1) unstable; urgency=medium
* Team upload.
* Import upstream version 0.15.
* Update Upstream-Contact in debian/copyright.
* Mark package as autopkgtest-able.
2015-04-29 - intrigeri <intrigeri@debian.org>
libdist-zilla-plugin-test-notabs-perl (0.14-1) unstable; urgency=medium
* Add upstream-vcs-tag to debian/gbp.conf, so that `gbp import-orig'
automatically merges the upstream release tag.
* Import new upstream releases.
* Declare compliance with Standards-Version 3.9.6 (no change required).
* Stop versioning build-dependency on libmodule-build-tiny-perl:
Debian has never had an older version than the one required.
* Bump copyright years for debian/*.
2014-08-19 - intrigeri <intrigeri@debian.org>
libdist-zilla-plugin-test-notabs-perl (0.09-1) unstable; urgency=medium
[ Salvatore Bonaccorso ]
* Update Vcs-Browser URL to cgit web frontend
[ intrigeri ]
* Import new upstream release.
* Update build-dependencies:
- bump libmodule-build-tiny-perl to >= 0.037
- bump libdist-zilla-perl to >= 4.300039
- add libfile-pushd-perl
- add libtest-deep-perl
* Update runtime dependencies: bump libdist-zilla-perl to >= 4.300039.
2014-05-07 - intrigeri <intrigeri@debian.org>
libdist-zilla-plugin-test-notabs-perl (0.08-1) unstable; urgency=medium
* New upstream release.
* Bump build-dependency on libmodule-build-tiny to >= 0.036.
* Add build-dependency on libtest-requires-perl.
2014-05-03 - intrigeri <intrigeri@debian.org>
libdist-zilla-plugin-test-notabs-perl (0.07-1) unstable; urgency=medium
[ gregor herrmann ]
* Install CONTRIBUTING file.
* debian/control: bump required debhelper version for
Module::Build::Tiny to 9.20140227.
[ intrigeri ]
* Add upstream/metadata file.
* New upstream release.
2013-12-21 - gregor herrmann <gregoa@debian.org>
libdist-zilla-plugin-test-notabs-perl (0.06-1) unstable; urgency=medium
* Team upload.
* New upstream release.
* Update build dependencies.
2013-10-18 - gregor herrmann <gregoa@debian.org>
libdist-zilla-plugin-test-notabs-perl (0.05-1) unstable; urgency=low
* Team upload.
* New upstream release.
* Bump versioned build dependency on libmodule-build-tiny-perl. Move it
to Build-Depends, and require newer debehlper.
2013-10-05 - intrigeri <intrigeri@debian.org>
libdist-zilla-plugin-test-notabs-perl (0.04-1) unstable; urgency=low
* Initial Release (Closes: #725112).

See Also

Package Description
libdist-zilla-plugin-test-perl-critic-perl_3.001-2_all.deb Dist::Zilla plugin to check your code with perlcritic
libdist-zilla-plugin-test-podspelling-perl_2.007005-1_all.deb Author tests for POD spelling
libdist-zilla-plugin-test-reportprereqs-perl_0.027-1_all.deb module to report on prerequisite versions during automated testing
libdist-zilla-plugin-twitter-perl_0.026-2_all.deb Twitter when you release with Dist::Zilla
libdist-zilla-plugins-cjm-perl_6.000-1_all.deb collection of CJM's plugins for Dist::Zilla
libdist-zilla-role-bootstrap-perl_1.001004-1_all.deb Shared logic for Dist::Zilla-related bootstrap things
libdist-zilla-role-modulemetadata-perl_0.006-1_all.deb role for plugins that use Module::Metadata
libdist-zilla-role-pluginbundle-pluginremover-perl_0.104-1_all.deb Dist::Zilla plugin to add '-remove' functionality to a bundle
libdist-zilla-util-configdumper-perl_0.003009-1_all.deb simplify extraction of plugin settings for Dist::Zilla plugin authors
libdist-zilla-util-test-kentnl-perl_1.005014-1_all.deb Module to write tests for Dist::Zilla plugins
libdistorm3-3_3.4.1-3_i386.deb powerful disassembler library for x86/AMD64 binary streams
libdistorm3-dev_3.4.1-3_i386.deb powerful disassembler library for x86/AMD64 binary streams (development files)
libdistorm64-1_1.7.30-1_i386.deb ultimate disassembler library for x86 code
libdistorm64-dev_1.7.30-1_i386.deb ultimate disassembler library for x86 code - header files
libdistro-info-perl_0.21_all.deb information about distributions' releases (Perl module)
Advertisement
Advertisement