libdist-zilla-plugin-prepender-perl_2.004-1_all.deb


Advertisement

Description

libdist-zilla-plugin-prepender-perl - Dist::Zilla plugin to prepend lines at the top of your perl files

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libdist-zilla-plugin-prepender-perl_2.004-1_all.deb
Package name libdist-zilla-plugin-prepender-perl
Package version 2.004
Package release 1
Package architecture all
Package type deb
Category devel::lang:perl devel::library implemented-in::perl perl role::shared-lib
Homepage https://metacpan.org/release/Dist-Zilla-Plugin-Prepender
License -
Maintainer Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>
Download size 8.76 KB
Installed size 25.00 KB
Dist::Zilla::Plugin::Prepender will prepend lines specified in
dist.ini to each Perl module or program within your Perl
distribution. For scripts having a shebang line, lines will be
inserted just after it.
This module is useful to enforce a set of pragmas to your files (since
pragmas are lexical, they will be active for the whole file), or to
add some copyright comments, as recommended by the Free Software
Foundation.

Alternatives

Package Version Architecture Repository
libdist-zilla-plugin-prepender-perl_2.004-1_all.deb 2.004 all Debian Main
libdist-zilla-plugin-prepender-perl - - -

Requires

Name Value
libdist-zilla-perl -
libmoose-perl -
perl -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libdist-zilla-plugin-prepender-perl_2.004-1_all.deb
Source Package libdist-zilla-plugin-prepender-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libdist-zilla-plugin-prepender-perl deb package:
    # sudo apt-get install libdist-zilla-plugin-prepender-perl

Files

Path
/usr/share/doc/libdist-zilla-plugin-prepender-perl/changelog.Debian.gz
/usr/share/doc/libdist-zilla-plugin-prepender-perl/changelog.gz
/usr/share/doc/libdist-zilla-plugin-prepender-perl/copyright
/usr/share/man/man3/Dist::Zilla::Plugin::Prepender.3pm.gz
/usr/share/perl5/Dist/Zilla/Plugin/Prepender.pm

Changelog

2017-11-05 - Damyan Ivanov <dmn@debian.org>
libdist-zilla-plugin-prepender-perl (2.004-1) unstable; urgency=medium
* Team upload
* New upstream version 2.004
* remove (build) dependency on libmoosex-has-sugar-perl
* declare conformance with Policy 4.1.1 (no changes needed)
2016-11-28 - gregor herrmann <gregoa@debian.org>
libdist-zilla-plugin-prepender-perl (2.003-1) unstable; urgency=medium
[ Salvatore Bonaccorso ]
* debian/control: Use HTTPS transport protocol for Vcs-Git URI
[ gregor herrmann ]
* debian/upstream/metadata: change GitHub/CPAN URL(s) to HTTPS.
* debian/upstream/metadata: use HTTPS for GitHub URLs.
* Import upstream version 2.003.
Fixes "Deprecation Warning with Dist::Zilla v6, will FTBFS with
Dist::Zilla v7" (Closes: #825313)
* Update debian/upstream/metadata.
* Update build dependencies.
* Update {Upstream-,}Contact.
* Update years of packaging copyright.
* Declare compliance with Debian Policy 3.9.8.
2015-08-21 - Lucas Kanashiro <kanashiro.duarte@gmail.com>
libdist-zilla-plugin-prepender-perl (2.002-1) unstable; urgency=medium
* Team upload.
* Import upstream version 2.002
* Bump debhelper compatibility level to 9
2015-06-01 - gregor herrmann <gregoa@debian.org>
libdist-zilla-plugin-prepender-perl (2.001-1) unstable; urgency=low
[ gregor herrmann ]
* debian/control: update {versioned,alternative} (build) dependencies.
[ Salvatore Bonaccorso ]
* Change Vcs-Git to canonical URI (git://anonscm.debian.org)
* Change search.cpan.org based URIs to metacpan.org based URIs
[ gregor herrmann ]
* Strip trailing slash from metacpan URLs.
[ Salvatore Bonaccorso ]
* Update Vcs-Browser URL to cgit web frontend
[ gregor herrmann ]
* Add debian/upstream/metadata
* Import upstream version 2.001
* Update years of packaging copyright.
* debian/copyright: switch formatting to Copyright-Format 1.0.
* Unconditionally build depend on libmodule-build-perl.
* Declare compliance with Debian Policy 3.9.6.
* Mark package as autopkgtest-able.
2011-08-27 - gregor herrmann <gregoa@debian.org>
libdist-zilla-plugin-prepender-perl (1.112280-1) unstable; urgency=low
[ Salvatore Bonaccorso ]
* debian/copyright: Replace DEP5 Format-Specification URL from
svn.debian.org to anonscm.debian.org URL.
[ gregor herrmann ]
* New upstream release.
* Add /me to Uploaders.
* Set Standards-Version to 3.9.2 (no changes).
* Update (alternative) build dependencies.
* Bump debhelper compatibility level to 8.
* Add missing Vcs- headers.
* Email change: Dominique Dumont -> dod@debian.org
2010-12-16 - Ansgar Burchardt <ansgar@debian.org>
libdist-zilla-plugin-prepender-perl (1.103470-1) unstable; urgency=low
* Team upload.
* New upstream release.
* Bump build-dep on libtest-simple-perl to >= 0.94.
* Correct build-dep on libmodule-build-perl to 0.360100 (was 0.3601).
* debian/copyright: Refer to "Debian systems" instead of "Debian GNU/Linux
systems".
2010-09-24 - Dominique Dumont <dominique.dumont@hp.com>
libdist-zilla-plugin-prepender-perl (1.101590-1) unstable; urgency=low
* Initial Release (Closes: #597618)

See Also

Package Description
libdist-zilla-plugin-readmefrompod-perl_0.37-1_all.deb Dist::Zilla plugin to generate a README from Pod
libdist-zilla-plugin-repository-perl_0.24-1_all.deb Dist::Zilla plugin to discovery repository URL from svn/svk/Git checkout
libdist-zilla-plugin-requiresexternal-perl_1.008-1_all.deb Dist::Zilla plugin to declare dependency on command-line tools
libdist-zilla-plugin-run-perl_0.048-1_all.deb Dist::Zilla plugin to execute external commands
libdist-zilla-plugin-templatefiles-perl_0.03-1_all.deb plugin that enables the use of templates in a Dist::Zilla distribution
libdist-zilla-plugin-test-compile-perl_2.058-1_all.deb common tests to check syntax of your modules, using only core modules
libdist-zilla-plugin-test-eol-perl_0.19-2_all.deb Dist::Zilla plugin to make sure that correct line endings are used
libdist-zilla-plugin-test-kwalitee-perl_2.12-1_all.deb Dist::Zilla plugin providing a release-time Kwalitee test
libdist-zilla-plugin-test-notabs-perl_0.15-3_all.deb Dist::Zilla plugin to make sure hard tabs are not used
libdist-zilla-plugin-test-perl-critic-perl_3.001-2_all.deb Dist::Zilla plugin to check your code with perlcritic
libdist-zilla-plugin-test-podspelling-perl_2.007005-1_all.deb Author tests for POD spelling
libdist-zilla-plugin-test-reportprereqs-perl_0.027-1_all.deb module to report on prerequisite versions during automated testing
libdist-zilla-plugin-twitter-perl_0.026-2_all.deb Twitter when you release with Dist::Zilla
libdist-zilla-plugins-cjm-perl_6.000-1_all.deb collection of CJM's plugins for Dist::Zilla
libdist-zilla-role-bootstrap-perl_1.001004-1_all.deb Shared logic for Dist::Zilla-related bootstrap things
Advertisement
Advertisement