libdbd-pg-perl_3.7.4-3_i386.deb


Advertisement

Description

libdbd-pg-perl - Perl DBI driver for the PostgreSQL database server

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libdbd-pg-perl_3.7.4-3_i386.deb
Package name libdbd-pg-perl
Package version 3.7.4
Package release 3
Package architecture i386
Package type deb
Category devel::lang:perl devel::lang:sql devel::library implemented-in::c implemented-in::perl perl protocol::db:psql role::devel-lib works-with::db
Homepage https://metacpan.org/release/DBD-Pg
License -
Maintainer Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>
Download size 204.59 KB
Installed size 541.00 KB
DBD::Pg is a Perl DBI Database Driver module that works with the DBI module to
provide access to PostgreSQL databases. It enables you to control a PostgreSQL
database in a Perl script.

Alternatives

Package Version Architecture Repository
libdbd-pg-perl_3.7.4-3_amd64.deb 3.7.4 amd64 Debian Main
libdbd-pg-perl - - -

Requires

Name Value
libc6 >= 2.4
libdbi-perl >= 1.614
libpq5 >= 8.4~
perl >= 5.28.1-4
perl-dbdabi-94 -
perlapi-5.28.1 -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libdbd-pg-perl_3.7.4-3_i386.deb
Source Package libdbd-pg-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libdbd-pg-perl deb package:
    # sudo apt-get install libdbd-pg-perl

Files

Path
/usr/lib/i386-linux-gnu/perl5/5.28/Bundle/DBD/Pg.pm
/usr/lib/i386-linux-gnu/perl5/5.28/DBD/Pg.pm
/usr/lib/i386-linux-gnu/perl5/5.28/auto/DBD/Pg/Pg.so
/usr/share/doc/libdbd-pg-perl/NEWS.Debian.gz
/usr/share/doc/libdbd-pg-perl/README.dev.gz
/usr/share/doc/libdbd-pg-perl/README.gz
/usr/share/doc/libdbd-pg-perl/TODO
/usr/share/doc/libdbd-pg-perl/changelog.Debian.gz
/usr/share/doc/libdbd-pg-perl/changelog.gz
/usr/share/doc/libdbd-pg-perl/copyright
/usr/share/man/man3/Bundle::DBD::Pg.3pm.gz
/usr/share/man/man3/DBD::Pg.3pm.gz

Changelog

2019-03-08 - gregor herrmann <gregoa@debian.org>
libdbd-pg-perl (3.7.4-3) unstable; urgency=medium
[ Laurent Baillet ]
* fix lintian file-contains-trailing-whitespace warning
[ gregor herrmann ]
* Refresh testdir.patch (offset).
* Add patch from upstream Git to fix test failure with
client_min_messages=FATAL. (Closes: #923905)
2019-02-07 - Christoph Berg <myon@debian.org>
libdbd-pg-perl (3.7.4-2) unstable; urgency=medium
[ gregor herrmann ]
* debian/*: update URLs from {search,www}.cpan.org to MetaCPAN.
[ Xavier Guimard ]
* Email change: Xavier Guimard -> yadd@debian.org
[ Christoph Berg ]
* Update PostgreSQL Maintainers address.
2018-03-09 - Damyan Ivanov <dmn@debian.org>
libdbd-pg-perl (3.7.4-1) unstable; urgency=medium
[ Alex Muntada ]
* Remove inactive pkg-perl members from Uploaders.
[ Damyan Ivanov ]
* declare conformance with Policy 4.1.3 (no changes needed)
[ Salvatore Bonaccorso ]
* Update Vcs-* headers for switch to salsa.debian.org
[ Damyan Ivanov ]
* New upstream version 3.7.4
* update years of upstream copyright
* enable bindnow hardening flags
2017-09-27 - Christoph Berg <myon@debian.org>
libdbd-pg-perl (3.7.0-1) unstable; urgency=medium
* New upstream version.
2017-07-22 - Christoph Berg <myon@debian.org>
libdbd-pg-perl (3.6.2-2) unstable; urgency=medium
* Bump S-V to 4.0.
2017-05-25 - Christoph Berg <myon@debian.org>
libdbd-pg-perl (3.6.2-1) experimental; urgency=medium
[ Salvatore Bonaccorso ]
* debian/control: Use HTTPS transport protocol for Vcs-Git URI
[ gregor herrmann ]
* debian/copyright: change Copyright-Format 1.0 URL to HTTPS.
* debian/upstream/metadata: change GitHub/CPAN URL(s) to HTTPS.
[ Martín Ferrari ]
* Remove myself from Uploaders.
[ gregor herrmann ]
* Remove Jonathan Yu from Uploaders. Thanks for your work!
* Remove Ryan Niebur from Uploaders. Thanks for your work!
[ Christoph Berg ]
* Import upstream version 3.6.2, compatible with PostgreSQL 10.
* Add myself and pkg-postgresql-public to Uploaders.
* Bump Standards-Version.
2015-10-17 - gregor herrmann <gregoa@debian.org>
libdbd-pg-perl (3.5.3-1) unstable; urgency=medium
* Import upstream version 3.5.3
* Update Repository in debian/upstream/metadata.
* Rename autopkgtest configuration file.
2015-06-28 - gregor herrmann <gregoa@debian.org>
libdbd-pg-perl (3.5.1-1) unstable; urgency=medium
* Import upstream version 3.5.1.
* Refresh testdir.patch (offset).
* Update years of upstream and packaging copyright.
* Mark package as autopkgtest-able.
2014-10-08 - gregor herrmann <gregoa@debian.org>
libdbd-pg-perl (3.4.2-1) unstable; urgency=medium
* Imported upstream version 3.4.2
* Declare compliance with Debian Policy 3.9.6.
2014-09-13 - Dominic Hargreaves <dom@earth.li>
libdbd-pg-perl (3.4.1-2) unstable; urgency=high
* Team upload.
* Add Breaks: on older versions of request-tracker4, which
were incompatible with newer versions of libdbd-pg-perl
(see #757879)

See Also

Package Description
libdbd-pgsql_0.9.0-6+b1_i386.deb PostgreSQL database server driver for libdbi
libdbd-sqlite2-perl_0.38-1+b1_i386.deb Perl DBI driver with a self-contained RDBMS (SQLite2 version)
libdbd-sqlite3-perl_1.62-3_i386.deb Perl DBI driver with a self-contained RDBMS
libdbd-sqlite3_0.9.0-6+b1_i386.deb SQLite3 database driver for libdbi
libdbd-sqlite_0.9.0-6+b1_i386.deb SQLite database driver for libdbi
libdbd-sybase-perl_1.14-1+b6_i386.deb Sybase/MS SQL database driver for the DBI module
libdbd-xbase-perl_1.08-1_all.deb Perl module to access xbase files (optionally through DBI)
libdbi-dev_0.9.0-5_i386.deb DB Independent Abstraction Layer for C -- development files
libdbi-doc_0.9.0-5_all.deb DB Independent Abstraction Layer for C -- documentation
libdbi-perl_1.642-1+b1_i386.deb Perl Database Interface (DBI)
libdbi-test-perl_0.001-1_all.deb test suite for the DBI API
libdbi1_0.9.0-5_i386.deb DB Independent Abstraction Layer for C -- shared library
libdbicx-sugar-perl_0.0200-1_all.deb syntax sugar for DBIx::Class
libdbicx-testdatabase-perl_0.05-2_all.deb module for testing a DBIx::Class::Schema
libdbix-abstract-perl_1.040-2_all.deb DBI SQL abstraction
Advertisement
Advertisement