libdbd-mariadb-perl_1.11-3_i386.deb


Advertisement

Description

libdbd-mariadb-perl - Perl5 database interface to the MariaDB/MySQL databases

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libdbd-mariadb-perl_1.11-3_i386.deb
Package name libdbd-mariadb-perl
Package version 1.11
Package release 3
Package architecture i386
Package type deb
Category devel::lang:perl devel::library implemented-in::c implemented-in::perl perl role::devel-lib
Homepage https://metacpan.org/release/DBD-MariaDB
License -
Maintainer Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>
Download size 109.52 KB
Installed size 305.00 KB
DBD::MariaDB is a Perl5 Database Interface driver for the MariaDB/MySQL
databases. In other words: DBD::MariaDB is an interface between the Perl
programming language and the MariaDB/MySQL programming API that comes with
the MariaDB/MySQL relational database management systems. Most functions
provided by this programming API are supported.
DBD::MariaDB is a fork of DBD::mysql (libdbd-mysql-perl) with inprovements in
MariaDB compatibility, Perl Unicode support, and some security related bug
fixes, at the cost of not being 100% backwards compatible.

Alternatives

Package Version Architecture Repository
libdbd-mariadb-perl_1.11-3_amd64.deb 1.11 amd64 Debian Main
libdbd-mariadb-perl - - -

Requires

Name Value
libc6 >= 2.4
libdbi-perl >= 1.642
libmariadb3 >= 3.0.0
libssl1.1 >= 1.1.0
perl >= 5.28.1-3
perl-dbdabi-94 -
perlapi-5.28.1 -
zlib1g >= 1:1.1.4

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libdbd-mariadb-perl_1.11-3_i386.deb
Source Package libdbd-mariadb-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libdbd-mariadb-perl deb package:
    # sudo apt-get install libdbd-mariadb-perl

Files

Path
/usr/lib/i386-linux-gnu/perl5/5.28/DBD/MariaDB.pm
/usr/lib/i386-linux-gnu/perl5/5.28/DBD/MariaDB.pod
/usr/lib/i386-linux-gnu/perl5/5.28/DBD/MariaDB/INSTALL.pod
/usr/lib/i386-linux-gnu/perl5/5.28/auto/DBD/MariaDB/MariaDB.so
/usr/share/doc/libdbd-mariadb-perl/changelog.Debian.gz
/usr/share/doc/libdbd-mariadb-perl/changelog.gz
/usr/share/doc/libdbd-mariadb-perl/copyright
/usr/share/man/man3/DBD::MariaDB.3pm.gz
/usr/share/man/man3/DBD::MariaDB::INSTALL.3pm.gz

Changelog

2019-01-17 - gregor herrmann <gregoa@debian.org>
libdbd-mariadb-perl (1.11-3) unstable; urgency=medium
* Team upload.
* Replace MariaDB 10.3.12 test patch with the one from the upstream pull
request. Thanks to Pali for coming up with a real fix.
2019-01-13 - gregor herrmann <gregoa@debian.org>
libdbd-mariadb-perl (1.11-2) unstable; urgency=medium
* Team upload.
* Add patch to temporarily make a test failure non-fatal which is caused
by a change in MariaDB 10.3.12's output. (Closes: #919071)
2019-01-04 - gregor herrmann <gregoa@debian.org>
libdbd-mariadb-perl (1.11-1) unstable; urgency=medium
* Team upload.
* Import upstream version 1.11.
* Add build dependency on libnet-ssleay-perl.
* Add libnet-ssleay-perl in debian/tests/control as well.
2018-12-25 - gregor herrmann <gregoa@debian.org>
libdbd-mariadb-perl (1.10-2) unstable; urgency=medium
* Team upload.
* Add libssl-dev to Build-Depends and in debian/tests/control to fix a
configure failure.
* Make build dependency on default-libmysqlclient-dev versioned.
Intermediate versions had dependency issues.
* debian/tests/control: add test-name to the tests.
* Declare compliance with Debian Policy 4.3.0.
* Bump debhelper compatibility level to 11.
2018-12-09 - gregor herrmann <gregoa@debian.org>
libdbd-mariadb-perl (1.10-1) unstable; urgency=medium
* Team upload.
* Import upstream version 1.10.
* Drop spelling-error.patch, applied upstream.
* Make (build) dependency on libdbi-perl versioned.
2018-10-12 - gregor herrmann <gregoa@debian.org>
libdbd-mariadb-perl (1.00-2) unstable; urgency=medium
* Team upload.
[ Xavier Guimard ]
* Email change: Xavier Guimard -> yadd@debian.org
[ gregor herrmann ]
* debian/tests/control: mark mysql test as skippable as there is no
mysql in testing.
This mirrors Paul Gever's merge request for libdbd-mysql-perl.
* debian/tests/control: drop "needs-recommends" restriction.
Deprecated, and the package has no Recommends anyway.
* Update years of packaging copyright.
* Declare compliance with Debian Policy 4.2.1.
2018-08-23 - Xavier Guimard <x.guimard@free.fr>
libdbd-mariadb-perl (1.00-1) unstable; urgency=low
* Initial release (Closes: #906883)
# Changes since libdbd-mysql-perl 4.046-2:
[ Xavier Guimard ]
* Join upstream copyright (as described in DBD::MariaDB)
* Add libdevel-checklib-perl in build dependencies
* Remove regression-fix-float_type_conversion.patch included in upstream
* Add spelling-error.patch (reported)
* autopkgtest smoke-setup:
- launch Makefile.PL in smoke-setup to create t/MariaDB.mtest if missing
and add related files in smoke-files
- modify smoke-setup using upstream contribution
[ gregor hermann ]
* autopkgtest smoke-setup:
- set utf8 in db creation to enable more tests

See Also

Package Description
libdbd-mock-perl_1.45-2_all.deb Mock database driver for testing
libdbd-mysql-perl_4.050-2_i386.deb Perl5 database interface to the MariaDB/MySQL database
libdbd-mysql_0.9.0-6+b1_i386.deb MySQL database server driver for libdbi
libdbd-odbc-perl_1.60-1_i386.deb Perl Database Driver implementing ODBC for DBI
libdbd-pg-perl_3.7.4-3_i386.deb Perl DBI driver for the PostgreSQL database server
libdbd-pgsql_0.9.0-6+b1_i386.deb PostgreSQL database server driver for libdbi
libdbd-sqlite2-perl_0.38-1+b1_i386.deb Perl DBI driver with a self-contained RDBMS (SQLite2 version)
libdbd-sqlite3-perl_1.62-3_i386.deb Perl DBI driver with a self-contained RDBMS
libdbd-sqlite3_0.9.0-6+b1_i386.deb SQLite3 database driver for libdbi
libdbd-sqlite_0.9.0-6+b1_i386.deb SQLite database driver for libdbi
libdbd-sybase-perl_1.14-1+b6_i386.deb Sybase/MS SQL database driver for the DBI module
libdbd-xbase-perl_1.08-1_all.deb Perl module to access xbase files (optionally through DBI)
libdbi-dev_0.9.0-5_i386.deb DB Independent Abstraction Layer for C -- development files
libdbi-doc_0.9.0-5_all.deb DB Independent Abstraction Layer for C -- documentation
libdbi-perl_1.642-1+b1_i386.deb Perl Database Interface (DBI)
Advertisement
Advertisement