libcwd-guard-perl_0.05-1_all.deb


Advertisement

Description

libcwd-guard-perl - module for temporarily changing working directory (chdir)

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libcwd-guard-perl_0.05-1_all.deb
Package name libcwd-guard-perl
Package version 0.05
Package release 1
Package architecture all
Package type deb
Category devel::lang:perl devel::library implemented-in::perl perl
Homepage https://metacpan.org/release/Cwd-Guard
License -
Maintainer Debian Perl Group <pkg-perl-maintainers@lists.alioth.debian.org>
Download size 5.83 KB
Installed size 19.00 KB
Cwd::Guard provides changing the current directory (chdir) using a limited
scope. Return to current working directory, if this object destroyed. If
failed to chdir, error messages stored to $Gwd::Guard::Error.

Alternatives

Package Version Architecture Repository
libcwd-guard-perl_0.05-1_all.deb 0.05 all Debian Main
libcwd-guard-perl - - -

Requires

Name Value
perl -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libcwd-guard-perl_0.05-1_all.deb
Source Package libcwd-guard-perl

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libcwd-guard-perl deb package:
    # sudo apt-get install libcwd-guard-perl

Files

Path
/usr/share/doc/libcwd-guard-perl/changelog.Debian.gz
/usr/share/doc/libcwd-guard-perl/changelog.gz
/usr/share/doc/libcwd-guard-perl/copyright
/usr/share/man/man3/Cwd::Guard.3pm.gz
/usr/share/perl5/Cwd/Guard.pm

Changelog

2016-05-22 - Salvatore Bonaccorso <carnil@debian.org>
libcwd-guard-perl (0.05-1) unstable; urgency=medium
* Team upload.
[ Salvatore Bonaccorso ]
* debian/control: Use HTTPS transport protocol for Vcs-Git URI
[ gregor herrmann ]
* debian/copyright: change Copyright-Format 1.0 URL to HTTPS.
[ Salvatore Bonaccorso ]
* Import upstream version 0.05
* Bump Debhelper compat level to 9
* Declare compliance with Debian policy 3.9.8
* Make Build-Depends on libmodule-build-perl unversioned
* Update Build-Depends for perl.
Replace alternative Build-Depends on perl (>= 5.13.10) or
libcpan-meta-perl with only perl.
* Add Build-Depends-Indep on libtest-requires-perl
* Wrap and sort fields in debian/control file
2015-06-18 - gregor herrmann <gregoa@debian.org>
libcwd-guard-perl (0.4-2) unstable; urgency=medium
* Team upload.
[ gregor herrmann ]
* Strip trailing slash from metacpan URLs.
[ Salvatore Bonaccorso ]
* Update Vcs-Browser URL to cgit web frontend
[ gregor herrmann ]
* Add debian/upstream/metadata
* Unconditionally build depend on libmodule-build-perl.
(Closes: #789140)
* Mark package as autopkgtest-able.
* Declare compliance with Debian Policy 3.9.6.
2013-06-13 - Oleg Gashev <oleg@gashev.net>
libcwd-guard-perl (0.4-1) unstable; urgency=low
* New upstream release
2013-05-21 - Oleg Gashev <oleg@gashev.net>
libcwd-guard-perl (0.3-1) unstable; urgency=low
* Initial Release. (Closes: #709235)

See Also

Package Description
libcwidget-dev_0.5.17-11_i386.deb high-level terminal interface library for C++ (development files)
libcwidget-doc_0.5.17-11_all.deb high-level terminal interface library for C++ (documentation)
libcwidget3v5_0.5.17-11_i386.deb high-level terminal interface library for C++ (runtime files)
libcwiid-dev_0.6.00+svn201-4_i386.deb library to interface with the wiimote -- development files
libcwiid1_0.6.00+svn201-4_i386.deb library to interface with the wiimote -- runtime files
libcwnn-dev_1.1.1~a021+cvs20130302-7+b1_i386.deb Header files and static library for cWnn (FreeWnn cserver)
libcwnn0_1.1.1~a021+cvs20130302-7+b1_i386.deb FreeWnn library for cWnn (FreeWnn cserver)
libcxsparse3_5.4.0+dfsg-1_i386.deb concise sparse matrix library
libcxxtools-dev_2.2.1-2_i386.deb library of unrelated but useful C++ classes
libcxxtools9v5_2.2.1-2_i386.deb library of unrelated but useful C++ classes
libcypher-parser-dev_0.6.0-1_i386.deb Development files for libcypher-parser
libcypher-parser-doc_0.6.0-1_all.deb Documentation for libcypher-parser
libcypher-parser8_0.6.0-1_i386.deb Parsing library for the Cypher query language
libcyrus-imap-perl_3.0.8-6_i386.deb Interface to Cyrus imap client imclient library
libczmq-dev_4.2.0-2_i386.deb High-level C binding for ZeroMQ (development files)
Advertisement
Advertisement