libblkid-dev_2.33.1-0.1_i386.deb


Advertisement

Description

libblkid-dev - block device ID library - headers and static libraries

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libblkid-dev_2.33.1-0.1_i386.deb
Package name libblkid-dev
Package version 2.33.1
Package release 0.1
Package architecture i386
Package type deb
Category admin::filesystem devel::lang:c devel::library implemented-in::c libdevel role::devel-lib
Homepage -
License -
Maintainer LaMont Jones <lamont@debian.org>
Download size 240.78 KB
Installed size 796.00 KB
The blkid library allows system programs such as fsck and mount to
quickly and easily find block devices by filesystem UUID or label.
This allows system administrators to avoid specifying filesystems by
hard-coded device names and use a logical naming system instead.
This package contains the development environment for the blkid library.

Alternatives

Package Version Architecture Repository
libblkid-dev_2.33.1-0.1_amd64.deb 2.33.1 amd64 Debian Main
libblkid-dev - - -

Requires

Name Value
libblkid1 = 2.33.1-0.1
libc-dev -
libc6-dev -
uuid-dev -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libblkid-dev_2.33.1-0.1_i386.deb
Source Package util-linux

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libblkid-dev deb package:
    # sudo apt-get install libblkid-dev

Files

Path
/usr/include/blkid/blkid.h
/usr/lib/i386-linux-gnu/libblkid.a
/usr/lib/i386-linux-gnu/libblkid.so
/usr/lib/i386-linux-gnu/pkgconfig/blkid.pc
/usr/share/doc/libblkid-dev/changelog.Debian.gz
/usr/share/doc/libblkid-dev/changelog.gz
/usr/share/doc/libblkid-dev/copyright
/usr/share/man/man3/libblkid.3.gz

Changelog

2019-01-10 - Andreas Henriksson <andreas@fatal.se>
util-linux (2.33.1-0.1) unstable; urgency=medium
* Non-maintainer upload.
* New upstream release.
* Drop all patches, now included in upstream release
2018-12-07 - Andreas Henriksson <andreas@fatal.se>
util-linux (2.33-0.2) unstable; urgency=medium
* Non-maintainer upload.
* Make tests non-fatal on alpha and arm*
* Breaks/Replaces bash-completion < 2.8 (Closes: #913412)
* Enable bindnow hardening
* Add Build-Depends-Package to debian/*.symbols
* Add debian/patches/uuid-service-documentation.patch
* Add debian/patches/fstrim-service-documentation.patch
* Add d/p/agetty-Return-old-behavior-with-empty-logname.patch
2018-11-06 - Andreas Henriksson <andreas@fatal.se>
util-linux (2.33-0.1) experimental; urgency=medium
* Non-maintainer upload.
* New upstream release.
* Ship new choom(1) command in util-linux pkg
* Add debian/patches/fix-agetty-hurd.patch.
Thanks to Samuel Thibault for fixing this upstream.
* Update symbols files with new additions
* Bump shlibs for new symbols
* Add lintian override because su really needs suid bit
* Drop unused lintian overrides
* Ship adjtime_config(5) manpage in util-linux
2018-11-06 - Andreas Henriksson <andreas@fatal.se>
util-linux (2.32.1-0.2) unstable; urgency=medium
* Non-maintainer upload.
[ Niels Thykier ]
* Declare the explicit requirement for (fake)root
[ Hideki Yamane ]
* Add fincore and blkzone command (Closes: #907391)
[ Andreas Henriksson ]
* Drop obsolete Breaks against cloud-utils
* debian/rules: Avoid hardcoding list of packages for bash-completions
* Merge setpriv into util-linux package
[ Stefano Zacchiroli ]
* debian/util-linux.README.Debian: Add information about the fstrim.timer
[ Ondřej Nový ]
* d/copyright: Use https protocol in Format field
* d/changelog: Remove trailing whitespaces
2018-08-12 - Andreas Henriksson <andreas@fatal.se>
util-linux (2.32.1-0.1) unstable; urgency=medium
[ Kapil Hari Paranjape ]
* Mention the su-l pam config keyinit revoke in NEWS (Closes: #905710)
[ Andreas Henriksson ]
* Mention DISPLAY and XAUTHORITY in util-linux.NEWS (Closes: #905409)
* New upstream release.
* Drop fix-hurd.patch from upstream, now part of release
2018-08-03 - Andreas Henriksson <andreas@fatal.se>
util-linux (2.32-0.4) unstable; urgency=medium
* Non-maintainer upload (greetings from DebCamp/DebConf Taiwan).
* ci: Add GitLab CI definition for package build/test runs
* Add NEWS entry for /bin/su takeover
* Bump util-linux Breaks/Replaces against bash-completion (Closes: #905303)
2018-07-28 - Andreas Henriksson <andreas@fatal.se>
util-linux (2.32-0.3) unstable; urgency=medium
* Non-maintainer upload (greetings from DebCamp/DebConf Taiwan).
[ Andreas Henriksson ]
* Revert "Disable pristine-tar"
- needs pristine-tar >= 1.43
* Install su(1) manpage (Closes: #904837)
* Actually install su and su-l pam configs (Closes: #904832)
[ Samuel Thibault ]
* Add patches from upstream that should fix build on hurd
- debian/patches/fix-hurd.patch (Closes: #891812)
2018-07-27 - Andreas Henriksson <andreas@fatal.se>
util-linux (2.32-0.2) unstable; urgency=medium
* Non-maintainer upload (greetings from DebCamp/DebConf Taiwan).
[ Laurent Bigonville ]
* debian/libfdisk1.shlibs: Bump shlibs version as well
[ Andreas Henriksson ]
* Mark rfkill as linux-any in debian/control
* Demote rfkill package to optional again
* Mark util-linux-locales as M-A foreign
- as suggested by Multiarch hinter on tracker.debian.org
* Take over /bin/su from login/src:shadow (See #833256)
- depends on new login package (rather than breaking old) as an
attempt to make apt unpack new u-l before new login to avoid
any gaps where /bin/su is not available.
The Depends/Breaks relationship between u-l and login can
be switched around (in both packages at the same time) once
the transition is fully done (after next stable or lts release).

See Also

Package Description
libblkid1_2.33.1-0.1_i386.deb block device ID library
libblockdev-btrfs-dev_2.20-7+deb10u1_i386.deb BTRFS plugin for libblockdev - development
libblockdev-btrfs2_2.20-7+deb10u1_i386.deb BTRFS plugin for libblockdev
libblockdev-crypto-dev_2.20-7+deb10u1_i386.deb Crypto plugin for libblockdev - development
libblockdev-crypto2_2.20-7+deb10u1_i386.deb Crypto plugin for libblockdev
libblockdev-dev_2.20-7+deb10u1_i386.deb Library for manipulating block devices - development
libblockdev-dm-dev_2.20-7+deb10u1_i386.deb Device Mapper plugin for libblockdev - development
libblockdev-dm2_2.20-7+deb10u1_i386.deb Device Mapper plugin for libblockdev
libblockdev-fs-dev_2.20-7+deb10u1_i386.deb file system plugin for libblockdev - development
libblockdev-fs2_2.20-7+deb10u1_i386.deb file system plugin for libblockdev
libblockdev-kbd-dev_2.20-7+deb10u1_i386.deb kernel block device plugin for libblockdev - development
libblockdev-kbd2_2.20-7+deb10u1_i386.deb kernel block device plugin for libblockdev
libblockdev-loop-dev_2.20-7+deb10u1_i386.deb Loop device plugin for libblockdev - development
libblockdev-loop2_2.20-7+deb10u1_i386.deb Loop device plugin for libblockdev
libblockdev-lvm-dbus-dev_2.20-7+deb10u1_i386.deb LVM DBus plugin for libblockdev - development
Advertisement
Advertisement