libbellesip0_1.6.3-5_i386.deb


Advertisement

Description

libbellesip0 - SIP stack from the Linphone team

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libbellesip0_1.6.3-5_i386.deb
Package name libbellesip0
Package version 1.6.3
Package release 5
Package architecture i386
Package type deb
Category libs role::shared-lib
Homepage https://www.linphone.org
License -
Maintainer Debian VoIP Team <pkg-voip-maintainers@lists.alioth.debian.org>
Download size 473.20 KB
Installed size 3.08 MB
Belle-Sip is a new SIP stack (RFC3261) developed by the Linphone team.
Belle-Sip supports multiple transports at the same time, has a dual
IPv6 and IPv4 stack, is fully asynchronous and implements the
+sip.instance and alias parameters. It also handles network
disconnections better, offers a privacy API and supports rich presence.
SIP/TLS is handled by mbed TLS (by way of bctoolbox), not OpenSSL.

Alternatives

Package Version Architecture Repository
libbellesip0_1.6.3-5_amd64.deb 1.6.3 amd64 Debian Main
libbellesip0 - - -

Requires

Name Value
libantlr3c-3.4-0 -
libantlr3c-antlrdbg-3.4-0 -
libbctoolbox1 >= 0.6.0
libbctoolbox1 << 0.7.0
libc6 >= 2.28
libgcc1 >= 1:4.2
libstdc++6 >= 4.1.1
zlib1g >= 1:1.1.4

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libbellesip0_1.6.3-5_i386.deb
Source Package belle-sip

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libbellesip0 deb package:
    # sudo apt-get install libbellesip0

Files

Path
/usr/lib/i386-linux-gnu/libbellesip.so.0
/usr/share/doc/libbellesip0/changelog.Debian.gz
/usr/share/doc/libbellesip0/copyright
/usr/share/lintian/overrides/libbellesip0

Changelog

2019-04-17 - Bernhard Schmidt <berni@debian.org>
belle-sip (1.6.3-5) unstable; urgency=medium
* Team upload.
* Cherry-Pick upstream fixes for crash with missing nonce at reg.
Thanks to Bernhard √úbelacker and Alf for testing (Closes: #921266)
2018-10-11 - Bernhard Schmidt <berni@debian.org>
belle-sip (1.6.3-4) unstable; urgency=medium
* Team upload.
* Temporarily downgrade new errors in GCC-8 (Closes: #906452)
2018-05-01 - Dr. Tobias Quathamer <toddy@debian.org>
belle-sip (1.6.3-3) unstable; urgency=medium
* Team upload.
* Remove Multi-Arch: same from libbellesip-dev package.
Thanks to Francois Gouget <fgouget@free.fr> (Closes: #897324)
* Use debhelper v11
* Switch Vcs-URLs to salsa.d.o
* Update Standards-Version to 4.1.4, no changes needed
2017-11-09 - Bernhard Schmidt <berni@debian.org>
belle-sip (1.6.3-2) unstable; urgency=medium
* Try to fix FTBFS on various architectures
- Disable parallel building
- Increase JAVA heap space
2017-11-06 - Dr. Tobias Quathamer <toddy@debian.org>
belle-sip (1.6.3-1) unstable; urgency=medium
* Team upload.
[ Felix Lechner ]
* Fix VCS URLs to point to packaging repository (Closes: #787170).
[ Daniel Gnoutcheff ]
* New upstream version 1.5.0
- Updated symbols, fix-spelling-errors.patch
- Now build-depends on libbctoolbox instead of polarssl
* Switch to CMake for builds
* Conservative upper bound for symbols/shlibs to control for API breakage
* Point Vcs-* to git repository
* Update copyright, descriptions
[ Johannes Schauer ]
* New upstream version 1.6.1
* remove version restriction from libbctoolbox-dev
* refreshed patch for 1.6.1
* debian/docs: README => README.md
* refresh debian/libbellesip0.symbols
* add cmake-zlib.patch using "zlib" instead of "z" in pkg-config
Requires.private
* remove debian/libbellesip0.shlibs because of misleading version
restriction
* bump debhelper compatibility level to 10
* debian/rules: Use hardening=+all
* use CMAKE_SKIP_RPATH=ON to avoid rpath in libraries
* run wrap-and-sort -abt
* remove libbellesip-dbg in favour of automatically generated dbgsym package
[ Dr. Tobias Quathamer ]
* Use dh_strip --dbgsym-migration for the obsolete debug package
* Use HTTPS URLs when possible
* Update to Standards-Version 4.1.1
* Minor update to debian/watch
* New upstream version 1.6.3
* Refresh symbols file for new upstream
* Remove upstream signing key, as releases are not signed
2015-05-23 - Tzafrir Cohen <tzafrir@debian.org>
belle-sip (1.4.1-1) unstable; urgency=medium
[ Felix Lechner ]
* New upstream version 1.4.1
* Added Build-Depends: libcunit1-ncurses-dev
* Added build option '--disable-tests' as unit tests require network
* Changed Svn-Browser to GitHub mirror
* Changed Svn-Git: to upstream, bypassing Savannah
* Changed url in watch file to run off GitHub tags
* Removed unnecessary section declaration for libbellesip0 from control
* Added Multi-Arch: same to libbellesip-dbg
* Corrected names and paths in copyright
* Clarified BSD license to say BSD-3-clause
* Fixed spelling errors in binary
* Updated Standards-Version to 3.9.6
[ Tzafrir Cohen ]
* Added Multi-Arch: same to libbellesip-dev as well.
2014-05-16 - Anibal Monsalve Salazar <anibal@debian.org>
belle-sip (1.3.0-1.1) unstable; urgency=medium
* Non-maintainer upload.
* Fix FTBFS mips.
Add increase-antlr-timeout.patch.
Patch by Dejan Latinovic <Dejan.Latinovic@imgtec.com>.
Closes: #748232.
2014-04-02 - Mark Purcell <msp@debian.org>
belle-sip (1.3.0-1) unstable; urgency=medium
[ Felix Lechner ]
* New upstream release
- Fixes "FTBFS: unexpected token" (Closes: #742852)
[ Mark Purcell ]
* Update debian/watch
2014-02-16 - Mark Purcell <msp@debian.org>
belle-sip (1.2.4-1) unstable; urgency=medium
[ Felix Lechner ]
* Team upload.
* Initial release (Closes: #737830)
* Use PolarSSL API v1.3 instead of v1.2 compatibility layer
[ Mark Purcell ]
* Add debian/watch

See Also

Package Description
libbelr-dev_0.1.3-2_i386.deb language recognition library by Belledonne Communications (development headers)
libbelr1_0.1.3-2_i386.deb language recognition library by Belledonne Communications
libben-ocaml-dev_0.8.2+b3_i386.deb OCaml libraries for Debian maintainers (development package)
libben-ocaml_0.8.2+b3_i386.deb OCaml libraries for Debian maintainers (runtime package)
libbenchmark-apps-perl_0.04-1_all.deb simple module to benchmark applications
libbenchmark-dev_1.4.1-3_i386.deb Microbenchmark support library, development files
libbenchmark-ocaml-dev_1.3-2+b1_i386.deb OCaml benchmarking library
libbenchmark-progressbar-perl_0.00001-2_all.deb Perl module that displays progress bar during benchmarking
libbenchmark-timer-perl_0.7112-1_all.deb benchmarking module with statistical confidence
libbenchmark-tools_1.4.1-3_all.deb Microbenchmark support library, tools and documentation
libbenchmark1_1.4.1-3_i386.deb Microbenchmark support library, shared library
libbencode-perl_1.501-1_all.deb Perl module for BitTorrent serialisation format
libberkeleydb-perl_0.55-2_i386.deb use Berkeley DB databases from Perl
libbest-perl_0.15-2_all.deb fallbackable module loader
libbetter-appframework-java-doc_1.9.2-1_all.deb Java Better Swing Application Framework (documentation)
Advertisement
Advertisement