libapache2-mod-dnssd_0.6-3.2_i386.deb


Advertisement

Description

libapache2-mod-dnssd - Zeroconf support for Apache 2 via avahi

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename libapache2-mod-dnssd_0.6-3.2_i386.deb
Package name libapache2-mod-dnssd
Package version 0.6
Package release 3.2
Package architecture i386
Package type deb
Category httpd implemented-in::c protocol::zeroconf role::shared-lib suite::apache
Homepage http://0pointer.de/lennart/projects/mod_dnssd/
License -
Maintainer Regis Boudin <regis@debian.org>
Download size 14.68 KB
Installed size 50.00 KB
mod_dnssd is an Apache HTTPD module which adds Zeroconf support
via DNS-SD using Avahi. This allows Apache to advertise itself and the
websites available to clients compatible with the protocol.

Alternatives

Package Version Architecture Repository
libapache2-mod-dnssd_0.6-3.2_amd64.deb 0.6 amd64 Debian Main
libapache2-mod-dnssd - - -

Requires

Name Value
apache2-api-20120211 -
apache2-bin >= 2.4.16
avahi-daemon >= 0.6.5
libapr1 >= 1.2.7
libavahi-client3 >= 0.6.16
libavahi-common3 >= 0.6.16
libc6 >= 2.4

Download

Type URL
Mirror ftp.br.debian.org
Binary Package libapache2-mod-dnssd_0.6-3.2_i386.deb
Source Package mod-dnssd

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install libapache2-mod-dnssd deb package:
    # sudo apt-get install libapache2-mod-dnssd

Files

Path
/etc/apache2/mods-available/dnssd.conf
/etc/apache2/mods-available/dnssd.load
/usr/lib/apache2/modules/mod_dnssd.so
/usr/share/doc/libapache2-mod-dnssd/README.gz
/usr/share/doc/libapache2-mod-dnssd/changelog.Debian.gz
/usr/share/doc/libapache2-mod-dnssd/copyright

Changelog

2017-11-26 - Jeremy Bicha <jbicha@debian.org>
mod-dnssd (0.6-3.2) unstable; urgency=medium
* Non-maintainer upload.
* Modernize packaging (Closes: #882779)
- Convert to simple dh7 style rules
- Bump debhelper compat to 10
- Bump Standards-Version to 4.1.1
- Build with all hardening flags
- Use section httpd instead of net
- Use copyright format 1.0
* Update port-for-apache2.4.patch with version accepted upstream
2013-05-30 - Arno Töll <arno@debian.org>
mod-dnssd (0.6-3.1) unstable; urgency=low
* Non-maintainer upload (Closes: #666829)
* Add support for Apache 2.4 by using the patch provided by Ondřej Surý.
* Make the module run with the changed Apache 2.4 API
* Rename Apache configuration files to comply with Apache's packaging
policy:
- mod-dnssd.conf -> dnssd.conf
- mod-dnssd.load -> dnssd.load
- Update symlinks when the module was enabled
* Bump debhelper dependency, to make sure its maintscript helper is
supported which aids for the conffile move.
2011-07-26 - Regis Boudin <regis@debian.org>
mod-dnssd (0.6-3) unstable; urgency=low
* Bump Standards-Version to 3.9.2. No other change needed.
* Add dependency on ${misc:Depends}. 
* Add build-arch and build-indep targets.
2009-11-12 - Regis Boudin <regis@debian.org>
mod-dnssd (0.6-2) unstable; urgency=low
* Depend on apache2.2-bin instead of apache2.2-common (Closes: #536212).
* Bump Standards-Version to 3.8.3
* Switch to format 3.0 (quilt)
2009-02-02 - Regis Boudin <regis@debian.org>
mod-dnssd (0.6-1) unstable; urgency=low
* New upstream release (Closes: #513954).
* Bump Standards-Version to 3.8.0
* Reference the Apache 2.0 License file in
/usr/share/common-licenses/Apache-2.0 instead of having the whole text
copied inside the copyright file.
* Update the long description to make lintian happy.
2007-12-06 - Regis Boudin <regis@debian.org>
mod-dnssd (0.5-1) unstable; urgency=low
* New upstream release (Closes: #426379, #368486).
* Acknowledge NMU. Thanks Joey ! (Closes: #391782, #393012).
* Take over maintainership of the package, as agreed with the previous
maintainer, who becomes uploader. Many thanks to Sebastien Estienne for his
work.
* Set the Homepage field in debian/control.
* Bump the Standards-Version to 3.7.3
2006-10-15 - Joey Hess <joeyh@debian.org>
mod-dnssd (0.4-1.1) unstable; urgency=low
* Non-maintainer upload.
[ Simon McVittie ]
* Alter source to compile with Apache 2.2 (closes: #391782, #393012)
2006-04-01 - Sebastien ESTIENNE <sebastien.estienne@gmail.com>
mod-dnssd (0.4-1) unstable; urgency=low
* New upstream release
2006-03-01 - Sebastien ESTIENNE <sebastien.estienne@gmail.com>
mod-dnssd (0.3-2) unstable; urgency=low
* fix prerm and postrm scripts to enable/disable the module
2006-01-31 - Sebastien ESTIENNE <sebastien.estienne@gmail.com>
mod-dnssd (0.3-1) unstable; urgency=low
* Initial release (Closes: #349419)

See Also

Package Description
libapache2-mod-encoding_20040616-6_i386.deb Apache2 module for non-ascii filename interoperability
libapache2-mod-evasive_1.10.1-3_i386.deb evasive module to minimize HTTP DoS or brute force attacks
libapache2-mod-fcgid_2.3.9-4_i386.deb FastCGI interface module for Apache 2
libapache2-mod-form-dev_0~svn146-1_all.deb Apache module to decode data submitted from Web forms (development files)
libapache2-mod-form_0~svn146-1_i386.deb Apache module to decode data submitted from Web forms
libapache2-mod-geoip_1.2.10-1_i386.deb GeoIP support for apache2
libapache2-mod-gnutls_0.9.0-1_i386.deb Apache module for TLS encryption with GnuTLS
libapache2-mod-intercept-form-submit_1.1.0-1_i386.deb Apache module to intercept login form submission and run PAM authentication
libapache2-mod-jk_1.2.46-1_i386.deb Apache 2 connector for the Tomcat Java servlet engine
libapache2-mod-ldap-userdir_1.1.19-2.1_i386.deb Apache module that provides UserDir lookups via LDAP
libapache2-mod-lisp_1.3.1-1.3_i386.deb An Apache2 module that interfaces with Lisp environments
libapache2-mod-log-slow_1.0.8-3_i386.deb Apache module for logging of slow requests handling
libapache2-mod-log-sql-dbi_1.100-16.3+b1_i386.deb Use SQL to store/write your Apache queries logs - DBI interface
libapache2-mod-log-sql-mysql_1.100-16.3+b1_i386.deb Use SQL to store/write your Apache queries logs - MySQL interface
libapache2-mod-log-sql-ssl_1.100-16.3+b1_i386.deb Use SQL to store/write your Apache queries logs - SSL extension
Advertisement
Advertisement