gir1.2-appstream-1.0_0.12.5-1_i386.deb


Advertisement

Description

gir1.2-appstream-1.0 - Library to access AppStream services (introspection data)

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename gir1.2-appstream-1.0_0.12.5-1_i386.deb
Package name gir1.2-appstream-1.0
Package version 0.12.5
Package release 1
Package architecture i386
Package type deb
Category introspection
Homepage https://www.freedesktop.org/wiki/Distributions/AppStream/
License -
Maintainer Matthias Klumpp <mak@debian.org>
Download size 18.03 KB
Installed size 68.00 KB
AppStream is a metadata specification, allowing to write metadata for
software projects in a standardized format. This allows software centers
to display useful information for not installed software, as well as
determining software the user might want to install (e.g. to open an
unknown file type or to make missing firmware available).
This package contains introspection data for the AppStream library.

Alternatives

Package Version Architecture Repository
gir1.2-appstream-1.0_0.12.5-1_amd64.deb 0.12.5 amd64 Debian Main
gir1.2-appstream-1.0 - - -

Requires

Name Value
gir1.2-glib-2.0 >= 1.53
libappstream4 = 0.12.5-1

Replaces

Name Value
gir1.2-appstream << 0.10.1

Download

Type URL
Mirror ftp.br.debian.org
Binary Package gir1.2-appstream-1.0_0.12.5-1_i386.deb
Source Package appstream

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install gir1.2-appstream-1.0 deb package:
    # sudo apt-get install gir1.2-appstream-1.0

Files

Path
/usr/lib/i386-linux-gnu/girepository-1.0/AppStream-1.0.typelib
/usr/share/doc/gir1.2-appstream-1.0/changelog.Debian.gz
/usr/share/doc/gir1.2-appstream-1.0/copyright

Changelog

2019-01-26 - Matthias Klumpp <mak@debian.org>
appstream (0.12.5-1) unstable; urgency=medium
* New upstream version: 0.12.5
* Drop patch: Applied upstream
* Switch to dh compat level 12
* Bump standards version: No changes needed
* Update symbols file
2018-12-22 - Matthias Klumpp <mak@debian.org>
appstream (0.12.4-2) unstable; urgency=medium
* Add no-invalid-warnings.patch: Don't warn about nonexistent issues
on cache refresh.
2018-12-22 - Matthias Klumpp <mak@debian.org>
appstream (0.12.4-1) unstable; urgency=medium
* New upstream version: 0.12.4
2018-10-22 - Matthias Klumpp <mak@debian.org>
appstream (0.12.3-1) unstable; urgency=medium
* New upstream version: 0.12.3
* Drop all patches: Applied upstream
2018-08-19 - Matthias Klumpp <mak@debian.org>
appstream (0.12.2-2) unstable; urgency=medium
* Use HTTPS version of homepage URL
* cache-explicit-variants.patch: Set explicit variant types when
generating the cache, for cases were we may not be able to
infer them automatically (Closes: #906538)
* apt-ignore-exit-status.patch: Don't return failure on metadata issues,
only print a warning and exit normally (Closes: #868018)
2018-08-04 - Matthias Klumpp <mak@debian.org>
appstream (0.12.2-1) unstable; urgency=medium
* New upstream version: 0.12.2
- Fixes autopkgtest by working around Meson/pkg-config bug
(Closes: #901299)
- Closes a few memory leaks (Closes: #868785)
* Bump standards version: No changes needed
2018-06-10 - Matthias Klumpp <mak@debian.org>
appstream (0.12.1-1) unstable; urgency=medium
* New upstream version: 0.12.1
* Drop all patches: Applied upstream
* Add build dependency on gperf
* Update symbols file
* Bump standards version: No changes needed
2018-04-06 - Matthias Klumpp <mak@debian.org>
appstream (0.12.0-3) unstable; urgency=medium
* load-desktop-data.patch: Load desktop file data properly again
2018-04-06 - Matthias Klumpp <mak@debian.org>
appstream (0.12.0-2) unstable; urgency=medium
* Make autopkgtest work again
* Update d/copyright (Closes: #894856)
* icon config: Pull in non-HiDPI config for large icons
if large-icon HiDPI config is installed
2018-04-04 - Matthias Klumpp <mak@debian.org>
appstream (0.12.0-1) unstable; urgency=medium
* New upstream version: 0.12.0
* Drop all patches: Applied upstream
* Update .symbols file
* d/rules: Drop obsolete --parallel flag
* Add APT config snippet packages for an easy way of enabling
icon downloads for different sizes and HiDPI.

See Also

Package Description
gir1.2-appstreamglib-1.0_0.7.14-1_i386.deb GObject introspection data for the libappstream-glib library
gir1.2-aravis-0.6_0.6.0-2_i386.deb GObject introspection data for Aravis
gir1.2-atk-1.0_2.30.0-2_i386.deb ATK accessibility toolkit (GObject introspection)
gir1.2-atril_1.20.3-1_i386.deb GObject introspection data for libatril* (transitional package)
gir1.2-atrildocument-1.5.0_1.20.3-1_i386.deb GObject introspection data for libatrildocument
gir1.2-atrilview-1.5.0_1.20.3-1_i386.deb GObject introspection data for libatrilview
gir1.2-atspi-2.0_2.30.0-7_i386.deb Assistive Technology Service Provider (GObject introspection)
gir1.2-avahi-0.6_0.7-4+b1_i386.deb GObject introspection data for Avahi
gir1.2-ayatanaappindicator-0.1_0.5.3-4_i386.deb Typelib files for libayatana-appindicator1 (GTK-2+ version)
gir1.2-ayatanaappindicator3-0.1_0.5.3-4_i386.deb Typelib files for libayatana-appindicator3-1 (GTK-3+ version)
gir1.2-ayatanaido3-0.4_0.4.4-1_i386.deb Widgets and other objects used for Ayatana Indicators - Typelib file
gir1.2-bamf-3_0.5.4-1_i386.deb GObject introspection data for the Bamf library
gir1.2-blockdev-2.0_2.20-7+deb10u1_i386.deb libblockdev introspection data
gir1.2-brasero-3.1_3.12.2-5_i386.deb CD/DVD burning library for GNOME - GObject introspection data
gir1.2-budgie-1.0_10.5-1_i386.deb GNOME introspection library for budgie-desktop
Advertisement
Advertisement