freeipa-client_4.7.2-3_i386.deb


Advertisement

Description

freeipa-client - FreeIPA centralized identity framework -- client

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename freeipa-client_4.7.2-3_i386.deb
Package name freeipa-client
Package version 4.7.2
Package release 3
Package architecture i386
Package type deb
Category net
Homepage http://www.freeipa.org
License -
Maintainer Debian FreeIPA Team <pkg-freeipa-devel@alioth-lists.debian.net>
Download size 108.93 KB
Installed size 298.00 KB
FreeIPA is an integrated solution to provide centrally managed Identity
(machine, user, virtual machines, groups, authentication credentials), Policy
(configuration settings, access control information) and Audit (events,
logs, analysis thereof).
This is the client package.

Alternatives

Package Version Architecture Repository
freeipa-client_4.7.2-3_amd64.deb 4.7.2 amd64 Debian Main
freeipa-client - - -

Requires

Name Value
bind9utils -
certmonger >= 0.79.5-2
curl -
dnsutils -
freeipa-common = 4.7.2-3
krb5-user -
libbasicobjects0 >= 0.4.0
libc6 >= 2.4
libcollection4 >= 0.4.0
libcom-err2 >= 1.43.9
libini-config5 >= 0.4.0
libk5crypto3 >= 1.9+dfsg~beta1
libkrb5-3 >= 1.13~alpha1+dfsg
libldap-2.4-2 >= 2.4.7
libnspr4 >= 2:4.9-2~
libnss-sss -
libnss3 >= 2:3.13.4-2~
libnss3-tools -
libpam-sss -
libpopt0 >= 1.14
libref-array1 >= 0.4.0
libsasl2-2 >= 2.1.27+dfsg
libsasl2-modules-gssapi-mit -
libssl1.1 >= 1.1.0
libsss-sudo -
libxmlrpc-core-c3 >= 1.16.33-3.1ubuntu5
oddjob-mkhomedir -
python-dnspython -
python-gssapi -
python-ipaclient = 4.7.2-3
python-ldap -
python-sss -
python:any -
sssd >= 1.14.0

Provides

Name Value
freeipa-admintools -

Replaces

Name Value
freeipa-admintools << 4.6.3-2~

Download

Type URL
Mirror ftp.br.debian.org
Binary Package freeipa-client_4.7.2-3_i386.deb
Source Package freeipa

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install freeipa-client deb package:
    # sudo apt-get install freeipa-client

Files

Path
/usr/bin/ipa
/usr/lib/tmpfiles.d/freeipa-client.conf
/usr/sbin/ipa-certupdate
/usr/sbin/ipa-client-automount
/usr/sbin/ipa-client-install
/usr/sbin/ipa-getkeytab
/usr/sbin/ipa-join
/usr/sbin/ipa-rmkeytab
/usr/share/doc/freeipa-client/changelog.Debian.gz
/usr/share/doc/freeipa-client/copyright
/usr/share/ipa/client/freeipa.template
/usr/share/lintian/overrides/freeipa-client
/usr/share/man/man1/ipa-certupdate.1.gz
/usr/share/man/man1/ipa-client-automount.1.gz
/usr/share/man/man1/ipa-client-install.1.gz
/usr/share/man/man1/ipa-getkeytab.1.gz
/usr/share/man/man1/ipa-join.1.gz
/usr/share/man/man1/ipa-rmkeytab.1.gz
/usr/share/man/man1/ipa.1.gz
/usr/share/man/man5/default.conf.5.gz

Changelog

2019-05-06 - Timo Aaltonen <tjaalton@debian.org>
freeipa (4.7.2-3) unstable; urgency=medium
* control: Move python-jwcrypto to python-ipaserver depends.
2019-02-12 - Timo Aaltonen <tjaalton@debian.org>
freeipa (4.7.2-2) unstable; urgency=medium
* tests: Disabled, they are for the server.
* Split server build-deps from the stub.
2019-02-05 - Timo Aaltonen <tjaalton@debian.org>
freeipa (4.7.2-1) unstable; urgency=medium
* New upstream release.
* client.tmpfile: Use /run instead of /var/run.
* control.common: Use same arch set on node-uglify build-dep as for
nodejs. (Closes: #918579)
* fix-fontawesome-path.diff: Refreshed.
* rules: Build only the client until Dogtag works again.
2018-12-06 - Timo Aaltonen <tjaalton@debian.org>
freeipa (4.7.1-3) unstable; urgency=medium
* control: Replace libsvrcore-dev build-dep with 389-ds-base-dev.
* tests: Install only the packages which are used for testing.
* rules: Don't run git on clean. (Closes: #912202)
* control: Nodejs is not available on all archs, build server packages
only where it is.
* control: Add systemd to python-ipalib depends. (Closes: #851158)
2018-10-18 - Timo Aaltonen <tjaalton@debian.org>
freeipa (4.7.1-2) unstable; urgency=medium
* control: Change python-nose to -mock on python-ipatests Depends.
* fix-oddjobd-conf.diff: Fix path to org.freeipa.server.conncheck.
* server.postinst: Fix a typo.
* fix-fontawesome-path.diff: Fix upgrade.
2018-10-09 - Timo Aaltonen <tjaalton@debian.org>
freeipa (4.7.1-1) unstable; urgency=medium
* New upstream release.
- fix-replicainstall.diff dropped, not applicable anymore
- ipa-httpd-pwdreader-force-fqdn.diff dropped, obsolete
- refresh patches
- server: drop ipa-replica-prepare
* dont-migrate-to-authselect.diff We don't have authselect, so just
return true when trying to migrate to it. (LP: #1793994)
* control: Move client dependency on chrony to recommends. (Closes:
#909803)
* control: Build server on any arch again.
* tests: Don't fail the tests, just dump the log if something goes
wrong.
2018-09-28 - Timo Aaltonen <tjaalton@debian.org>
freeipa (4.7.0-1) unstable; urgency=medium
* New upstream release. (LP: #1772447, #1772450)
- fix-version.diff: Dropped, not needed
- hack-duplicate-cert-directive.diff: Dropped, fixed upstream
- ldap-multiarch.diff: Dropped, fixed upstream
- support-pam-mkhomedir.diff: Dropped, fixed upstream
- fix-apache-ssl-setup.diff: Dropped, fixed upstream
- fix-httpd-group.diff: Dropped, fixed upstream
- fix-named-conf-template.diff: Dropped, fixed upstream
- fix-paths.diff: Dropped, fixed upstream
- refresh patches
* tests/server-install: Fix the fake domain, single label domains are not
supported anymore.
* server.postinst: Fix upgrade from earlier version.
* fix-fontawesome-path.diff: Fix the path to font-awesome. (LP:
#1772921)
* fix-krb5kdc-cert-path.diff: Apache can't access KDC certs, move them
to /var/lib/ipa/certs. (LP: #1772447)
* ipa-httpd-pwdreader-force-fqdn.diff: Make sure HOSTNAME is a FQDN. (LP:
#1769485)
* control: Add libjs-scriptaculous to server depends.
* fix-gzip-path.diff: Fix path to gzip. (LP: #1778236)
* control, rules: Switch rhino to nodejs for ui build.
* d/s/local-options: Add some files to ignore.
* control, copyright: Add node-uglify to build-depends, the embedded
copy was removed.
* control, fix-py3-lesscpy-name.diff: Add python3-lesscpy to build-
depends, call the binary with the correct name.
* control: Add python3-pkg-resources to build-depends.
* client.install: Add new template.
* control: Update vcs urls.
* control: Mark priority as optional.
* control, rules: Bump dh to 11.
* control: Add adduser to server depends.
* source/lintian-overrides: Updated.
* control: Bump policy to 4.1.5.
* control: Update maintainer list address.
* control: Build the server only on archs where 389-ds-base is
available.
* control: Bump python-ldap build-dep to 3.1.

See Also

Package Description
freeipa-common_4.7.2-3_all.deb FreeIPA centralized identity framework -- common files
freeipmi-bmc-watchdog_1.6.3-1.1_i386.deb GNU implementation of the IPMI protocol - BMC watchdog
freeipmi-common_1.6.3-1.1_all.deb GNU implementation of the IPMI protocol - common files
freeipmi-ipmidetect_1.6.3-1.1_i386.deb GNU IPMI - IPMI node detection tool
freeipmi-ipmiseld_1.6.3-1.1_i386.deb GNU IPMI - IPMI node detection tool
freeipmi-tools_1.6.3-1.1_i386.deb GNU implementation of the IPMI protocol - tools
freeipmi_1.6.3-1.1_all.deb GNU implementation of the IPMI protocol
freemat-data_4.2+dfsg1-6_all.deb freemat data files
freemat-help_4.2+dfsg1-6_all.deb freemat help files
freemat_4.2+dfsg1-6+b3_i386.deb mathematics framework (mostly matlab compatible)
freemedforms-common-resources_0.9.4-2_all.deb common data for the FreeMedForms project applications
freemedforms-emr-doc-en_0.9.4-2_all.deb FreeMedForms EMR English documentation
freemedforms-emr-doc-fr_0.9.4-2_all.deb FreeMedForms EMR French documentation
freemedforms-emr-resources_0.9.4-2_all.deb data for the FreeMedForms EMR
freemedforms-emr_0.9.4-2_i386.deb electronic medical record manager
Advertisement
Advertisement