fcitx-pinyin_4.2.9.6-5_i386.deb


Advertisement

Description

fcitx-pinyin - Flexible Input Method Framework - classic Pinyin engine

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename fcitx-pinyin_4.2.9.6-5_i386.deb
Package name fcitx-pinyin
Package version 4.2.9.6
Package release 5
Package architecture i386
Package type deb
Category utils
Homepage https://gitlab.com/fcitx/fcitx
License -
Maintainer Debian Input Method Team <debian-input-method@lists.debian.org>
Download size 1.97 MB
Installed size 7.05 MB
Fcitx is a input method framework with extension support, which provides
an interface for entering characters of different scripts in applications
using a variety of mapping systems.
It offers a pleasant and modern experience, with intuitive graphical
configuration tools and customizable skins and mapping tables. It is
highly modularized and extensible, with GTK+ 2/3 and Qt4 IM Modules, support
for UIs based on Fbterm, pure Xlib, GTK+, or KDE, and a developer-friendly
API.
This package provides the classic Pinyin input method, which features
very short responding time by loading the whole dict into RAM during
activation.

Alternatives

Package Version Architecture Repository
fcitx-pinyin_4.2.9.6-5_amd64.deb 4.2.9.6 amd64 Debian Main
fcitx-pinyin - - -

Requires

Name Value
fcitx-bin -
fcitx-data >= 1:4.2.9.6
fcitx-modules -
libc6 >= 2.7

Replaces

Name Value
fcitx << 1:4.2.9.6

Download

Type URL
Mirror ftp.br.debian.org
Binary Package fcitx-pinyin_4.2.9.6-5_i386.deb
Source Package fcitx

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install fcitx-pinyin deb package:
    # sudo apt-get install fcitx-pinyin

Files

Path
/usr/lib/i386-linux-gnu/fcitx/fcitx-pinyin-enhance.so
/usr/lib/i386-linux-gnu/fcitx/fcitx-pinyin.so
/usr/share/doc-base/fcitx-pinyin
/usr/share/doc/fcitx/pinyin.txt
/usr/share/doc/fcitx-pinyin/changelog.Debian.gz
/usr/share/doc/fcitx-pinyin/changelog.gz
/usr/share/doc/fcitx-pinyin/copyright
/usr/share/fcitx/addon/fcitx-pinyin-enhance.conf
/usr/share/fcitx/addon/fcitx-pinyin.conf
/usr/share/fcitx/configdesc/fcitx-pinyin-enhance.desc
/usr/share/fcitx/configdesc/fcitx-pinyin.desc
/usr/share/fcitx/inputmethod/pinyin.conf
/usr/share/fcitx/inputmethod/shuangpin.conf
/usr/share/fcitx/pinyin/pySym.mb
/usr/share/fcitx/pinyin/pybase.mb
/usr/share/fcitx/pinyin/pyphrase.mb
/usr/share/fcitx/pinyin/sp.dat
/usr/share/fcitx/py-enhance/py_stroke.mb
/usr/share/fcitx/py-enhance/py_table.mb
/usr/share/lintian/overrides/fcitx-pinyin

Changelog

2018-08-30 - Boyuan Yang <byang@debian.org>
fcitx (1:4.2.9.6-5) unstable; urgency=medium
* Team upload.
* debian/control:
+ Bump Standards-Version to 4.2.1.
+ Update YunQiang Su's email address and use the @debian.org one.
+ Add new build-dependency libjson-c-dev.
- Remove reference to im-switch, long disappeared.
* debian/patches: Backport patches to fix #907523.
Closes: #907523.
2018-07-23 - Boyuan Yang <073plan@gmail.com>
fcitx (1:4.2.9.6-4) unstable; urgency=medium
* Team upload.
* debian/control:
+ Add Breaks+Replaces against old fcitx-libs-dev for file replacement.
Closes: #903454.
+ Update Vcs fields to indicate that the packaging repo is maintained
under Salsa input-method-team.
+ Bump Standards-Version to 4.1.5. (no changes needed).
2018-06-29 - Boyuan Yang <073plan@gmail.com>
fcitx (1:4.2.9.6-3) unstable; urgency=medium
* Team upload.
* Manual rebuild against opencc 1.0.5.
* Use GitLab repository as upstream homepage to coordinate with
upstream project migration.
* Install fcitx4-config into fcitx-bin instead of fcitx-libs-dev.
This partially solves #806567.
* d/rules: Pass "--as-needed" option to the linker.
2018-04-28 - Boyuan Yang <073plan@gmail.com>
fcitx (1:4.2.9.6-2) unstable; urgency=medium
* Team upload.
* d/control: Use Salsa repository for Vcs fields.
* d/control: Bump Standards-Version to 4.1.4 (no changes needed).
* d/control: Fix Break relationship with fcitx-module-quickphrase-editor,
let fcitx-modules recommends fcitx5-module-quickphrase-editor.
2018-02-24 - Boyuan Yang <073plan@gmail.com>
fcitx (1:4.2.9.6-1) unstable; urgency=medium
* Team upload.
* New upstream release.
* d/patches: Refresh patches; drop patch 0003-0006, applied upstream.
* d/control: Use kdialog instead of kdebase-bin as dependency.
Closes: #885836, Closes: #885850
* d/control: Add X-Ubuntu-Use-Langpack: yes to strip translation
for Ubuntu.
2018-02-05 - Boyuan Yang <073plan@gmail.com>
fcitx (1:4.2.9.5-1) unstable; urgency=medium
* Team upload.
* Upload to unstable.
* Add patch to fix spelling errors. Closes: #826696.
* d/control: Use debian-input-method maillist in maintainer field.
2017-12-31 - Boyuan Yang <073plan@gmail.com>
fcitx (1:4.2.9.5-1~exp1) experimental; urgency=medium
* Team upload.
* New upstream release.
* Drop binary package fcitx-module-quickphrase-editor, fcitx-qt5
will provide it instead.
* Bump Standards-Version to 4.1.3. (no changes needed)
* Make libfcitx-qt0 provides fcitx-libs-qt to make older software
that depend on fcitx-libs-qt happy.
* Update d/copyright file.
* Drop unnecessary patch 0003 in d/patches, applied upstream.
* Add new build dependency uuid-dev.
* Install new module fcitx-ipcportal into fcitx-modules.
* Use secure uri in d/watch file.
* Initiate SONAME Bump for libfcitx-gclient.
* d/patches: Backport several upstream patches from trunk.
2017-10-24 - Aron Xu <aron@debian.org>
fcitx (1:4.2.9.4-3) unstable; urgency=medium
* Restore fcitx-libs for compatibility
2017-10-23 - Aron Xu <aron@debian.org>
fcitx (1:4.2.9.4-2) unstable; urgency=medium
[ Aron Xu ]
* Revert "debian: update control file"
* Update std-ver to 4.1.1
2017-10-03 - Boyuan Yang <073plan@gmail.com>
fcitx (1:4.2.9.4-1) unstable; urgency=medium
* Team upload.
* New upstream release.
* Drop cherry-picked patches 0003-0011.
* Drop transitional package fcitx-libs.
* Drop transitional package fcitx-libs-gclient.
* Drop transitional package fcitx-libs-qt.
* Refresh library symbols.
* Refresh d/copyright information.
* Refresh packaging instructions.
+ Bump Standards-Version to 4.1.0.
+ Bump debhelper compat to v10.
+ Use canonical Vcs URL.
+ Fix various typos.
* Put gir XML file into fcitx-libs-dev package to fix lintian warning.
* Migrate to -dbgsym packages.

See Also

Package Description
fcitx-qw_4.2.9.6-5_i386.deb Flexible Input Method Framework - QuWei engine
fcitx-rime_0.3.2-5_i386.deb Fcitx wrapper for RIME engine
fcitx-sayura_0.1.2-1_i386.deb Fcitx wrapper for Sayura IM engine
fcitx-skk_0.1.4-1_i386.deb Japanese SKK input engine for Fcitx
fcitx-sunpinyin_0.4.2-2_i386.deb fcitx wrapper for Sunpinyin IM engine
fcitx-table-all_4.2.9.6-5_all.deb Flexible Input Method Framework - tables metapackage
fcitx-table-amharic_0.2.4-2_all.deb Flexible Input Method Framework - Amharic table
fcitx-table-arabic_0.2.4-2_all.deb Flexible Input Method Framework - Arabic table
fcitx-table-array30-big_0.3.8-2_all.deb Flexible Input Method Framework - Array30-Big table
fcitx-table-array30_0.3.8-2_all.deb Flexible Input Method Framework - Array30 table
fcitx-table-bingchan_4.2.9.6-5_all.deb Flexible Input Method Framework - Bingchan table
fcitx-table-boshiamy_0.3.8-2_all.deb Flexible Input Method Framework - Boshiamy table
fcitx-table-cangjie-big_0.3.8-2_all.deb Flexible Input Method Framework - Cangjie-Big table
fcitx-table-cangjie3_0.3.8-2_all.deb Flexible Input Method Framework - Cangjie3 table
fcitx-table-cangjie5_0.3.8-2_all.deb Flexible Input Method Framework - Cangjie5 table
Advertisement
Advertisement