cypher-lint_0.6.0-1_i386.deb


Advertisement

Description

cypher-lint - Lint tool for the Cypher query language

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename cypher-lint_0.6.0-1_i386.deb
Package name cypher-lint
Package version 0.6.0
Package release 1
Package architecture i386
Package type deb
Category devel
Homepage https://cleishm.github.io/libcypher-parser/
License -
Maintainer Chris Leishman <chris@leishman.org>
Download size 9.16 KB
Installed size 32.00 KB
Cypher is a graph query language that allows for expressive and efficient
querying of graph data.
This tool provides correctness checking of Cypher language input, and can
be used to output the Abstract Syntax Tree (AST) of the parsed input.

Alternatives

Package Version Architecture Repository
cypher-lint_0.6.0-1_amd64.deb 0.6.0 amd64 Debian Main
cypher-lint - - -

Requires

Name Value
libc6 >= 2.4
libcypher-parser8 >= 0.5.0

Download

Type URL
Mirror ftp.br.debian.org
Binary Package cypher-lint_0.6.0-1_i386.deb
Source Package libcypher-parser

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install cypher-lint deb package:
    # sudo apt-get install cypher-lint

Files

Path
/usr/bin/cypher-lint
/usr/share/doc/cypher-lint/changelog.Debian.gz
/usr/share/doc/cypher-lint/copyright
/usr/share/man/man1/cypher-lint.1.gz

Changelog

2017-09-20 - Chris Leishman <chris@leishman.org>
libcypher-parser (0.6.0-1) unstable; urgency=medium
* New upstream release.
- Adds #define's for compile time version inspection. 
2017-09-07 - Chris Leishman <chris@leishman.org>
libcypher-parser (0.5.4-1) unstable; urgency=medium
* New upstream release.
- Accept parameters using leading `$`
- Support pattern comprehensions
- Support ENDS WITH
- Support map projections
- Various other fixes and updates
2017-05-25 - Chris Leishman <chris@leishman.org>
libcypher-parser (0.5.3-1) unstable; urgency=medium
* New upstream release.
- Fixes an issue with indentation on multiline commands.
2016-09-24 - Chris Leishman <chris@leishman.org>
libcypher-parser (0.5.2-1) unstable; urgency=medium
* New upstream release.
- Fixes an issue tracking line numbers over multiple statements.
2016-08-15 - Chris Leishman <chris@leishman.org>
libcypher-parser (0.5.1-1) unstable; urgency=medium
* New upstream release. 
2016-08-10 - Chris Leishman <chris@leishman.org>
libcypher-parser (0.5.0-1) unstable; urgency=medium
* New upstream release.
2016-07-18 - Chris Leishman <chris@leishman.org>
libcypher-parser (0.4.0-1) unstable; urgency=medium
* New upstream release.
2016-07-01 - Chris Leishman <chris@leishman.org>
libcypher-parser (0.3.4-1) unstable; urgency=high
* New upstream release. Closes: #829209, #829211, #829212
* Renamed -dev package to remove the soname.
* Add support for Multi-Arch.
* Updated debian/copyright.
2016-06-11 - Chris Leishman <chris@leishman.org>
libcypher-parser (0.3.3-1) unstable; urgency=low
* Initial packaging. Closes: #825072

See Also

Package Description
cyphesis-cpp-clients_0.6.2-3+b1_i386.deb WorldForge game server - clients to control the server
cyphesis-cpp-mason_0.6.2-3_all.deb WorldForge game server - game data for Mason
cyphesis-cpp_0.6.2-3+b1_i386.deb WorldForge game server
cyrus-admin_3.0.8-6_all.deb Cyrus mail system - administration tools
cyrus-caldav_3.0.8-6_i386.deb Cyrus mail system - CalDAV and CardDAV support
cyrus-clients_3.0.8-6_i386.deb Cyrus mail system - test clients
cyrus-common_3.0.8-6_i386.deb Cyrus mail system - common files
cyrus-dev_3.0.8-6_i386.deb Cyrus mail system - developer files
cyrus-doc_3.0.8-6_all.deb Cyrus mail system - documentation files
cyrus-imapd_3.0.8-6_i386.deb Cyrus mail system - IMAP support
cyrus-imspd_1.8-5_i386.deb Internet Message Support Protocol daemon
cyrus-murder_3.0.8-6_i386.deb Cyrus mail system - proxies and aggregator
cyrus-nntpd_3.0.8-6_i386.deb Cyrus mail system - NNTP support
cyrus-pop3d_3.0.8-6_i386.deb Cyrus mail system - POP3 support
cyrus-replication_3.0.8-6_i386.deb Cyrus mail system - replication
Advertisement
Advertisement