crossbuild-essential-arm64_12.6_all.deb


Advertisement

Description

crossbuild-essential-arm64 - Informational list of cross-build-essential packages

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename crossbuild-essential-arm64_12.6_all.deb
Package name crossbuild-essential-arm64
Package version 12.6
Package release -
Package architecture all
Package type deb
Category devel
Homepage -
License -
Maintainer Matthias Klose <doko@debian.org>
Download size 6.42 KB
Installed size 15.00 KB
If you do not plan to cross build Debian packages, you don't need
this package.  Starting with sbuild (>= 0.63.0) this package is
required for cross building Debian packages in a chroot.
This package contains an informational list of packages which are
considered essential for cross building Debian packages.  This
package also depends on the packages on that list, to make it easy to
have the cross-build-essential packages installed.
If you have this package installed, you only need to install whatever
a package specifies as its build-time dependencies to cross build the
package.  Conversely, if you are determining what your package needs
to build-depend on, you can always leave out the packages this
package depends on.

Alternatives

Package Version Architecture Repository
crossbuild-essential-arm64_12.6_all.deb 12.6 all Debian Main
crossbuild-essential-arm64 - - -

Requires

Name Value
dpkg-cross -
g++-aarch64-linux-gnu >= 4:8.3
g++:arm64 -
gcc-aarch64-linux-gnu >= 4:8.3
gcc:arm64 -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package crossbuild-essential-arm64_12.6_all.deb
Source Package build-essential

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install crossbuild-essential-arm64 deb package:
    # sudo apt-get install crossbuild-essential-arm64

Files

Path
/usr/share/crossbuild-essential-arm64/list
/usr/share/doc/crossbuild-essential-arm64/changelog.gz
/usr/share/doc/crossbuild-essential-arm64/copyright
/usr/share/doc/crossbuild-essential-arm64/list

Changelog

2019-03-01 - Matthias Klose <doko@debian.org>
build-essential (12.6) unstable; urgency=medium
* Bump dependencies on gcc and g++ to 8.3.
* Regenerate lists of essential packages.
* Bump standards version.
2018-04-26 - Matthias Klose <doko@debian.org>
build-essential (12.5) unstable; urgency=medium
* Bump dependencies on gcc and g++ to 7.3.
* Tighten dependency for cross gcc versions. Closes: #891001.
* Regenerate lists of essential packages.
* Build crossbuild-essential-amd64, crossbuild-essential-i386.
Closes: #883769, #875860.
* Bump standards version.
2017-09-17 - Matthias Klose <doko@debian.org>
build-essential (12.4) unstable; urgency=medium
* Bump dependencies on gcc and g++ to 7.2.
* Build crossbuild-essential-mips, crossbuild-essential-mips64el,
crossbuild-essential-s390x, 
* Bump standards version.
2017-01-25 - Matthias Klose <doko@debian.org>
build-essential (12.3) unstable; urgency=medium
* Bump debhelper and standards versions.
* Bump dependencies on gcc and g++ to 6.3.
2016-02-03 - Matthias Klose <doko@debian.org>
build-essential (12.2) unstable; urgency=medium
* Bump dependencies on gcc and g++ to 5.3.
* For cross packages, drop libc-dev dependency on libc-dev.
2015-08-02 - Matthias Klose <doko@debian.org>
build-essential (12.1) unstable; urgency=medium
* Bump dependencies on gcc and g++ to 5.2.
* Fix generating essential-package-list files for !linux targets (Pino
Toscano). Closes: #772593. 
* Update package lists.
2014-10-24 - Matthias Klose <doko@debian.org>
build-essential (12) experimental; urgency=medium
* Update package lists.
* Add missing architectures to the cross list (Thorsten Glaser).
Closes: #697702.
* Enable cross builds for armel, armhf, arm64, mipsel, powerpc, ppc64el.
Closes: #766551.
2014-08-12 - Matthias Klose <doko@debian.org>
build-essential (11.7) unstable; urgency=medium
* Update Standards-Version to 3.9.5.
* Build-depend on python3:any instead of python3. Closes: #750976.
* Add package lists for new architectures.
* Regenerate the autotools files.
2013-01-08 - Matthias Klose <doko@debian.org>
build-essential (11.6) unstable; urgency=low
* Update Standards-Version to 3.9.4.
* Build-depend on python3 instead of python.
* Update make-esslist.sh to consider ports archives and distros.
Closes: #603386.
* Update essential packages lists.
* Build crossbuild-essential-<arch> packages for architectures
provided in debian/cross-targets (currently all commented out).
Closes: #693220.
2010-03-14 - Matthias Klose <doko@debian.org>
build-essential (11.5) unstable; urgency=low
* Bump dependencies on gcc and g++ to 4.4.3.
* Re-add explicit dependency on gcc. Closes: #536038.
* Update essential packages lists. Closes: #545890.

See Also

Package Description
crossbuild-essential-armel_12.6_all.deb Informational list of cross-build-essential packages
crossbuild-essential-armhf_12.6_all.deb Informational list of cross-build-essential packages
crossbuild-essential-i386_12.6_all.deb Informational list of cross-build-essential packages
crossbuild-essential-mips64el_12.6_all.deb Informational list of cross-build-essential packages
crossbuild-essential-mips_12.6_all.deb Informational list of cross-build-essential packages
crossbuild-essential-mipsel_12.6_all.deb Informational list of cross-build-essential packages
crossbuild-essential-powerpc_12.6_all.deb Informational list of cross-build-essential packages
crossbuild-essential-ppc64el_12.6_all.deb Informational list of cross-build-essential packages
crossbuild-essential-s390x_12.6_all.deb Informational list of cross-build-essential packages
crossfire-client-images_1.70.0-1_all.deb Base crossfire-client images
crossfire-client_1.73.0-1_i386.deb Client for the multiplayer roguelike Crossfire
crossfire-common_1.71.0+dfsg1-2_all.deb Architecture independent common files for Crossfire server
crossfire-doc_1.71.0+dfsg1-2_all.deb Documentation for Crossfire
crossfire-maps-small_1.5.0-3_all.deb Small set of maps for crossfire
crossfire-maps_1.71.0-1_all.deb Standard set of maps for crossfire
Advertisement
Advertisement