br2684ctl_2.5.1-2_i386.deb


Advertisement

Description

br2684ctl - Utility for configuring RFC 2684 ATM/Ethernet bridging

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename br2684ctl_2.5.1-2_i386.deb
Package name br2684ctl
Package version 2.5.1
Package release 2
Package architecture i386
Package type deb
Category admin::configuring admin::hardware admin::kernel devel::lang:c devel::library hardware::modem hardware::modem:dsl hardware::usb implemented-in::c interface::commandline net protocol::atm protocol::ethernet role::devel-lib role::program scope::utility use::configuring use::driver
Homepage -
License -
Maintainer Debian QA Group <packages@qa.debian.org>
Download size 7.10 KB
Installed size 25.00 KB
ATM bridging is a way to extend Ethernet over an ATM network and is
mainly used for DSL connections. This package contains the user space
utility needed to configure the kernel driver.
This package is needed if you own an USB DSL modem and your connection
uses one of these protocols: RFC 1483 bridged (RFC 2684 bridged),
RFC 1483 bridged (RFC 2684 routed), PPP over Ethernet (PPPoE).

Alternatives

Package Version Architecture Repository
br2684ctl_2.5.1-2_amd64.deb 2.5.1 amd64 Debian Main
br2684ctl - - -

Requires

Name Value
libatm1 = 1:2.5.1-2
libc6 >= 2.4

Download

Type URL
Mirror ftp.br.debian.org
Binary Package br2684ctl_2.5.1-2_i386.deb
Source Package linux-atm

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install br2684ctl deb package:
    # sudo apt-get install br2684ctl

Files

Path
/usr/sbin/br2684ctl
/usr/share/doc/br2684ctl
/usr/share/man/man8/br2684ctl.8.gz

Changelog

2016-12-10 - Andreas Beckmann <anbe@debian.org>
linux-atm (1:2.5.1-2) unstable; urgency=medium
* QA upload.
* Add Build-Depends: libfl-dev.  (Closes: #846437)
* Clean up maintainer scripts.
2016-06-25 - Andreas Henriksson <andreas@fatal.se>
linux-atm (1:2.5.1-1.6) unstable; urgency=medium
* Non-maintainer upload.
* Add atm.service masking the atm init script (Closes: #796628)
* Build-depend on dh-systemd and use dh_systemd_{enable,start}
in debian/rules for the above.
* Source LSB init function in atm init script
- this it possible for systemd LSB hook to properly redirect
direct invocations of the init script to systemctl.
* Add an explicit Depends on lsb-base because of the above.
* Drop build-dependency on initscripts package. (Closes: #828003)
- the original intention was likely to have this as a dependency
rather than build-dependency, but either way should no longer
be needed so just drop it.
* Orphan the package (Closes: #813775)
- there has been no maintainer upload in over a decade and
p2-mate confirmed he no longer has atm hardware and/or interest.
2012-09-22 - Salvatore Bonaccorso <carnil@debian.org>
linux-atm (1:2.5.1-1.5) unstable; urgency=low
* Non-maintainer upload.
* Correct directory in libatm1-dev.postinst.
Correct the directory checked for the directory symlink migration to be
/usr/share/doc/libatm1-dev for the libatm1-dev binary package. It
wrongly refered to /usr/share/doc/atm-tools. (Closes: #687857)
2012-07-03 - Luk Claes <luk@debian.org>
linux-atm (1:2.5.1-1.4) unstable; urgency=low
* Non-maintainer upload.
* Make build targets executable in parallel (Closes: #674611).
2011-10-30 - Marco d'Itri <md@linux.it>
linux-atm (1:2.5.1-1.3) unstable; urgency=low
* Non-maintainer upload.
* Package converted to multiarch.
* Support sendsigs.omit.d/ in /run and depend on initscripts
>= 2.88dsf-13.3. (Closes: #633029)
* Install the changelogs only in libatm1.
* Removed the K links of the atmarpd initscript, there is no point in
stopping the daemon.
2010-01-02 - Marco d'Itri <md@linux.it>
linux-atm (1:2.5.1-1.2) unstable; urgency=low
* Non-maintainer upload.
* Also Build-Depend on autoconf, automake, libtool. (Closes: #563306)
* Prevent sendsigs from killing atmarpd. (Closes: #62144)
2009-12-24 - Marco d'Itri <md@linux.it>
linux-atm (1:2.5.1-1.1) unstable; urgency=low
* Non-maintainer upload.
* New upstream release. (Closes: #463401)
* Removed the atm-dev dummy package. (Closes: #321826)
* Fixed typos in some man pages. (Closes: #325072)
* Autoreconf on build. (Closes: #535736, #549144)
* Do not restart the init script on upgrades. (Closes: #303069)
* Build with -fno-strict-aliasing just to be sure.
* Added a .symbols file for libatm1.
* Cleaned up debian/rules and updated to modern best practices.
* Slightly cleaned up the init script.
* Upgraded debhelper level to 5.
* Merged back br2684ctl from the standalone source package.
* Added an epoch to be able to replace the standalone br2684ctl package
which has version 20040226-1.
2008-03-31 - Petter Reinholdtsen <pere@debian.org>
linux-atm (2.4.1-17.2) unstable; urgency=low
* Non-maintainer upload to fix RC bug.
* Add LSB dependency header to init.d scripts (Closes: #468459).
2007-07-19 - Pierre Habouzit <madcoder@debian.org>
linux-atm (2.4.1-17.1) unstable; urgency=low
* Non-maintainer upload.
* Add patches/20_missing_includes.dpatch to add missing #include
<linux/types.h> needed with last linux-libc-dev (Closes: #428943).
2005-03-17 - Peter De Schrijver (p2) <p2@mind.be>
linux-atm (2.4.1-17) unstable; urgency=low
* Fix build problem with gcc 4.0 (Closes: )

See Also

Package Description
braa_0.82-4_i386.deb Mass SNMP scanner
brag_1.4.1-2.1_all.deb Downloads and assembles multipart Usenet binaries
braillegraph_0.3-1_all.deb simple histogram tool producing text dot-matrix graphs
brailleutils_1.2.3-4_all.deb command-line interface for the brailleutils library
brainparty-data_0.61+dfsg-5_all.deb 36 puzzle games for all the family -- game data
brainparty_0.61+dfsg-5_i386.deb 36 puzzle games for all the family
brandy_1.20.1-1+b1_i386.deb BBC BASIC V interpreter
brasero-cdrkit_3.12.2-5_i386.deb cdrkit extensions for the Brasero burning application
brasero-common_3.12.2-5_all.deb Common files for the Brasero CD burning application and library
brasero_3.12.2-5_i386.deb CD/DVD burning application for GNOME
brazilian-conjugate_3.0~beta4-22_all.deb Brazilian Portuguese verb conjugator
breathe-doc_4.11.1-1_all.deb Sphinx autodox support for languages with doxygen support (documentation)
brebis_0.10-1_all.deb fully automated backup checker
breeze-cursor-theme_5.14.5-1_all.deb Default Plasma cursor theme
breeze-dev_5.14.5-1_i386.deb Default Plasma theme (development files)
Advertisement
Advertisement