adonthell_0.3.8-1_i386.deb


Advertisement

Description

adonthell - 2D graphical roleplaying game

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main i386
Package filename adonthell_0.3.8-1_i386.deb
Package name adonthell
Package version 0.3.8
Package release 1
Package architecture i386
Package type deb
Category game::rpg games hardware::input:keyboard interface::graphical interface::x11 role::program uitoolkit::sdl use::gameplaying x11::application
Homepage http://adonthell.nongnu.org/index.shtml
License -
Maintainer Debian Games Team <pkg-games-devel@lists.alioth.debian.org>
Download size 293.77 KB
Installed size 1.30 MB
A 2D graphical RPG game inspired by good old console RPGs like the
ones on the SNES.
This package contains the Adonthell engine. You'll also need a game
to be able to play. For this release, the official game is Waste's
Edge, found in the package adonthell-data.

Alternatives

Package Version Architecture Repository
adonthell_0.3.8-1_amd64.deb 0.3.8 amd64 Debian Main
adonthell - - -

Requires

Name Value
libc6 >= 2.4
libfreetype6 >= 2.2.1
libgcc1 >= 1:3.0
libogg0 >= 1.0rc3
libpython3.7 >= 3.7.0
libsdl2-2.0-0 >= 2.0.8
libsdl2-mixer-2.0-0 >= 2.0.2
libsdl2-ttf-2.0-0 >= 2.0.14
libstdc++6 >= 5.2
libvorbis0a >= 1.1.2
python3:any -
zlib1g >= 1:1.1.4

Download

Type URL
Mirror ftp.br.debian.org
Binary Package adonthell_0.3.8-1_i386.deb
Source Package adonthell

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install adonthell deb package:
    # sudo apt-get install adonthell

Files

Path
/usr/games/adonthell
/usr/share/doc/adonthell/AUTHORS
/usr/share/doc/adonthell/NEWS.gz
/usr/share/doc/adonthell/README.gz
/usr/share/doc/adonthell/changelog.Debian.gz
/usr/share/doc/adonthell/changelog.gz
/usr/share/doc/adonthell/copyright
/usr/share/games/adonthell/modules/adonthell.py
/usr/share/games/adonthell/modules/dialogue.py
/usr/share/man/man6/adonthell.6.gz
/usr/share/python3/runtime.d/adonthell.rtupdate

Changelog

2019-01-12 - Markus Koschany <apo@debian.org>
adonthell (0.3.8-1) unstable; urgency=medium
* Team upload.
* New upstream version 0.3.8.
* Declare compliance with Debian Policy 4.3.0.
* Use canonical VCS URI.
2018-04-25 - Markus Koschany <apo@debian.org>
adonthell (0.3.7-1) unstable; urgency=medium
* Team upload.
* New upstream version 0.3.7.
* Switch to compat level 11.
* Declare compliance with Debian Policy 4.1.4.
2016-09-27 - Markus Koschany <apo@debian.org>
adonthell (0.3.6-1) unstable; urgency=medium
* Team upload.
* New upstream release.
* Switch to compat level 10.
* Tighten versioned recommendation on adonthell-data.
2016-07-12 - Markus Koschany <apo@debian.org>
adonthell (0.3.6~beta1-1) unstable; urgency=medium
* Team upload.
* Moved the package to Git.
* debian/control:
- Remove dpkg-dev and versioned constraints from Build-Depends.
- Remove libaa1-dev from Build-Depends.
- Switch from SDL1 to SDL2.
- Switch from Python 2 to Python 3.
- Remove obsolete Breaks and change Recommends to
adonthell-data (>= 0.3.6~beta1)
* Remove README.debian and README.source.
* Simplify debian/rules for new release.
* Drop all patches. Fixed upstream.
* Use --disable-pyc configure option.
* Update docs file. FULLSCREEN.howto is no longer available.
* Remove obsolete dirs file.
* debian/watch: Use version=4.
* Switch to copyright format 1.0.
2016-04-14 - Markus Koschany <apo@debian.org>
adonthell (0.3.5-11) unstable; urgency=medium
* Team upload.
* Add disable-swig.patch and stop rebuilding adonthell.py from source due to
incompatible changes in Swig >= 3 that would cause runtime errors on
startup and make the game unusable. See README.source for more information
and work in progress.
* Add typemap-bool.patch but disable it by default. (See README.source)
* Add format-security.patch to fix FTBFS due to use of format-security flag.
* Build-Depend on dh-python and dh-autoreconf.
* Build with parallel and autoreconf.
2016-04-11 - Markus Koschany <apo@debian.org>
adonthell (0.3.5-10) unstable; urgency=medium
* Team upload.
[ Evgeni Golov ]
* Correct Vcs-* URLs to point to anonscm.debian.org.
[ Moritz Muehlenhoff ]
* Remove myself from uploaders.
[ Markus Koschany ]
* wrap-and-sort -sa.
* Declare compliance with Debian Policy 3.9.8.
* Use compat level 9 and require debhelper >= 9.
* Vcs-Browser: Use https.
* Fix Lintian warning copyright-refers-to-symlink-license.
* Try to build adonthell on all architectures again. Set architecture field
to any. (Closes: #727144)
* debian/rules: Remove empty directories.
* Remove lintian-overrides file.
2013-05-29 - Barry deFreese <bdefreese@debian.org>
adonthell (0.3.5-9) unstable; urgency=low
* Remove extra flag from --with python2. (Closes: #710317).
2013-05-20 - Barry deFreese <bdefreese@debian.org>
adonthell (0.3.5-8) unstable; urgency=low
* Acknowledge NMU.
* Clean up packaging.
- Change debian/rules to dh7 style.
- Bump debhelper and compat to 7.
- Replace Conflicts with Breaks in control.
- Add hardening flags.
- Update Homepage to new address.
- Remove links against libdl and libutil since they aren't used.
* Bump Standards Version to 3.9.4.
2011-10-02 - Luca Falavigna <dktrkranz@debian.org>
adonthell (0.3.5-7.1) unstable; urgency=medium
* Non-maintainer upload.
* debian/patches/12_no_sparc_bytecompile.patch:
- Do not bytecompile Python files during build on sparc, workaround
to let adonthell compile again. Generated files were not installed
in the package, and byte-compilation is performed at a later stage
by python-support anyway (Closes: #639450).

See Also

Package Description
adplay_1.7-4_i386.deb console-based OPL2 audio player
adplug-utils_2.2.1+dfsg3-1_i386.deb free AdLib sound library (utils)
adql-java-doc_1.4-1_all.deb Parse, manipulate and translate ADQL queries (API doc)
adql-java_1.4-1_all.deb Parse, manipulate and translate ADQL queries with Java
adun-core_0.81-13_i386.deb Molecular Simulator
adun.app_0.81-13_i386.deb Molecular Simulator for GNUstep (GUI)
adv-17v35x-dkms_5.0.3.0-2_all.deb dkms driver sources for Advantech PCI/PCIe ACOM Series adapters
advancecomp_2.1-2_i386.deb collection of recompression utilities
advi-examples_1.10.2-4_all.deb example presentations for Active-DVI (advi)
advi_1.10.2-4_i386.deb active DVI previewer and presenter
adwaita-icon-theme_3.30.1-1_all.deb default icon theme of GNOME
adwaita-qt_1.0-2_i386.deb Qt 5 port of GNOME’s Adwaita theme
aegean_0.16.0+dfsg-1_i386.deb integrated genome analysis toolkit
aegisub-l10n_3.2.2+dfsg-4_all.deb aegisub language packages
aegisub_3.2.2+dfsg-4_i386.deb advanced subtitle editor
Advertisement
Advertisement