uim-el_1.8.8-4_amd64.deb


Advertisement

Description

uim-el - Universal Input Method - Emacs front end

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main amd64
Package filename uim-el_1.8.8-4_amd64.deb
Package name uim-el
Package version 1.8.8
Package release 4
Package architecture amd64
Package type deb
Category accessibility::input implemented-in::c implemented-in::lisp lisp role::plugin suite::emacs
Homepage https://github.com/uim/uim/wiki
License -
Maintainer HIGUCHI Daisuke (VDR dai) <dai@debian.org>
Download size 83.02 KB
Installed size 275.00 KB
Uim is an input method module library which supports various scripts and can
act as a front end for a range of input methods, including Anthy, Canna,
or SKK (for Japanese), Pinyin (for Chinese), Byeoru (for Korean), and
M17n (for many other languages). Most of its functions are implemented in
Scheme, so it's very simple and flexible.
This package contains an Emacs front end for uim.

Alternatives

Package Version Architecture Repository
uim-el_1.8.8-4_i386.deb 1.8.8 i386 Debian Main
uim-el - - -

Requires

Name Value
emacs24 -
emacsen -
libc6 >= 2.15
libuim8 >= 1:1.7.0
uim >= 1:1.8.8-4
uim-data >= 1:1.8.8-4
xemacs21-mule -
xemacs21-mule-canna-wnn -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package uim-el_1.8.8-4_amd64.deb
Source Package uim

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install uim-el deb package:
    # sudo apt-get install uim-el

Files

Path
/etc/emacs/site-start.d/50uim-el.el
/usr/bin/uim-el-agent
/usr/bin/uim-el-helper-agent
/usr/lib/emacsen-common/packages/compat/uim-el
/usr/lib/emacsen-common/packages/install/uim-el
/usr/lib/emacsen-common/packages/remove/uim-el
/usr/share/doc/uim-el/NEWS.Debian.gz
/usr/share/doc/uim-el/README.gz
/usr/share/doc/uim-el/README.ja.gz
/usr/share/doc/uim-el/changelog.Debian.gz
/usr/share/doc/uim-el/changelog.gz
/usr/share/doc/uim-el/copyright
/usr/share/emacs/site-lisp/uim-el/uim-candidate.el
/usr/share/emacs/site-lisp/uim-el/uim-debug.el
/usr/share/emacs/site-lisp/uim-el/uim-helper.el
/usr/share/emacs/site-lisp/uim-el/uim-key.el
/usr/share/emacs/site-lisp/uim-el/uim-keymap.el
/usr/share/emacs/site-lisp/uim-el/uim-leim.el
/usr/share/emacs/site-lisp/uim-el/uim-preedit.el
/usr/share/emacs/site-lisp/uim-el/uim-util.el
/usr/share/emacs/site-lisp/uim-el/uim-var.el
/usr/share/emacs/site-lisp/uim-el/uim-version.el
/usr/share/emacs/site-lisp/uim-el/uim.el
/usr/share/lintian/overrides/uim-el

Changelog

2019-03-28 - HIGUCHI Daisuke (VDR dai) <dai@debian.org>
uim (1:1.8.8-4) unstable; urgency=medium
[ YOSHINO Yoshihito ]
* Non-maintainer upload.
* d/{uim.{postinst,prerm},NEWS}: Do not auto-register/unregister plugins of
the following input methods:
byeoru, ipa-x-sampa, latin, look, m17nlib, pinyin, viqr
When upgrading from stretch this behaved badly and they took precedence
over other popular plugins many people use.
* d/{control,rules,uim-*.{postinst,prerm}}: Resurrect packages
uim-{byeoru,ipa-x-sampa,latin,look,m17nlib,pinyin,viqr} for those plugins.
All of them exist in stretch and should upgrade normally.
Dear testing/sid users,
If you are using some of the input methods above, you have to manually
install the respective package(s). Sorry for any inconvenience.
* d/{uim.preinst,control}: Unregister those plugins on upgrade from
testing/sid. Make uim Pre-Depends: uim-data accordingly.
2018-08-03 - HIGUCHI Daisuke (VDR dai) <dai@debian.org>
uim (1:1.8.8-3) unstable; urgency=medium
[ HIGUCHI Daisuke (VDR dai) ]
* d/control: set Breaks+Replaces: uim-qt5 to uim-qt5-immodule
(Closes: #905186).
2018-05-13 - HIGUCHI Daisuke (VDR dai) <dai@debian.org>
uim (1:1.8.8-2) unstable; urgency=medium
[ HIGUCHI Daisuke (VDR dai) ]
* d/t/: do not use Makefile.
2018-05-12 - HIGUCHI Daisuke (VDR dai) <dai@debian.org>
uim (1:1.8.8-1) unstable; urgency=medium
[ HIGUCHI Daisuke (VDR dai) ]
* New upstream release.
* d/control: tighten build-dependency libgcroots-dev.
* d/p/support_anthy-0.3.patch: refresh patch.
* d/p/fix_spelling_error_sigscheme.patch: removed, imported upstream.
* d/p/uim_can_work_with_libgcroot_0.2.2.patch: removed, imported upstream.
* d/rules, d/uim-data.docs: use RELNOTE as upstream changelog.
* support autopkgtest.
* bump up Standards-Version 4.1.4.
2018-03-03 - HIGUCHI Daisuke (VDR dai) <dai@debian.org>
uim (1:1.8.6+gh20180301.c79432c-1) unstable; urgency=medium
[ HIGUCHI Daisuke (VDR dai) ]
* New upstream git checkout.
* d/p/qt5-disable-debug-flag.patch: removed, imported upstream.
* d/p/qt5-immodule-qmake-conf.patch: removed, not-needed.
2018-02-11 - HIGUCHI Daisuke (VDR dai) <dai@debian.org>
uim (1:1.8.6+gh20180114.64e3173-2) unstable; urgency=medium
[ HIGUCHI Daisuke (VDR dai) ]
* eliminate lintian warning: spelling-error-in-patch-description
* uim-data and uim-plugins breaks/replaces old uim-anthy (Closes: #890068).
2018-01-24 - HIGUCHI Daisuke (VDR dai) <dai@debian.org>
uim (1:1.8.6+gh20180114.64e3173-1) unstable; urgency=medium
[ HIGUCHI Daisuke (VDR dai) ]
* New upstream git checkout.
* d/p/pass_cppflags_to_cmake_cxx_flags.patch: removed, imported upstream.
* uim-anthy pre-depends uim-data (Closes: #877918)
thanks to Andreas Beckmann <anbe@debian.org>.
* eliminate lintian warning: insecure-copyright-format-uri
2018-01-14 - HIGUCHI Daisuke (VDR dai) <dai@debian.org>
uim (1:1.8.6+gh20180111.cbd2c5e-1) unstable; urgency=medium
[ HIGUCHI Daisuke (VDR dai) ]
* New upstream git checkout.
* Move Vcs-* to salsa.debian.org
2018-01-07 - HIGUCHI Daisuke (VDR dai) <dai@debian.org>
uim (1:1.8.6+gh20180106.ec697da-1) unstable; urgency=medium
[ HIGUCHI Daisuke (VDR dai) ]
* New upstream git checkout.
- gtk3: support Wayland backend (Closes: #810739)
* d/p/do_not_use_run-singletest_sh.patch: removed, imported upstream.
* d/p/panel_applet_inprocess.patch: removed, imported upstream.
* d/p/qt5-delayed-candwin.patch: removed, imported upstream.
* d/p/qt5-do-not-use-private-qt_plugin_prf.patch: removed, imported upstream.
* d/p/qt5-fix-candwin-unexpected-behavior.patch: removed, imported upstream.
* d/p/qt5-qt4-fix-toolbar-icon.patch: removed, imported upstream.
* d/p/fix-lib-deps.patch: removed, imported upstream.
* Refresh patches.
* d/README.source: remove dpatch entry and add origin of this package source.
* upgrade debhelper to 11.
* bump up Standards-Version 4.1.3.

See Also

Package Description
uim-fep_1.8.8-4_amd64.deb Universal Input Method - front end processor
uim-gtk2.0-immodule_1.8.8-4_amd64.deb Universal Input Method - GTK+2.x IM-module
uim-gtk2.0_1.8.8-4_amd64.deb Universal Input Method - GTK+2.x front end
uim-gtk3-immodule_1.8.8-4_amd64.deb Universal Input Method - GTK+3.x IM module
uim-gtk3_1.8.8-4_amd64.deb Universal Input Method - GTK+3.x front end
uim-ipa-x-sampa_1.8.8-4_all.deb Universal Input Method - X-SAMPA IPA input support metapackage
uim-latin_1.8.8-4_all.deb Universal Input Method - Latin script input support metapackage
uim-look_1.8.8-4_all.deb Universal Input Method - Dictionary-based completion input support metapackage
uim-m17nlib_1.8.8-4_all.deb Universal Input Method - m17nlib plugin metapackage
uim-mozc_2.23.2815.102+dfsg-4_amd64.deb Mozc engine for uim - Client of the Mozc input method
uim-pinyin_1.8.8-4_all.deb Universal Input Method - pinyin input support metapackage
uim-plugins_1.8.8-4_amd64.deb Universal Input Method - plugin files
uim-qt5-immodule_1.8.8-4_amd64.deb Universal Input Method - Qt 5.x IM module
uim-qt5_1.8.8-4_amd64.deb Universal Input Method - Qt 5.x front end
uim-skk_1.8.8-4_all.deb Universal Input Method - SKK support metapackage
Advertisement
Advertisement