sysvbanner_1.0-16_amd64.deb


Advertisement

Description

sysvbanner - System-V banner clone

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main amd64
Package filename sysvbanner_1.0-16_amd64.deb
Package name sysvbanner
Package version 1.0
Package release 16
Package architecture amd64
Package type deb
Category game::toys misc network::service role::program use::viewing works-with::text
Homepage -
License -
Maintainer Debian QA Group <packages@qa.debian.org>
Download size 6.82 KB
Installed size 32.00 KB
Displays, horizontally, a 'banner' text in the same way as the System V
banner does.
This package provides the banner and sysvbanner commands (the same function).

Alternatives

Package Version Architecture Repository
sysvbanner_1.0-16_i386.deb 1.0 i386 Debian Main
sysvbanner - - -

Requires

Name Value
libc6 >= 2.2.5

Download

Type URL
Mirror ftp.br.debian.org
Binary Package sysvbanner_1.0-16_amd64.deb
Source Package sysvbanner

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install sysvbanner deb package:
    # sudo apt-get install sysvbanner

Files

Path
/usr/bin/banner
/usr/bin/sysvbanner
/usr/share/doc/sysvbanner/changelog.Debian.gz
/usr/share/doc/sysvbanner/copyright
/usr/share/man/man1/banner.1.gz
/usr/share/man/man1/sysvbanner.1.gz

Changelog

2017-09-21 - Joao Eriberto Mota Filho <eriberto@debian.org>
sysvbanner (1:1.0-16) unstable; urgency=medium
* QA upload.
* Set Debian QA Group as maintainer. (see #856302)
* Since 1.0-13 revision, the package was converted to native. However, it is
not a native package. I found #44247, that confirms this situation. Now, I
am reverting to a non-native package. Consequently:
- Using 'epoch 1:' to get 1.0-16 revision.
- Using original upstream tarball, provided by 1.0-1 revision.
- Moved the manpage, previously provided by a patch, from upstream place
to debian/.
- Created patch 10_fix-banner.patch to include string.h and fix a typo.
- Dropped all unneeded changes in upstream source code.
* Migrations:
- debian/copyright to 1.0 format.
- DebSrc from 1.0 native to 3.0 quilt.
- DH level to 10.
* debian/control:
- Bumped Standards-Version to 4.1.0.
- Improved the description.
- Removed the VCS fields because the old maintainer repository no longer
exists.
* debian/install: added to install the binary.
* debian/links: created to provide the sysvbanner command, pointing to
banner. (LP: #322200)
* debian/lintian-overrides: removed because it is no longer needed.
* debian/manpages: added to install the manpage.
* debian/patches/20_add-GCC-hardening.patch: added to provide CPPFLAGS.
* debian/README.source: created to tell about VCS fields.
* debian/rules:
- Added DEB_BUILD_MAINT_OPTIONS variable to improve GCC hardening.
- Created target override_dh_strip because this package does not provide
any symbol inside -dbgsym package.
* debian/watch: added a fake site to explain about the current status of the
original upstream homepage.
2009-05-07 - Ryan Niebur <ryanryan52@gmail.com>
sysvbanner (1.0.15) unstable; urgency=low
* fix Standards-Version to be 3.8.1
* add build dependency on debhelper 7 (Closes: #526847)
* completely redo debian/rules with debhelper 7
* add debian/compat
* remove README.debian
* remove prerm, doubt it's needed anymore
* adopt package (Closes: #527153)
* remove dependency on bsdmainutils, remove conflict on old version,
it is over 10 years old
* add misc:Depends dependency
* version number is now 1.0.15, making this a (correct) native package
- override latest-debian-changelog-entry-changed-to-native
* add the phrase 'public domain' to d/copyright to get rid of the
lintian warning
* add Vcs-* fields
2009-05-03 - David Frey <dfrey@debian.org>
sysvbanner (1.0-14) unstable; urgency=low
* Upload with correct e-Mail address.
2009-05-01 - David Frey <david@eos.eos.lugs.ch>
sysvbanner (1.0-13) unstable; urgency=low
* update to standard version 3.8.1.0
* handle nostrip option (closes: #438083)
* change permissions of debian/files and debian/substvars
* orphaned package
2003-02-16 - David Frey <dfrey@debian.org>
sysvbanner (1.0-12) unstable; urgency=low
* renamed <strings.h> to <string.h> include to fix compiler warning
* do not set link to /usr/doc in postinst (fixes lintian bug)
* make it a foreign Debian package, by creating an "original" .tar.gz
out of the original shell archive (sysvbanner was posted to
comp.sources.misc, Volume 3, Issue 71) (closes: #44247)
2002-08-24 - David Frey <dfrey@debian.org>
sysvbanner (1.0-11) unstable; urgency=low
* updated standard version, strip binary on install
2001-01-07 - David Frey <dfrey@debian.org>
sysvbanner (1.0-10) unstable; urgency=low
* recompile for woody
1999-10-10 - David Frey <dfrey@debian.org>
sysvbanner (1.0-9) unstable; urgency=low
* adapted to follow FHS (rules and Makefile updated).
1999-05-15 - David Frey <dfrey@debian.org>
sysvbanner (1.0-8) unstable; urgency=low
* recompile for potato.
* renamed changelog to changelog.Debian
1998-02-10 - David Frey <dfrey@debian.org>
sysvbanner (1.0-7) unstable; urgency=low
* fixed bugs reported by lintian: md5sums-file starting with dot.
* changed maintainer address to official Debian address.

See Also

Package Description
sysvinit-core_2.93-8_amd64.deb System-V-like init utilities
sysvinit-utils_2.93-8_amd64.deb System-V-like utilities
t-code-common_2.3.1-8_all.deb Japanese direct input method environment - common files
t-code_2.3.1-8_all.deb Japanese direct input method environment for emacsen
t-coffee-examples_12.00.7fb08c2-4_all.deb annotated examples for the use of T-Coffee
t-coffee_12.00.7fb08c2-4_amd64.deb Multiple Sequence Alignment
t-prot_3.4-4_all.deb display filter for Internet messages
t1-cyrillic_4.17_all.deb A basic set of free PostScript fonts
t1-oldslavic_4.17_all.deb OldSlavic -- a Cyrillic Type1 font with medieval design
t1-teams_4.17_all.deb Teams -- a PostScript font covering ASCII and basic Cyrillic
t1utils_1.41-3_amd64.deb Collection of simple Type 1 font manipulation programs
t2html_2016.1020+git294e8d7-1_all.deb text to HTML converter implemented in Perl
t2n_0.6-6_amd64.deb Simple command-line tool for LEGO Mindstorms NXT
t3highlight_0.4.6-1_amd64.deb Command-line syntax highligher
t50_5.8.3-2_amd64.deb Multi-protocol packet injector tool
Advertisement
Advertisement