ruby-version-sorter_2.1.0+dfsg-1+b2_amd64.deb


Advertisement

Description

ruby-version-sorter - fast sorting of version strings

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main amd64
Package filename ruby-version-sorter_2.1.0+dfsg-1+b2_amd64.deb
Package name ruby-version-sorter
Package version 2.1.0+dfsg
Package release 1+b2
Package architecture amd64
Package type deb
Category ruby
Homepage http://github.com/defunkt/version_sorter
License -
Maintainer Debian Ruby Extras Maintainers <pkg-ruby-extras-maintainers@lists.alioth.debian.org>
Download size 6.54 KB
Installed size 30.00 KB
Used to sort version strings faster. It is used to sort a repository's
tags. It is used as follows
require 'version_sorter'
versions = %w( 1.0.9 2.0 1.0.10 1.0.3 )
VersionSorter.rsort(versions) # => ["2.0", "1.0.10", "1.0.9", "1.0.3"]
VersionSorter.sort(versions)  # => ["1.0.3", "1.0.9", "1.0.10", "2.0"]

Alternatives

Package Version Architecture Repository
ruby-version-sorter_2.1.0+dfsg-1+b2_i386.deb 2.1.0+dfsg i386 Debian Main
ruby-version-sorter - - -

Requires

Name Value
libc6 >= 2.4
libgmp10 -
libruby2.5 >= 2.5.0~preview1
ruby >= 1:2.5~0
ruby << 1:2.6~

Download

Type URL
Mirror ftp.br.debian.org
Binary Package ruby-version-sorter_2.1.0+dfsg-1+b2_amd64.deb
Source Package ruby-version-sorter

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby-version-sorter deb package:
    # sudo apt-get install ruby-version-sorter

Files

Path
/usr/lib/x86_64-linux-gnu/ruby/vendor_ruby/2.5.0/version_sorter.so
/usr/share/doc/ruby-version-sorter/README.md
/usr/share/doc/ruby-version-sorter/changelog.Debian.amd64.gz
/usr/share/doc/ruby-version-sorter/changelog.Debian.gz
/usr/share/doc/ruby-version-sorter/copyright
/usr/share/rubygems-integration/2.5.0/specifications/version_sorter-2.1.0.gemspec

Changelog

2016-09-12 - Pirate Praveen <praveen@debian.org>
ruby-version-sorter (2.1.0+dfsg-1) unstable; urgency=medium
* Team upload
* New upstream release
* use github.com url in watch
2015-03-31 - Miguel Landaeta <nomadium@debian.org>
ruby-version-sorter (2.0.0+dfsg-2) unstable; urgency=medium
* Team upload.
* Don't install binaries that conflict with another packages.
(Closes: #781570).
2015-03-06 - Balasankar C <balasankarc@autistici.org>
ruby-version-sorter (2.0.0+dfsg-1) unstable; urgency=medium
* Upstream update
2014-10-27 - Balasankar C <balasankarc@autistici.org>
ruby-version-sorter (1.1.0+dfsg-1) unstable; urgency=medium
* Initial release (Closes: #767073)

See Also

Package Description
ruby-versionist_1.7.0-1_all.deb version for Rails based RESTful APIs
ruby-versionomy_0.5.0-2_all.deb Generalized version number class for Ruby
ruby-virtus_1.0.5-3_all.deb attributes on steroids for plain old Ruby objects
ruby-vmstat_2.3.0-2+b1_amd64.deb library to gather system information
ruby-warden_1.2.3-2_all.deb Rack middleware that provides authentication for rack applications
ruby-wavefile_0.6.0-2_all.deb Pure Ruby library for reading and writing Wave sound files (*.wav)
ruby-web-console_3.6.2-2_all.deb Ruby on Rails debugger
ruby-webfinger_1.0.2-2_all.deb Ruby WebFinger client library
ruby-webkit2-gtk_3.3.2-1_all.deb WebKitGTK+ bindings for the Ruby language
ruby-webmock_3.4.2-1_all.deb library for stubbing HTTP requests in Ruby
ruby-webpack-rails_0.9.11+git-1_all.deb Webpack & Rails integration made easier
ruby-webrobots_0.1.2-1_all.deb Library for creating robots.txt-aware web robots
ruby-websocket-driver_0.6.3-2+b2_amd64.deb WebSocket protocol handler with pluggable I/O
ruby-websocket-extensions_0.1.2-1_all.deb Generic extension manager for WebSocket connections
ruby-websocket_1.2.8-2_all.deb Universal Ruby library to handle WebSocket protocol
Advertisement
Advertisement