ruby-vcr_4.0.0-1_all.deb


Advertisement

Description

ruby-vcr - Record and replay HTTP interactions (Ruby library)

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main amd64
Package filename ruby-vcr_4.0.0-1_all.deb
Package name ruby-vcr
Package version 4.0.0
Package release 1
Package architecture all
Package type deb
Category ruby
Homepage https://relishapp.com/vcr/vcr/docs
License -
Maintainer Debian Ruby Extras Maintainers <pkg-ruby-extras-maintainers@lists.alioth.debian.org>
Download size 51.39 KB
Installed size 213.00 KB
Record your test suite's HTTP interactions and replay them during future test
runs for fast, deterministic, accurate tests.
* Automatically records and replays your HTTP interactions with minimal
setup/configuration code.
* Supports and works with the HTTP stubbing facilities of multiple libraries.
Currently, the following are supported:
* WebMock
* Typhoeus
* Faraday
* Excon
* Supports multiple HTTP libraries:
* Patron (when using WebMock)
* Curb (when using WebMock -- only supports Curl::Easy at the moment)
* HTTPClient (when using WebMock)
* em-http-request (when using WebMock)
* Net::HTTP (when using WebMock)
* Typhoeus (Typhoeus::Hydra, but not Typhoeus::Easy or Typhoeus::Multi)
* Excon
* Faraday
* And of course any library built on Net::HTTP, such as Mechanize, HTTParty
or Rest Client
* Request matching is configurable based on HTTP method, URI, host, path, body
and headers, or you can easily implement a custom request matcher to handle
any need.
* The same request can receive different responses in different tests--just
use different cassettes.
* The recorded requests and responses are stored on disk in a serialization
format of your choice (currently YAML and JSON are built in, and you can
easily implement your own custom serializer) and can easily be inspected and
edited.
* Dynamic responses are supported using ERB.
* Optionally re-records cassettes on a configurable regular interval to keep
them fresh and current.
* Disables all HTTP requests that you don't explicitly allow.
* Simple Cucumber integration is provided using tags.
* Includes convenient RSpec macros and integration with RSpec 2 metadata.
* Known to work well with many popular Ruby libraries including RSpec 1 & 2,
Cucumber, Test::Unit, Capybara, Mechanize, Rest Client and HTTParty.
* Includes Rack and Faraday middleware.

Alternatives

Package Version Architecture Repository
ruby-vcr_4.0.0-1_all.deb 4.0.0 all Debian Main
ruby-vcr - - -

Requires

Name Value
ruby -
ruby-interpreter -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package ruby-vcr_4.0.0-1_all.deb
Source Package ruby-vcr

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby-vcr deb package:
    # sudo apt-get install ruby-vcr

Files

Path
/usr/lib/ruby/vendor_ruby/vcr.rb
/usr/lib/ruby/vendor_ruby/vcr/cassette.rb
/usr/lib/ruby/vendor_ruby/vcr/configuration.rb
/usr/lib/ruby/vendor_ruby/vcr/deprecations.rb
/usr/lib/ruby/vendor_ruby/vcr/errors.rb
/usr/lib/ruby/vendor_ruby/vcr/library_hooks.rb
/usr/lib/ruby/vendor_ruby/vcr/linked_cassette.rb
/usr/lib/ruby/vendor_ruby/vcr/request_handler.rb
/usr/lib/ruby/vendor_ruby/vcr/request_ignorer.rb
/usr/lib/ruby/vendor_ruby/vcr/request_matcher_registry.rb
/usr/lib/ruby/vendor_ruby/vcr/structs.rb
/usr/lib/ruby/vendor_ruby/vcr/version.rb
/usr/lib/ruby/vendor_ruby/vcr/cassette/erb_renderer.rb
/usr/lib/ruby/vendor_ruby/vcr/cassette/http_interaction_list.rb
/usr/lib/ruby/vendor_ruby/vcr/cassette/migrator.rb
/usr/lib/ruby/vendor_ruby/vcr/cassette/persisters.rb
/usr/lib/ruby/vendor_ruby/vcr/cassette/serializers.rb
/usr/lib/ruby/vendor_ruby/vcr/cassette/persisters/file_system.rb
/usr/lib/ruby/vendor_ruby/vcr/cassette/serializers/compressed.rb
/usr/lib/ruby/vendor_ruby/vcr/cassette/serializers/json.rb
/usr/lib/ruby/vendor_ruby/vcr/cassette/serializers/psych.rb
/usr/lib/ruby/vendor_ruby/vcr/cassette/serializers/syck.rb
/usr/lib/ruby/vendor_ruby/vcr/cassette/serializers/yaml.rb
/usr/lib/ruby/vendor_ruby/vcr/library_hooks/excon.rb
/usr/lib/ruby/vendor_ruby/vcr/library_hooks/faraday.rb
/usr/lib/ruby/vendor_ruby/vcr/library_hooks/typhoeus.rb
/usr/lib/ruby/vendor_ruby/vcr/library_hooks/typhoeus_0.4.rb
/usr/lib/ruby/vendor_ruby/vcr/library_hooks/webmock.rb
/usr/lib/ruby/vendor_ruby/vcr/middleware/excon.rb
/usr/lib/ruby/vendor_ruby/vcr/middleware/faraday.rb
/usr/lib/ruby/vendor_ruby/vcr/middleware/rack.rb
/usr/lib/ruby/vendor_ruby/vcr/middleware/excon/legacy_methods.rb
/usr/lib/ruby/vendor_ruby/vcr/tasks/vcr.rake
/usr/lib/ruby/vendor_ruby/vcr/test_frameworks/cucumber.rb
/usr/lib/ruby/vendor_ruby/vcr/test_frameworks/rspec.rb
/usr/lib/ruby/vendor_ruby/vcr/util/hooks.rb
/usr/lib/ruby/vendor_ruby/vcr/util/internet_connection.rb
/usr/lib/ruby/vendor_ruby/vcr/util/logger.rb
/usr/lib/ruby/vendor_ruby/vcr/util/variable_args_block_caller.rb
/usr/lib/ruby/vendor_ruby/vcr/util/version_checker.rb
/usr/share/doc/ruby-vcr/changelog.Debian.gz
/usr/share/doc/ruby-vcr/changelog.gz
/usr/share/doc/ruby-vcr/copyright
/usr/share/rubygems-integration/all/specifications/vcr-4.0.0.gemspec

Changelog

2018-12-03 - Mathieu Parent <sathieu@debian.org>
ruby-vcr (4.0.0-1) unstable; urgency=medium
* Initial release (Closes: #695195)

See Also

Package Description
ruby-version-sorter_2.1.0+dfsg-1+b2_amd64.deb fast sorting of version strings
ruby-versionist_1.7.0-1_all.deb version for Rails based RESTful APIs
ruby-versionomy_0.5.0-2_all.deb Generalized version number class for Ruby
ruby-virtus_1.0.5-3_all.deb attributes on steroids for plain old Ruby objects
ruby-vmstat_2.3.0-2+b1_amd64.deb library to gather system information
ruby-warden_1.2.3-2_all.deb Rack middleware that provides authentication for rack applications
ruby-wavefile_0.6.0-2_all.deb Pure Ruby library for reading and writing Wave sound files (*.wav)
ruby-web-console_3.6.2-2_all.deb Ruby on Rails debugger
ruby-webfinger_1.0.2-2_all.deb Ruby WebFinger client library
ruby-webkit2-gtk_3.3.2-1_all.deb WebKitGTK+ bindings for the Ruby language
ruby-webmock_3.4.2-1_all.deb library for stubbing HTTP requests in Ruby
ruby-webpack-rails_0.9.11+git-1_all.deb Webpack & Rails integration made easier
ruby-webrobots_0.1.2-1_all.deb Library for creating robots.txt-aware web robots
ruby-websocket-driver_0.6.3-2+b2_amd64.deb WebSocket protocol handler with pluggable I/O
ruby-websocket-extensions_0.1.2-1_all.deb Generic extension manager for WebSocket connections
Advertisement
Advertisement