ruby-httparty_0.16.2+dfsg1-2_all.deb


Advertisement

Description

ruby-httparty - quick web service consumption from any Ruby class

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main amd64
Package name ruby-httparty
Package version 0.16.2+dfsg1
Package release 2
Package architecture all
Package type deb
Installed size 144 B
Download size 34.56 KB
Official Mirror ftp.br.debian.org
HTTParty is a Ruby library to build easily classes that can use
Web-based APIs and related services. At its simplest, the
HTTParty module is included within a class, which gives the class a
"get" method that can retrieve data over HTTP. Further directives,
however, instruct HTTParty to parse results (XML, JSON, and so on),
define base URIs for the requests, and define HTTP authentication
information.

Alternatives

Package Version Architecture Repository
ruby-httparty_0.16.2+dfsg1-2_all.deb 0.16.2+dfsg1 all Debian Main
ruby-httparty - - -

Requires

Name Value
ruby -
ruby interpreter
ruby-multi json
ruby-multi xml

Download

Type URL
Binary Package ruby-httparty_0.16.2+dfsg1-2_all.deb
Source Package ruby-httparty

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby-httparty deb package:
    # sudo apt-get install ruby-httparty

Files

Path
/usr/bin/httparty
/usr/lib/ruby/vendor_ruby/httparty.rb
/usr/lib/ruby/vendor_ruby/httparty/connection_adapter.rb
/usr/lib/ruby/vendor_ruby/httparty/cookie_hash.rb
/usr/lib/ruby/vendor_ruby/httparty/exceptions.rb
/usr/lib/ruby/vendor_ruby/httparty/hash_conversions.rb
/usr/lib/ruby/vendor_ruby/httparty/module_inheritable_attributes.rb
/usr/lib/ruby/vendor_ruby/httparty/net_digest_auth.rb
/usr/lib/ruby/vendor_ruby/httparty/parser.rb
/usr/lib/ruby/vendor_ruby/httparty/request.rb
/usr/lib/ruby/vendor_ruby/httparty/response.rb
/usr/lib/ruby/vendor_ruby/httparty/version.rb
/usr/lib/ruby/vendor_ruby/httparty/logger/apache_formatter.rb
/usr/lib/ruby/vendor_ruby/httparty/logger/curl_formatter.rb
/usr/lib/ruby/vendor_ruby/httparty/logger/logger.rb
/usr/lib/ruby/vendor_ruby/httparty/request/body.rb
/usr/lib/ruby/vendor_ruby/httparty/request/multipart_boundary.rb
/usr/lib/ruby/vendor_ruby/httparty/response/headers.rb
/usr/share/doc/ruby-httparty/README.md
/usr/share/doc/ruby-httparty/changelog.Debian.gz
/usr/share/doc/ruby-httparty/changelog.gz
/usr/share/doc/ruby-httparty/copyright
/usr/share/doc/ruby-httparty/examples/README.md
/usr/share/doc/ruby-httparty/examples/aaws.rb
/usr/share/doc/ruby-httparty/examples/basic.rb
/usr/share/doc/ruby-httparty/examples/crack.rb
/usr/share/doc/ruby-httparty/examples/custom_parsers.rb
/usr/share/doc/ruby-httparty/examples/delicious.rb
/usr/share/doc/ruby-httparty/examples/google.rb
/usr/share/doc/ruby-httparty/examples/headers_and_user_agents.rb
/usr/share/doc/ruby-httparty/examples/logging.rb
/usr/share/doc/ruby-httparty/examples/nokogiri_html_parser.rb
/usr/share/doc/ruby-httparty/examples/rescue_json.rb
/usr/share/doc/ruby-httparty/examples/rubyurl.rb
/usr/share/doc/ruby-httparty/examples/stackexchange.rb
/usr/share/doc/ruby-httparty/examples/stream_download.rb
/usr/share/doc/ruby-httparty/examples/tripit_sign_in.rb
/usr/share/doc/ruby-httparty/examples/twitter.rb
/usr/share/doc/ruby-httparty/examples/whoismyrep.rb
/usr/share/man/man1/httparty.1.gz
/usr/share/rubygems-integration/all/specifications/httparty-0.16.2.gemspec

Changelog

2018-11-16 - Pirate Praveen <praveen@debian.org>
ruby-httparty (0.16.2+dfsg1-2) unstable; urgency=medium
* Team upload
* Disable tests that fail with OpenSSL 1.1.1 (Closes: #912239)
2018-08-16 - Cédric Boutillier <boutil@debian.org>
ruby-httparty (0.16.2+dfsg1-1) unstable; urgency=medium
* New upstream version 0.16.2+dfsg1
+ Repack to remove nonfree spec/fixtures/google.html
* Use https for homepage (updated) and copyright format
* Move debian/watch to gemwatch.debian.net
* Bump debhelper compatibility level to 11
* Bump Standards-Version to 4.2.0 (no changes needed)
* Use salsa.debian.org in Vcs-* fields
* Refresh skip_failing_test.patch
* Add replacement for the removed google.html fixture file
* Add encoding.patch, forcing encoding to UTF-8 to fix tests on default
build environments
2017-12-26 - Cédric Boutillier <boutil@debian.org>
ruby-httparty (0.15.6-1) unstable; urgency=medium
* Reupload to unstable
* Bump Standards-Version to 4.1.2 (no changes needed)
* Use https in watch file
2017-11-25 - Cédric Boutillier <boutil@debian.org>
ruby-httparty (0.15.6-1~exp1) experimental; urgency=medium
* New upstream version 0.15.6
* Bump Standards-Version to 4.1.1 (no changes needed)
* Bump debhelper compatibility level to 10
* Refresh skip_failing_test.patch
* New patch git-in-gemspecs.patch to remove use of git in gemspecs
* Build-depend on ruby-webmock
* Use DEB_VERSION_UPSTREAM instead of parsing changelog
* Test gem dependencies when running tests 
2017-11-25 - Cédric Boutillier <boutil@debian.org>
ruby-httparty (0.13.7-2) unstable; urgency=medium
* Relax dependency version in gem dependency on json.
This fixes loading httparty with the gem command (Closes: #864723)
2016-06-07 - Cédric Boutillier <boutil@debian.org>
ruby-httparty (0.13.7-1) unstable; urgency=medium
* Imported Upstream version 0.13.7
* Bump debhelper compatibility level to 9
* Remove version in the gem2deb build-dependency
* Use https:// in Vcs-* fields
* Bump Standards-Version to 3.9.8 (no changes needed)
* Run wrap-and-sort on packaging files
* Set Testsuite field to autopkgtest-pkg-ruby
2015-07-05 - Cédric Boutillier <boutil@debian.org>
ruby-httparty (0.13.5-1) unstable; urgency=medium
* Reupload to unstable.
2015-05-25 - Cédric Boutillier <boutil@debian.org>
ruby-httparty (0.13.5-1~exp1) experimental; urgency=medium
* Imported Upstream version 0.13.5
+ now uses rspec3
+ upload to experimental until rspec3 is in unstable
* skip all old patches, add skip_failing_test.patch
* bump Standards-Version to 3.9.6
* add build-dep on ruby-simplecov
* remove coverage/ dir upon cleaning
* wrap and sort fields in debian/control
2014-06-16 - Cédric Boutillier <boutil@debian.org>
ruby-httparty (0.13.0-2) unstable; urgency=medium
* Add spec_convert_nil_to_empty_string.patch to fix a FTBFS caused by the
addition of a string with nil in a test. (Closes: #747734)
2014-02-28 - Cédric Boutillier <boutil@debian.org>
ruby-httparty (0.13.0-1) unstable; urgency=medium
* Imported Upstream version 0.13.0
* Refresh clean_spec_helper.patch and newer_rspec.patch
* Add exception_spec.patch to adapt a new spec to RSpec 2.0

See Also

Package Description
ruby-httpauth_0.2.1+gh-1_all.deb Ruby library for the HTTP authentication protocol (RFC 2617)
ruby-httpclient_2.8.3-2_all.deb HTTP client library for ruby
ruby-i18n-inflector-rails_1.0.7-4_all.deb I18n Inflector bindings for Rails
ruby-i18n-inflector_2.6.7-1_all.deb enhance i18n backend with inflections
ruby-i18n_1.5.3-1_all.deb I18n and localization solution for Ruby
ruby-icalendar_2.4.1-2_all.deb ruby implementation of the iCalendar specification (RFC-5545)
ruby-ice-cube_0.12.1-1_all.deb Ruby Date Recurrence Library
ruby-ice-nine_0.11.2-1_all.deb Ruby module to deep freeze objects
ruby-image-science_1.3.0-1_all.deb Clean Ruby library to provide simple transformations on images
ruby-in-parallel_0.1.17-1_all.deb lightweight Ruby library with very simple syntax for parallelization
ruby-indentation_0.1.1-2_all.deb Ruby extensions for Array and String classes
ruby-inflecto_0.0.2-1_all.deb Ruby library to transform words from singular to plural
ruby-influxdb_0.2.3-2_all.deb library for InfluxDB
ruby-iniparse_1.4.2-1_all.deb library for parsing INI documents
ruby-inline_3.12.4-2_all.deb Ruby library for embedding C/C++ external module code
Advertisement
Advertisement