ruby-fftw3_1.0.2-2_amd64.deb


Advertisement

Description

ruby-fftw3 - Ruby interface to the FFTW Ver.3 library

Property Value
Distribution Debian 10 (Buster)
Repository Debian Main amd64
Package filename ruby-fftw3_1.0.2-2_amd64.deb
Package name ruby-fftw3
Package version 1.0.2
Package release 2
Package architecture amd64
Package type deb
Category ruby
Homepage http://ruby.gfd-dennou.org/products/ruby-fftw3/
License -
Maintainer Debian Ruby Extras Maintainers <pkg-ruby-extras-maintainers@lists.alioth.debian.org>
Download size 11.86 KB
Installed size 52.00 KB
Ruby-FFTW3 is the Ruby interface to the FFTW Ver.3 library.
Features:
- Use NArray, which is an efficient multi-dimensional numeric array
class for Ruby
- Multi-dimensional complex FFT.(Real data are coerced to complex)
- Supports both double and single float transforms.
- Not normalized as in FFTW

Alternatives

Package Version Architecture Repository
ruby-fftw3_1.0.2-2_i386.deb 1.0.2 i386 Debian Main
ruby-fftw3 - - -

Requires

Name Value
libc6 >= 2.4
libfftw3-double3 >= 3.3.5
libfftw3-single3 >= 3.3.5
libgmp10 -
libruby2.5 >= 2.5.0~preview1
ruby << 1:2.6~
ruby >= 1:2.5~0
ruby-narray -

Download

Type URL
Mirror ftp.br.debian.org
Binary Package ruby-fftw3_1.0.2-2_amd64.deb
Source Package ruby-fftw3

Install Howto

  1. Update the package index:
    # sudo apt-get update
  2. Install ruby-fftw3 deb package:
    # sudo apt-get install ruby-fftw3

Files

Path
/usr/lib/ruby/vendor_ruby/numru/fftw3.rb
/usr/lib/ruby/vendor_ruby/numru/fftw3/version.rb
/usr/lib/x86_64-linux-gnu/ruby/vendor_ruby/2.5.0/numru/fftw3/fftw3.so
/usr/share/doc/ruby-fftw3/changelog.Debian.gz
/usr/share/doc/ruby-fftw3/changelog.gz
/usr/share/doc/ruby-fftw3/copyright
/usr/share/rubygems-integration/2.5.0/specifications/ruby-fftw3-1.0.2.gemspec

Changelog

2018-07-10 - Youhei SASAKI <uwabami@gfd-dennou.org>
ruby-fftw3 (1.0.2-2) unstable; urgency=medium
* d/control: Bump compat 11
* d/control: Swap Maintainer, Uploaders for Team maint.
* d/copyright: Fix insecure URL, Bump year
* d/watch: use gemwatch
* d/control: Bump Standard-Version 4.1.5
* d/control: Update Vcs-{Git,Browser}. use salsa
2016-08-21 - Youhei SASAKI <uwabami@gfd-dennou.org>
ruby-fftw3 (1.0.2-1) unstable; urgency=medium
* Use gemwatch as upstream
* Drop File-excluded
* Imported Upstream version 1.0.2
* Drop unneeded patch
2016-07-21 - Youhei SASAKI <uwabami@gfd-dennou.org>
ruby-fftw3 (1.0.1-1) unstable; urgency=medium
* Imported Upstream version 1.0.1
* Update debian/copyright
- Add Files-Excluded entry:
Upstream source contains two gemspec files.
This cause error build/clean processes.
- Update copyright year
* Refresh patches
* Drop documents install, removed upstream
2016-07-07 - Youhei SASAKI <uwabami@gfd-dennou.org>
ruby-fftw3 (0.4.2-3) unstable; urgency=medium
[ Cédric Boutillier ]
* Remove version in the gem2deb build-dependency
* Use https:// in Vcs-* fields
* Use https:// in Vcs-* fields
* Bump Standards-Version to 3.9.7 (no changes needed)
* Run wrap-and-sort on packaging files
[ Youhei SASAKI ]
* Fix invalid Depends line (Closes: #830093)
* Bump Standard version: 3.9.8
* Drop -dbg package
* Add patch: replace git execution from gemspec
2015-09-04 - Youhei SASAKI <uwabami@gfd-dennou.org>
ruby-fftw3 (0.4.2-2) unstable; urgency=medium
* Refresh patches
* Add patch: Drop RubyGems Depend
2015-07-23 - Youhei SASAKI <uwabami@gfd-dennou.org>
ruby-fftw3 (0.4.2-1) unstable; urgency=medium
* Imported Upstream version 0.4.2
* Bump Standard Version: 3.9.6
* Drop obsolete patch
2013-12-15 - Youhei SASAKI <uwabami@gfd-dennou.org>
ruby-fftw3 (0.4-6) unstable; urgency=medium
* Fix Build-Depends for Ruby2.0 support
* Rebuild against Ruby (>= 2.0), drop ruby1.8 binaries
2013-10-15 - Youhei SASAKI <uwabami@gfd-dennou.org>
ruby-fftw3 (0.4-5) unstable; urgency=low
[ Cédric Boutillier ]
* debian/control: remove obsolete DM-Upload-Allowed flag
* use canonical URI in Vcs-* fields
* debian/copyright: use DEP5 copyright-format/1.0
official URL for Format field
[ Youhei SASAKI ]
* Unapply patches after build
* Refresh patches
* Bump Standard version: 3.9.4
* Add doc-base support
* Rebuild against newer ruby-narray, support Ruby >=2.0 (Closes: #720242)
2012-11-24 - Youhei SASAKI <uwabami@gfd-dennou.org>
ruby-fftw3 (0.4-4) unstable; urgency=low
* debian/watch: fixed the URL to point to the releases page.
* debian/control: Build against newer gem2deb for support rubygems-integration
2011-07-22 - Youhei SASAKI <uwabami@gfd-dennou.org>
ruby-fftw3 (0.4-3) unstable; urgency=low
* Refactoring test suite
* Add ruby-narray to Depends

See Also

Package Description
ruby-file-tail_1.2.0-1_all.deb Ruby library for following still-growing files
ruby-filepath_0.7-1_all.deb small library to manipulate paths
ruby-filesystem_0.5-5.1+b8_amd64.deb Ruby extension for file-system information
ruby-fission_0.5.0-2_all.deb Command line tool to manage VMware Fusion VMs
ruby-fix-trinity-output_1.0.0-2_all.deb Fix output fastq files from trinityrnaseq
ruby-fixwhich_1.0.2-2_all.deb ruby module that emulates the 'which' program
ruby-flexmock_2.0.4-1_all.deb simple and flexible mock objects for testing
ruby-flipper_0.13.0-3_all.deb Feature flipper for ANYTHING
ruby-flot-rails_0.0.7-1_all.deb jQuery Flot for Rails Asset pipeline
ruby-flowdock_0.7.1-1_all.deb Ruby library for using Flowdock's API
ruby-fog-aliyun_0.3.2-2_all.deb Fog provider for Aliyun Web Services
ruby-fog-aws_3.3.0-5_all.deb module for the 'fog' gem to support Amazon Web Services
ruby-fog-core_2.1.0-3_all.deb shared classes and tests for fog providers and services
ruby-fog-google_1.8.2-1_all.deb module for the 'fog' library to support Google cloud services
ruby-fog-json_1.2.0-1_all.deb JSON parsing for fog providers
Advertisement
Advertisement